none
Exchange DAG copy queue length 9223372036854775766

    Question

  • Exchange 2010 SP2

    I have the same situation as described here in which the copy que length is set to the maximum:

    http://blogs.technet.com/b/timmcmic/archive/2012/05/30/exchange-2010-the-mystery-of-the-9223372036854775766-copy-queue.aspx

    The suggested solution is to run the following, which bypasses all saftey checks:

    Move-ActiveMailboxDatabase DAG-DB0 -ActivateOnServer DAG-2 -SkipHealthChecks -SkipActiveCopyChecks -SkipClientExperienceChecks -SkipLagChecks -MountDialOverride:BESTEFFORT

    I have attempted to move the active DB several times with the above switches, but the shell freezes and will not move past "A remote procedure call has been issued to database...". I ran it verbose and it doesn't move past "Resolved current organization", which is right after I confirm the action.  I let it sit for about 8 hours with no activity in the shell or in the event viewer.  This is present on all DBs (28) in a 2 server DAG group, and DBs are mounted, healthy copy status, healthy content index and a 0 replay queue length.  We have half as active on 1 server, and half active on the other.  Our latency is less than 1MS as both servers are located on our property, a local network with a 100Mbit connection about 1 mile apart from each other.  There are under 1000 users in the DAG, and I have attempted this on 2 different DBs each with 1 user each under 250MB size mailbox.  Any ideas on how to proceed?

    Friday, August 02, 2013 12:43 PM