locked
Windows 8 Remote desktop service not working

    Question

  • Regarding Win 8 Build 8400   - 

    Situation:

    1) ENable remote desktop from Windows 8/ verify firewall / network connection

    2) Can RDP from Windows 7 machine to the windows 8 ... but as soon as authenticated - 

    3)  RDP connection  dies after like 2 seconds.

    4) Event Viewer shows Application errors [The Desktop Window Manager has encountered a fatal error (0x8898008d)] (about 24 of them in sequence) and System Errors [The server {AAC1009F-AB33-48F9-9A21-7F5B88426A2E} did not register with DCOM within the required timeout.] as follows:

    Log Name:      Application
    Source:        Desktop Window Manager
    Date:          7/13/2012 11:48:36 AM
    Event ID:      9020
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      w8-w520
    Description:
    The Desktop Window Manager has encountered a fatal error (0x8898008d)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Desktop Window Manager" />
        <EventID Qualifiers="49152">9020</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-07-13T16:48:36.000000000Z" />
        <EventRecordID>1057</EventRecordID>
        <Channel>Application</Channel>
        <Computer>w8-w520</Computer>
        <Security />
      </System>
      <EventData>
        <Data>0x8898008d</Data>
      </EventData>
    </Event>

    Log Name:      System
    Source:        Microsoft-Windows-DistributedCOM
    Date:          7/13/2012 11:49:09 AM
    Event ID:      10010
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          NETWORK SERVICE
    Computer:      w8-w520
    Description:
    The server {AAC1009F-AB33-48F9-9A21-7F5B88426A2E} did not register with DCOM within the required timeout.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
        <EventID Qualifiers="0">10010</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8080000000000000</Keywords>
        <TimeCreated SystemTime="2012-07-13T16:49:09.695542500Z" />
        <EventRecordID>1152</EventRecordID>
        <Correlation />
        <Execution ProcessID="1000" ThreadID="3636" />
        <Channel>System</Channel>
        <Computer>w8-w520</Computer>
        <Security UserID="S-1-5-20" />
      </System>
      <EventData>
        <Data Name="param1">{AAC1009F-AB33-48F9-9A21-7F5B88426A2E}</Data>
      </EventData>
    </Event>v
    Saturday, July 14, 2012 4:38 AM

Answers

  • I am also seeing this exact same issue and have narrowed it down to being some kind of conflict with Nvidia graphics drivers for Windows 8.

    I was running Windows 7 x64 with the appropriate version of the Nvidia graphics drivers on this laptop and everything worked great.

    I did a clean install of Windows 8 and installed the Windows 8 x64 version of the Nvidia drivers and Remote Desktop started crashing with the above error.

    I uninstalled the drivers and everything worked fine.  Reinstalled the Nvidia drivers: crashed again. 

    The only way this works is to completely remove the Nvidia graphics drivers and let the default Windows 8 drivers be responsible for my GPU.   Needless to say, my graphics performance is not what it should be, but Remote Desktop now works.

    Has anyone else done any research or has any experience with this?  (Other than the "delete currently cached profile" copy-pasta).

    Thanks.

    -ttritten

    • Marked as answer by Schreibman Saturday, September 08, 2012 10:36 PM
    Saturday, September 08, 2012 10:30 AM

All replies

  • I'm seeing the same behavior here too.

    Possibly a recent update?

    Monday, July 16, 2012 2:28 PM
  • Hi,

    You may try to delete the currently cached profile, then try to log on to create a fresh profile for a test.

    The Remote Desktop works perfectly on my computer.


    Juke Chou

    TechNet Community Support

    Wednesday, July 25, 2012 9:57 AM
  • I am also seeing this exact same issue and have narrowed it down to being some kind of conflict with Nvidia graphics drivers for Windows 8.

    I was running Windows 7 x64 with the appropriate version of the Nvidia graphics drivers on this laptop and everything worked great.

    I did a clean install of Windows 8 and installed the Windows 8 x64 version of the Nvidia drivers and Remote Desktop started crashing with the above error.

    I uninstalled the drivers and everything worked fine.  Reinstalled the Nvidia drivers: crashed again. 

    The only way this works is to completely remove the Nvidia graphics drivers and let the default Windows 8 drivers be responsible for my GPU.   Needless to say, my graphics performance is not what it should be, but Remote Desktop now works.

    Has anyone else done any research or has any experience with this?  (Other than the "delete currently cached profile" copy-pasta).

    Thanks.

    -ttritten

    • Marked as answer by Schreibman Saturday, September 08, 2012 10:36 PM
    Saturday, September 08, 2012 10:30 AM
  • That 'resolved' it for me, although as mentioned "  Needless to say, my graphics performance is not what it should be, but Remote Desktop now works.".  I'll post back if I see a new driver version posted.

    For me the Nvidia drivers were on Lenovo W520.

    Saturday, September 08, 2012 10:38 PM
  • me too

    Thinkpad T420


    如果您的问题得到解答,请进行标注。http://goxia.maytide.net

    Wednesday, September 12, 2012 2:41 AM
  • I solved this problem with updating my mobile nVIDIA graphic card driver which version is 306.23~!

    If you use an nVIDIA graphic card you'd better try this~

    Regards,

    Younghwan Jang

    • Edited by Faney Saturday, September 15, 2012 12:39 PM
    Saturday, September 15, 2012 12:39 PM
  • Had the same problem, different graphics driver, uninstalled it and RDP was back in business!

    -TM


    Integrating the future into today

    Saturday, September 29, 2012 2:53 AM
  • Today, I hit the same problem, and found 306.23 NVIDIA driver for notebook works. It is for GeForce, not for quadro, however it works on my thinkpad w520 with quadro 1000m.

    29X does not work, and 302 has this remote desktop problem.

    I hope it helps.

    Tuesday, October 02, 2012 4:42 PM
  • Good to see from the responses that the vendors are updating their video drivers for W8 and that seems to be resolving this issue.

    Tuesday, October 02, 2012 4:53 PM
  • Today is the 30th of December. My fresh W8pro installation can't work with latest nVidia drivers for GF GT630 (AMD FX-8150/RAM 32GB).

    Is it the reason to uninstall W8?

    Sunday, December 30, 2012 6:49 AM
  • I am also seeing this exact same issue and have narrowed it down to being some kind of conflict with Nvidia graphics drivers for Windows 8.

    I was running Windows 7 x64 with the appropriate version of the Nvidia graphics drivers on this laptop and everything worked great.

    I did a clean install of Windows 8 and installed the Windows 8 x64 version of the Nvidia drivers and Remote Desktop started crashing with the above error.

    I uninstalled the drivers and everything worked fine.  Reinstalled the Nvidia drivers: crashed again. 

    The only way this works is to completely remove the Nvidia graphics drivers and let the default Windows 8 drivers be responsible for my GPU.   Needless to say, my graphics performance is not what it should be, but Remote Desktop now works.

    Has anyone else done any research or has any experience with this?  (Other than the "delete currently cached profile" copy-pasta).

    Thanks.

    -ttritten

    Thanks ttritten for the answer. But if still doesn't work, check to see if you have disabled your onboard graphic, or play around with the monitor setups. This extra step work for me.

    Tuesday, April 23, 2013 7:11 PM