locked
Internet Connection Sharing ( ICS ) not working in Windows 8 CP

    Question

  • i tried to use ICS to share my broadband so that other computers in my network can also get the internet. even though all the clients computers have their IP address from my computer ( DHCP is working ) they still cannot use the Internet.. I've done this multiple times in Windows 7 before so i know a little bit or is Windows 8 CP is different?
    Sunday, March 25, 2012 5:56 AM

All replies

  • Hi,

    1. Please update your network adapter driver from manufacturer's website manually.
    2. Verify your host computer can use Internet.
    3. Verify your client computer can ping host computer. (firewall off)
    4. You can disable firewall and security software for a test.


    Niki Han

    TechNet Community Support

    Thursday, March 29, 2012 8:35 AM
    Moderator
  • I'm having the same issue.  I'm pretty sure I'm up to date on everything.
    Thursday, March 29, 2012 2:37 PM
  • same issue here. 
    Friday, March 30, 2012 5:08 PM
  • I am having the same issue. A Win8 netbook (Everex) and Win8 laptop (Dell) will successfully connect to a wireless ad hoc network from a Win7 laptop (Toshiba) or from a WinVista desktop (HP) (Win7 & WinVista had internet access and ICS enabled), but it cannot access the internet through either (pinging works fine).

    Moreover, a Win7 laptop (HP) connecting to an Internet and ICS enabled Win8 desktop (HP) could not access the Internet through Win8.

    This involved six different computers, if you were wondering. This is clearly not a hardware / unique configuration problem.

    Any thoughts Microsoft?

    Monday, April 02, 2012 6:15 PM
  • Hi, I just tried ICS first time connecting a Win8 via another Win8 and figured, that I don't receive an IP. I configured the 2nd machine using static IP in the same range as the 1st and used the IPs of the 1st as default GW and DNS. Like that it works.
    Tuesday, April 03, 2012 6:58 PM
  • Hi,

    Please disable security software and firewall temporarily to check the result.


    Niki Han

    TechNet Community Support

    Wednesday, April 04, 2012 8:54 AM
    Moderator
  • ICS is not working here.
    This is not a firewall problem as far as I can see.
    But have tried to disable all firewall and security solutions.

    Have also tried this:

    a. disable ICS;
    b. run the following repairs;
    c. enable ICS;
    d. see if the ipconfig /all has changed.

    Reset WINSOCK entries to installation defaults: netsh winsock reset catalog
    Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log
    Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

    Done with admin priv.

    -----

    As you can also see, that "IP Routing Enabled" is :NO, but that should be Yes when ICS is enabled.

    This is a 3G connection, and does not have a default gateway that I can see. That way I can not just manual set this up at all the clients.

    Have enabled and disabled several times, plus restarts, windows update and so on... Nothing helps..

    -----

    Perhaps a BUG?
    This was working with earlier versions of Windows.
    -----

    Here is a copy from ipconfig /all

    Microsoft Windows [Version 6.2.8250]
    (c) 2012 Microsoft Corporation. All rights reserved.

    ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : kontor
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    PPP adapter Chess Internett:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Chess Internett
       Physical Address. . . . . . . . . :
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 46.212.XX.XX(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.255
       Default Gateway . . . . . . . . . : 0.0.0.0
       DNS Servers . . . . . . . . . . . : 212.169.123.67
                                           212.45.188.254
       Primary WINS Server . . . . . . . : 10.11.12.13
       Secondary WINS Server . . . . . . : 10.11.12.14
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Wired Ethernet Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controlle
    r
       Physical Address. . . . . . . . . : XX-XX-XX-XX-XX-XX
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::b12e:4126:1f81:ea6c%12(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.137.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 251662659
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-0B-EA-22-00-11-43-2D-0D-10

       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{42948317-9B4F-45F6-B476-AC733F6F76B9}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{79F9C92C-0F9F-4AFF-9493-BF195282696A}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes





    • Edited by mr4ndersen Friday, April 06, 2012 10:44 PM
    Friday, April 06, 2012 10:41 PM
  • I've the same problem, IP is not assigned.

    Same HW with Windows 7 works like a charm

    Tuesday, April 10, 2012 8:15 AM
  • The same problem. In Windows 8 CP and DP is not working ICS. The server is connected to the Internet via L2TP VPN, clients are connected through a hub, the traffic between the client and the server is and they see each other but do not have the Internet to customers. in windows 7 everything works correctly.
    Wednesday, April 11, 2012 3:18 AM
  • same problem.

    installed all updates (2012.04.12), updated all drivers from officials, disabled firewall, security essentials and....nothing. clients(win7,android,osx10.7) got proper ips 192.168.137.*, gateways,dns 192.168.137.1, from win8, but internet isn.t workin. if on client run "ping xx.xx", ip adress resolves perfectly, but its no respond. on win8-host machine internet works fine. lan working. same on host-win7-machine working.

    host-config:

    2 Network adapters

    1. with provider's cable with PPP connection

    2. link to switch (lan)

    PPP shared to local.

    Adapters in "Networking and Sharing Center" marks as unidentified network. via gpedit.msc unidentified networks set as home networks, and ICS works until reboot. now its just LAN.

    Fixed IP's on clients aren't helps.

    Temporary solution (no warranty, it works sometimes for me):

    run->services.msc->internet connection sharing->stop/start

    C:\Users\Vaseker>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Vaseker-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    PPP adapter Dom.ru:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Dom.ru
       Physical Address. . . . . . . . . :
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 92.255.170.81(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.255
       Default Gateway . . . . . . . . . : 0.0.0.0
       DNS Servers . . . . . . . . . . . : 91.144.128.3
                                           91.144.130.3
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Ethernet adapter Inet:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : D-Link DFE-520TX PCI Fast Ethernet Adapter
       Physical Address. . . . . . . . . : 00-1C-F0-D0-8B-36
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::5902:93bb:6467:d892%13(Preferred)
       Autoconfiguration IPv4 Address. . : 169.254.216.146(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 318774512
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-11-07-3A-E0-CB-4E-87-F2-8

       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Physical Address. . . . . . . . . : E0-CB-4E-87-F2-87
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.137.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . :
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{1BD25041-8537-4C25-8FAB-61FB3F393188}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{C15FE594-C4D0-4319-8A37-B8629DF8C002}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{1714D197-CF7A-402B-998E-237300BADC48}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter 6TO4 Adapter:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft 6to4 Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:5cff:aa51::5cff:aa51(Preferred)
       Default Gateway . . . . . . . . . :
       DNS Servers . . . . . . . . . . . : 91.144.128.3
                                           91.144.130.3
       NetBIOS over Tcpip. . . . . . . . : Disabled




    • Edited by Vaseker Thursday, April 12, 2012 4:43 PM
    Thursday, April 12, 2012 3:49 PM
  • And here is a solution:

    Set ics service start mode to auto(delayed)

    run->services.msc->internet connection sharing->startup type-auto(delayed)

    restart pc or stop/start service.

    this service will loaded after windows starting in about 5 minutes (on i7 960), its not immediatly start.


    • Edited by Vaseker Friday, April 13, 2012 3:33 PM
    • Proposed as answer by Niki HanModerator Tuesday, April 24, 2012 9:25 AM
    Friday, April 13, 2012 3:33 PM
  • Still not working....any help?


    Ramy Ismail

    Friday, April 13, 2012 5:20 PM
  • me too...… this is happening after applying recent updates.

    ICS stop and start didn't work.


    Update: Anything with a $ sign sharing is the problem otherwise share works just fine.
    • Edited by Mr.Kris Thursday, April 19, 2012 4:50 AM
    Thursday, April 19, 2012 2:33 AM
  • Jesus... I cannot share my Internet connection too. I have correctly set up two machines: W8 (192.168.137.1) and WXP (192.168.137.XXX). I can see and share files with WXP machine from W8; I can see and share files with W8 from WXP. I tried firewall settings ON/OFF and it doesn't matter. I tried wired/wireless connection and... it doesn't matter. Using Windows 7's ICS feature instead of Windows 8's one works fine.

    I remember having this ANNOYING problem in Windows 7 RC, but this problem magically disappeared in Windows 7 RTM. Maybe the problem is related to beta/rc OS settings. I don't know. What I do know is that I tried everything. I had abused of Google search and trying everything linked from it and NOTHING.


    • Edited by Martín.Ib Tuesday, May 01, 2012 6:07 PM IP addresses corrected
    Saturday, April 21, 2012 1:47 PM
  • Hi there... I see admins forgot its issue. But I Update this thread. Not working ICS, its you know. And I tried to avoid ICS. I try to make a Network Bridge. And when on other computer try to connect to internet its ALL OK.... But... After 2-5 mins Win 8 (host with bridge) crash to BSOD!=(

    P.S. Sorry for my English... Im from Russia.

    • Proposed as answer by GhostRiderYo Monday, May 14, 2012 10:49 AM
    Monday, May 14, 2012 10:48 AM
  • That worked for me. Cheers :)

    Edit (I mean Vaseker's solution)

    Saturday, June 02, 2012 5:42 PM
  • And here is a solution:

    Set ics service start mode to auto(delayed)

    run->services.msc->internet connection sharing->startup type-auto(delayed)

    restart pc or stop/start service.

    this service will loaded after windows starting in about 5 minutes (on i7 960), its not immediatly start.


    Thanks a lot! This helped me resolve internet connection sharing issue.

    Miscrosoft has to make a fix for this problem. It will be shame if this issue will still occur in the final version of Windows 8.

    Wednesday, June 06, 2012 12:22 PM
  •  Vaseker's solution works fine.

    But it's annoying to stop and start the service every time.

    So I found an alternative solution:

    http://www.youngzsoft.net/ccproxy/

    Cheers! :)

    Sunday, July 15, 2012 6:15 AM
  • And here is a solution:

    Set ics service start mode to auto(delayed)

    run->services.msc->internet connection sharing->startup type-auto(delayed)

    restart pc or stop/start service.

    this service will loaded after windows starting in about 5 minutes (on i7 960), its not immediatly start.


    This is still happening in Win8 Release Preview when you go to hibernation or sleep and this solution fixes it (enabling and disabling ICS service).
    Tuesday, July 17, 2012 12:51 PM
  • It works!

    Thank you!

    But why is it still a problem in RTM!!!

    Friday, November 09, 2012 6:59 AM
  • Congratu to Microsoft!...it Still there
    Friday, November 09, 2012 7:02 AM
  • I am having a similar problem on windows 8 pro on HP Probook 4530s. I am unable to share internet connection have tried all possible solutions mentioned in this thread. nothing has worked so far. pasting my ipconfig /all

    Microsoft Windows [Version 6.2.9200]
    (c) 2012 Microsoft Corporation. All rights reserved.
    C:\WINDOWS\system32>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : nom-hp
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    PPP adapter ZTE Wireless Terminal:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : ZTE Wireless Terminal
       Physical Address. . . . . . . . . :
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 119.154.235.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.255
       Default Gateway . . . . . . . . . : 0.0.0.0
       DNS Servers . . . . . . . . . . . : 8.8.8.8
                                           203.128.7.10
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Wireless LAN adapter Local Area Connection* 12:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2

       Physical Address. . . . . . . . . : 20-10-7A-43-CA-C2
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter WiFi:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8188CE 802.11b/g/n WiFi Adapte
    r
       Physical Address. . . . . . . . . : 20-10-7A-43-CA-C2
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Ethernet:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Physical Address. . . . . . . . . : E4-11-5B-51-90-7C
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::d0e0:4a78:7801:d459%12(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.137.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : fe80::ad8c:8a84:f592:4dbd%12
       DHCPv6 IAID . . . . . . . . . . . : 266604891
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-30-D9-F7-E4-11-5B-51-90-7C

       DNS Servers . . . . . . . . . . . : 8.8.8.8
                                           8.8.4.4
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{5A25CE67-970D-40B5-89B4-06FFE3222018}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter 6TO4 Adapter:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft 6to4 Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:779a:eb01::779a:eb01(Preferred)
       Default Gateway . . . . . . . . . :
       DNS Servers . . . . . . . . . . . : 8.8.8.8
                                           203.128.7.10
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:1428:1f57:8865:14fe(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::1428:1f57:8865:14fe%16(Preferred)
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 553648128
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-30-D9-F7-E4-11-5B-51-90-7C

       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter isatap.{9206D2D8-D282-43DF-9EF5-CD2E1CC1BB90}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    C:\WINDOWS\system32>
    Sunday, November 11, 2012 1:20 AM
  • Restart your internet connection sharing service.

    .....................................Dharavi.....................

    Tuesday, December 11, 2012 9:32 PM
  • As i just have found out on another forum. Some guy pointed at this and i was shocked!

    Go to run->services.msc but then, aside from checking ICS service, CHECK FOR  "Routing and Remote Access" if it's on AUTOMATIC

    It was "OFF" , not even "Manual".

    After i changed it for "Automatic" and pressed start, Internet started working.

    • Edited by col1n Tuesday, January 01, 2013 4:07 PM
    • Proposed as answer by col1n Wednesday, January 02, 2013 11:06 PM
    Tuesday, January 01, 2013 3:47 PM
  • Yes it's Working Fine but , Faced Disconnect after 2 Min

    So Could You tell me about Issue

    Tuesday, January 01, 2013 4:04 PM
  • problem solved

    I just want you to know I'm in the process of this problem from the first days of "Windows 8 beta"  and  for this I would like to thank all those who contributed to the publication of this solution                                                                     

    PEACE from ALGERIA

    Saturday, January 19, 2013 6:59 PM
  • I have tried all of the above solutions and it didn't sem to work. I have put "Routing and Remote Access" on Automatic and rebooted, afterwards put it again on Disabled and rebooted and it seemed to have fixed the ICS. I had to set again the gtaeway ip, 192.168.137.1 and netmask on the interface i was sharing through.

    BTW, "Routing and Remote Access" is a service that conflicts with ICS, so setting it on enabled it will not work unless you start configuring advanced routing.

    Monday, January 28, 2013 9:36 PM
  • HI ALL,

    i have faced the same issue in windows 8 pro. while trying to enable sharing in my Ethernet adapter it wasn't enable. it  given the error. i tried all the aspect given in forum but didnt work. So i decided to install the Ethernet adapter driver and search for it in lennovo website. post installing the drivers i can enable the sharing in Ethernet adapter. And its working fine.  try it... all the best.

    thanks

    • Proposed as answer by Ganesh021 Thursday, February 07, 2013 4:21 PM
    Thursday, February 07, 2013 4:04 PM
  • Basically, having followed all the advice on this forum I was still getting nowhere. This was made more frustrating by the fact that I got ICS to work the first time but disabled it as my connections weren't quite right.

    So two things. Firstly, even if you do set ICS to automatic in service.msc, it wont work until you physically set your wireless device to share under it's properties/sharing tab. You can then look back at ICS in services.msc and you should see that it has started.

    Secondly, if after this your cmd is still reporting "Host network could not be started", and you've done everything else, go to 'Device Manager' under Computer management. Find network adapters and there will be one called windows virtual-something, right-click and 'enable'. Then you should be able to run 'netsh wlan start hostednetwork' without any problems.

    I've no idea why windows 8 disables this in the first place, it was a big was of time trying to find the reason.

    Thanks.

    Friday, February 22, 2013 11:37 PM