none
Windows Server 2003 x64 - Erro Instalação Microsoft .Net Framework 4

    Question

  • Boa Tarde Amigos,

    Ao tentar realizar instalação do KB982671 (Microsoft .Net Framework 4), o mesmo gera os logs de erro mencionados abaixo.

    Saliento que o erro em questão ocorre tanto na instalação através do Windows Update, bem como através do instalador.

    Event Type: Error
    Event Source: Windows Update Agent
    Event Category: Installation
    Event ID: 20
    Date:  22/03/2012
    Time:  16:09:55
    User:  N/A
    Computer: DATASERVER
    Description:
    Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft .NET Framework 4 for Windows Server 2003 x64-based Systems (KB982671).

    ==========================================================================================================
    Event Type: Error
    Event Source: VSSetup
    Event Category: None
    Event ID: 5000
    Date:  22/03/2012
    Time:  16:09:48
    User:  N/A
    Computer: DATASERVER
    Description:
    EventType vssetup, P1 microsoft .net framework 4 setup, P2 4.0.30319, P3 10.0.30319.1, P4 1, P5  , P6 none_ui_silent_crash, P7 0xc0000005, P8 0, P9  , P10 NIL.

    Dese já agradeço à atenção dispensada.

    Obrigado.

    Abraços,

    Rodrigo

    Thursday, March 22, 2012 7:36 PM

Answers

  • Rodrigo, boa tarde!

    Você está instalando com o usuário que tenha permissão? O servido de instalação é iniciado? (Desculpe, mas às vezes...)

    Vamos tentar executar o procedimento abaixo;
    1 - Clique em Iniciar, digite regedit na caixa de pesquisa;

    2 - Na janela Editor do Registro, navegue até:
    HKLM \ System \ CurrentControlSet \ Services \ MSIServer

    3 - Altere o valor DisplayName para:
    C: \ WINDOWS \ SysWOW64 \ msiexec.exe / V

    4 - Feche o Editor do Registro.

    5 - Agora registrar o instalador abrindo um prompt de comando (Clique em Iniciar digite cmd na caixa de pesquisa).
    C: \ WINDOWS \ SysWOW64 \ msiexec.exe / regserver

    6. Digite Exit.

    Espero ter ajudado.

    Abs.



    Pablo Santos MCTS - ITIL E-mail/MSN: pablocpsantos@gmail.com

    Thursday, March 22, 2012 7:47 PM

All replies

  • Rodrigo, boa tarde!

    Você está instalando com o usuário que tenha permissão? O servido de instalação é iniciado? (Desculpe, mas às vezes...)

    Vamos tentar executar o procedimento abaixo;
    1 - Clique em Iniciar, digite regedit na caixa de pesquisa;

    2 - Na janela Editor do Registro, navegue até:
    HKLM \ System \ CurrentControlSet \ Services \ MSIServer

    3 - Altere o valor DisplayName para:
    C: \ WINDOWS \ SysWOW64 \ msiexec.exe / V

    4 - Feche o Editor do Registro.

    5 - Agora registrar o instalador abrindo um prompt de comando (Clique em Iniciar digite cmd na caixa de pesquisa).
    C: \ WINDOWS \ SysWOW64 \ msiexec.exe / regserver

    6. Digite Exit.

    Espero ter ajudado.

    Abs.



    Pablo Santos MCTS - ITIL E-mail/MSN: pablocpsantos@gmail.com

    Thursday, March 22, 2012 7:47 PM
  • Pablo,

    Estarei realizando o teste informado, e lhe informo os resultados.

    Um grande abraço,

    Rodrigo

    Friday, March 23, 2012 4:50 PM
  • Pablo,

    Testes efetuados com sucesso.

    Obrigado.

    Abraços,

    Rodrigo

    Thursday, March 29, 2012 7:53 PM