none
Socket Pooling FTP Service 2008 R2

    General discussion

  • My Problem is that svchost.exe is running on 0.0.0.0:21. I know how to stop socket pooling by http protocols but by ftp protocol I have problem, I didnt findy anything. 

    The microsoft ftp service is binded to all 21 port on all IP adresses. I dont know how to unbind the ftp service from all 21 port. 

    I want to use only 1 ip adress for the microsoft ftp service. The other I want to unbind from microsoft ftp service.

    I found a solution for the problem but it doesnt work.

    The solution steps are:

    Open a command prompt and navigate to the \Inetpub\adminscripts\ folder -OK
    Type net stop msftpsvc and press [ENTER] -OK
    Type the following command:
     cscript adsutil.vbs set msftpsvc/disablesocketpooling true and press [ENTER]  - [the command promt writes me the following error "Unexpected Error 0x8ffe2740 Occurred"so I cant go to the next steps] write to me unknown service
    At the command prompt type net start msftpsvc and press [ENTER]

    Check with netstat –na to confirm that TCP port 21 is now listening on one IP address instead of listening on 0.0.0.0.

    Please explain to me how to disable socket pooling only by ftp service. I don't want to modify http settings because it works well.

    I need a solution only for microsoft ftp service.

    I want to bind the ftp service only for 1 specific IP adress.

    Thanks for answers

    Regards Peter Laszlo



    Saturday, September 21, 2013 10:07 PM

All replies