none
Autorizzazioni c:\windows\system32 win 2008 standard edition R2

    Question

  • Buonasera,

    ho questo problema:

    Server con win. 2008 R2 standard edition, unico utente esistente Administrator,

    ma non ha i permessi su c:\windows\system32

    Come mai?

    C'è un modo per concederli?

    In attesa e complimentandomi con voi per il lavoro che svolgete tutti i giorni porgo

    Cordiai Saluti

    Emanuele Salati

    Tuesday, August 21, 2012 12:27 PM

Answers

  • Entra nelle proprietà della DLL, vai sulla scheda sicurezza, vai su Modifica (o Avanzate), aggiungi alla lista il tuo account inserendolo manualmente (ad esempio Admin123) e modifica le autorizzazioni.

    Per sicurezza diventa anche proprietario.

    Wednesday, August 22, 2012 1:38 PM
    Moderator
  • clicca "Edit", selezione "Administrator" e quest'ultimo verrà sostituito a TrustedInstaller

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    • Marked as answer by emanuelesalati Wednesday, August 22, 2012 2:22 PM
    Wednesday, August 22, 2012 7:45 AM
    Moderator

All replies

  • mi puoi dire quali sono i permessi che vedi impostati in questo momento su c:\windows\system32 ?

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    Tuesday, August 21, 2012 1:06 PM
    Moderator
  • Ciao Emanuele, di seguito una screen con i permessi di una installazione standard. Verificala con la tua struttura e riporta oltre a quanto richiesto da Edoardo Benusi eventuali perpessi anomali.

    Saluti

    Nino

     
    Tuesday, August 21, 2012 1:12 PM
    Moderator
  • ok, ti incollo di seguito lo Stamp:

    Tuesday, August 21, 2012 1:15 PM
  • @Edoardo, tu riesci a vedere quanto riportato nella screen?

    Emanuele, puoi postare soltanto la pagina delle proprietà e non l'intero schermo... non si vede niente.

    Saluti

    Nino


    Tuesday, August 21, 2012 1:19 PM
    Moderator
  • è corretto quanto vedi infatti gli Administrators hanno tutti i permessi ad eccezione del full control come indicato nel permesso speciale che vedi nell'immagine postata da Nino.

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    Tuesday, August 21, 2012 1:25 PM
    Moderator
  • Ciao,

    vi incollo di seguito la maschera delle "Advenced security settings":

    (è tutto uguale al post di Nino ma non capisco, perchè pur essendo Administrator non lo sono relamente?)

    Tuesday, August 21, 2012 1:41 PM
  • ... perchè pur essendo Administrator non lo sono relamente?

    In che senso?

    Spostiamo la discussione su un'altro aspetto:

    Tu che problema riscontri (a parte i permessi che sembrano corretti)?  Cosa devi fare?

    Saluti

    Nino

    Tuesday, August 21, 2012 3:27 PM
    Moderator
  • Devo sovrascrivere una .dll di blat.exe perchè va in CRASH da 8 giorni e mi dice accesso negato

    Emanuele Salati

    Wednesday, August 22, 2012 6:14 AM
  • vai su start, tutti i programmi, fai click col tasto destro su "Windows Explorer" e scegli "Run as administrator", quando si apre esplora risorse prova a sostituire la dll.

    se ancora non va, verifica che l'accesso nehato non sia dovuto al fatto che il file è in uso nel qual caso devi interrompere il processo che lo usa.

    se non va ancora, ultima possibilità, acquisisci la proprietà della system32 con l'account Administrator e sostituisci la dll.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    Wednesday, August 22, 2012 6:27 AM
    Moderator
  • Edoardo Benussi mi ha preceduto di qualche secondo (stavo ancora a  letto con il mio caffè)....

    Non sono sicuro, ma forse il file risulta aperto (in esecuzione).

    Facci sapere

    Nino



    Wednesday, August 22, 2012 6:32 AM
    Moderator
  • Buongiorno ragazzi:

    "acquisisci la proprietà della system32 con l'account Administrator "

    Come si fa?

    Grazie ancora


    Emanuele Salati

    Wednesday, August 22, 2012 6:46 AM
  • Se guardi la seconda screen che hai postato noterai il terzo tab (Owner). Prima però seguirei i passi di Edoardo Benussi 1 e 2

    Saluti

    Nino

    Wednesday, August 22, 2012 6:53 AM
    Moderator
  • Fatto i passi di Edoardo,

    ma niente (vedi di seguito)

    Ho omesso di dirvi che sono collegato in Desktop Remoto ma come Administrator (L'ho installato tutto da remoto e funziona IIS etc....)


    Emanuele Salati

    Wednesday, August 22, 2012 7:04 AM
  • assegna il full control al gruppo Administrators e acquisisci l'ownership della cartella da Advanced Security Settings -> Tab Owner.

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    Wednesday, August 22, 2012 7:14 AM
    Moderator
  • Questa è la mia situazione:


    Emanuele Salati

    Wednesday, August 22, 2012 7:32 AM
  • clicca "Edit", selezione "Administrator" e quest'ultimo verrà sostituito a TrustedInstaller

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    • Marked as answer by emanuelesalati Wednesday, August 22, 2012 2:22 PM
    Wednesday, August 22, 2012 7:45 AM
    Moderator
  • Fatto ma mi dice sempre accesso negato

    Emanuele Salati

    Wednesday, August 22, 2012 8:56 AM
  • ti sei dato anche il permesso full control ?

    esegui l'esplora risorse con "run as administrstor" ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    Wednesday, August 22, 2012 9:33 AM
    Moderator
  • Fatto, mi da ugualmente Accesso Negato

    Emanuele Salati

    Wednesday, August 22, 2012 10:04 AM
  • allego immagine:


    Emanuele Salati

    Wednesday, August 22, 2012 10:08 AM
  • Se stai cercando di sovrascrivere una DLL credo che dovresti verificare i permessi solo sul file DLL e non su tutto system32. Secondo me la DLL ha delle autorizzazioni non ereditate da system32 oppure è aperto da qualche applicazione in esecuzione.

    Verifica anche che l'account in uso sia proprio "Administrator" e non un account appartenente al gruppo "Administrators", altrimenti dovresti inserire l'account nelle autorizzazioni in modo esplicito (Windows Server 2008 richiede per sicurezza di inserire delle autorizzazioni esplicite anche se queste sono state già concesse al gruppo Administrators).

    Wednesday, August 22, 2012 1:25 PM
    Moderator
  • "altrimenti dovresti inserire l'account nelle autorizzazioni in modo esplicito"

    Come si fa? Grazie


    Emanuele Salati

    Wednesday, August 22, 2012 1:27 PM
  • Entra nelle proprietà della DLL, vai sulla scheda sicurezza, vai su Modifica (o Avanzate), aggiungi alla lista il tuo account inserendolo manualmente (ad esempio Admin123) e modifica le autorizzazioni.

    Per sicurezza diventa anche proprietario.

    Wednesday, August 22, 2012 1:38 PM
    Moderator
  • OK RISOLTO avevi ragione,

    siete stata bravissimi, veramente complimenti, vedi che in Italia c'è ancora qualcosa di bello che funziona.

    Un grande saluto a tutti ed ora che vi ho scoperto non vi lascio più.


    Emanuele Salati

    Wednesday, August 22, 2012 1:54 PM
  • Grazie per il feedback, per chiudere la domanda contrassegna come risposta il post che ti è stato utile alla risoluzione del problema.
    • Marked as answer by emanuelesalati Wednesday, August 22, 2012 2:22 PM
    • Unmarked as answer by emanuelesalati Wednesday, August 22, 2012 2:22 PM
    Wednesday, August 22, 2012 1:59 PM
    Moderator
  • Un grande saluto a tutti ed ora che vi ho scoperto non vi lascio più.

    Spero non sia una minaccia ::)
    Wednesday, August 22, 2012 3:22 PM
    Moderator
  • Un grande saluto a tutti ed ora che vi ho scoperto non vi lascio più.

    Spero non sia una minaccia ::)

    credo proprio che lo sia :-P

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    Thursday, August 23, 2012 7:02 AM
    Moderator