none
Help with Impersonation Error

    Question

  • Hi,

    I'm relatively new to SSAS and have run into an issue when attempting to process a dimension or cube from within Sql Server Management Server.  I've seen this error mentioned several times in various posts, but so far nothing I've found has directly applied to what I'm running into.

    The error is: 

    Could not load file or assembly 'System.Transactions, Version=4.0.0.0, Culture=neutral,PublicKeyToken=b77a5c561934e089' or one of its dependencies. Either a required impersonation level was not provided, or the provided impersonation level is invalid. (Exception from HRESULT: 0x80070542)

    Sql Server and Analysis Services (2012) are running on the same server and  I'm logged in as a local administrator.

    SSAS has a single database that has a Data Source defined that is using a specific account (mine) that is used for the Impersonate Account of that Data Source.

    The Impersonate Account has a sysadmin role on the local SqlServer instance.

    I've tried various accounts in various combinations but have not been able to get an account to successfully process any dimension or cube.

    I'd appreciate any help or direction in resolving this.

    Thanks,

    Jim

    Sunday, October 06, 2013 6:06 PM

Answers

  • Hi Jim,

    Please refer to the following methods to deal with this issue:

    Method 1: Re-specify the impersonation information, please refer to the steps below:

    1. Open SQL Server Manager Studio and then connect to SSAS Server instance.
    2. Expand the "Data Source" folder, right-click on the data source and select "Proprties".
    3. In the "Data Source Properties" dialog, click the "..." button on the "ImpersonateAccount" section.
    4. Specify the "User Name" and "Password". Please ensure the account have sufficient permission access to the database.

    Metod 2: We can try to configue the impersonation information by using service account, please refer to the steps below:

    1. Open SQL Server Configuration Manager, stop SQL Server Analysis Sevices service.
    2. Specify a domain account for SSAS service, and then start it.
    3. Open SQL Server Manager Studio and then connect to SSAS Server instance. Then, open the "Data Source Properties" dialog.
    4. Specify the "Use the service account" option for the impersonation information.

    If all of methods doesn't work for you, please try to re-deploy your SSAS cube to OLAP Server to see if this helps.

    Best Regards,


    Elvis Long
    TechNet Community Support

    Tuesday, October 08, 2013 5:57 AM
    Moderator