none
500 internal server error - OWA when trying to open options - Exchange 2010

    Question

  • Hello,

    I have been in the process of setting up our new exchange 2010 server and have found the following issue.  I can log into the secure OWA site without issue and can send and receive emails fine.  When i attempt to select any "option" such as set automatic replies or see all options  I receive the following error message -

    "500 internal server error there is a problem with the resource you are looking for, and cannot be displayed".

    I have verified that all required exchange servicesare running.

    I am running exchange 2010 sp3 on server 2012.

    I think it may an issue within IIS but i'm not sure

    Any help would be appreciated.

    Thanks

    Friday, August 16, 2013 3:03 PM

Answers

  • Hi,

    According to your description, there is a 500 internal server error when you select any Option in your OWA.

    Based on my research, we can try the following steps:

    1.  Check whether Virtual Directories Authentication configured properly. Enable the ECP Virtual Directory with Anonymous and Basic Authentication.

    2.  Check on the Application Pools to view whether ECP Application Pool is running on .NET Framework v4.0. It maybe the incompletely installation of Framework that causes this error.

    If so, We can try to run the following command as Administrator:

    %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

    Or change the MSExchangeECPAppPool from .NET Framework from v4.0 to v2.0. Then restart IIS.

    If you have any question, please do not hesitate to tell me.

    Hope it helps.

    Thanks,

    Winnie Liang



    Thursday, August 22, 2013 11:35 AM
  • What does the Get-ECPVirtualDirectoty | fl internalurl, externalurl show?

     However i do not think it is a misconfiguration on thiis part because entering the ECP directory on the server itself produces the same error. You could also use https://localhost/ecp if you are running the command on your Client Access Server itself.

    You could try a IISreset /NoForce, or a reboot. if that fails you might need to recreate the ECP virtualdirectory.

    new-ecpvirtualdirectory 

    http://technet.microsoft.com/en-us/library/dd351218(v=exchg.150).aspx


    Answers provided are coming from personal experience, and come with no warranty of success. I as everybody else do make mistakes.

    Monday, August 19, 2013 2:06 PM

All replies

  • It seems like you're having problems with /ecp resources. Did you try to log on to https://yourservername/ecp? 

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Damir

    Sunday, August 18, 2013 9:04 PM
  • ok i tried https://ntserver6/ecp? which is my internal server name and still get the same error. 500.21 internal server error.  I tried this on my client pc and directly on the exchange server.  Could this be an issue within IIS??
    Monday, August 19, 2013 12:34 PM
  • What does the Get-ECPVirtualDirectoty | fl internalurl, externalurl show?

     However i do not think it is a misconfiguration on thiis part because entering the ECP directory on the server itself produces the same error. You could also use https://localhost/ecp if you are running the command on your Client Access Server itself.

    You could try a IISreset /NoForce, or a reboot. if that fails you might need to recreate the ECP virtualdirectory.

    new-ecpvirtualdirectory 

    http://technet.microsoft.com/en-us/library/dd351218(v=exchg.150).aspx


    Answers provided are coming from personal experience, and come with no warranty of success. I as everybody else do make mistakes.

    Monday, August 19, 2013 2:06 PM
  • Hi,

    According to your description, there is a 500 internal server error when you select any Option in your OWA.

    Based on my research, we can try the following steps:

    1.  Check whether Virtual Directories Authentication configured properly. Enable the ECP Virtual Directory with Anonymous and Basic Authentication.

    2.  Check on the Application Pools to view whether ECP Application Pool is running on .NET Framework v4.0. It maybe the incompletely installation of Framework that causes this error.

    If so, We can try to run the following command as Administrator:

    %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

    Or change the MSExchangeECPAppPool from .NET Framework from v4.0 to v2.0. Then restart IIS.

    If you have any question, please do not hesitate to tell me.

    Hope it helps.

    Thanks,

    Winnie Liang



    Thursday, August 22, 2013 11:35 AM
  • We were having same issues on our end.  We ensured ECP virtual directories and OWA were mapped correctly.

    It turned out to be (2) for us we looked at the app pools in IIS and ECP was mapped to v4.0 for MS.NET.  We switch to 2.0 and iis restarted and it appears to be working now.

    Thanks for the info.

    Tuesday, October 08, 2013 2:28 PM
  • We had the same problem. In one Site, I have two 2010 CAS servers in an NLB array that has an Internet-facing ExternalURL. In another Site, we have a  CAS array with no ExternalURL on the OWA or ECP directories.

    I did that to force clients in the non-Internet-connected Site to get proxied instead of redirected (which would force them to authenticate twice to two different URLs; very annoying).

    Clients in the non-Internet-connected Site got the "500 Internal Server Error..." when navigating to "Options> Set Automatic Replies". I first set the ECP directories in the Internet-connected Site back to .NET 2.0, cleared browser cache, logged on again...same error. I then changed the ECP directories to 2.0 in the other Site, and that fixed the problem.

    Wednesday, April 09, 2014 1:29 PM