none
Best VM NIC Teaming configuration? (2012 R2 host, 2008 R2 guest)

    Question

  • Hi there,

    So I've got an Acer AR180 F1 server with 6 Intel 82576 NICs, running a standalone Hyper-V role on Windows Server 2012 R2 Standard. Storage is direct-attached.

    In Server Manager, I've added the first 2 physical NICs to a dynamic LACP NIC team. This is to be used for management traffic (eg. RDP to the server from my workstation).

    I want to dedicate the remaining 4 physical NICs to Hyper-V traffic.

    Initially I only had a single VM running Windows Server 2012 R2, so for each of the 4 physical NICs I created a Hyper-V Virtual Switch with SR-IOV enabled. This allowed me to go into the 2012 R2 guest and do the team there, taking advantage of SR-IOV.

    However, I now need to run a second VM on the server, running Windows Server 2008 R2.

    As I understand it, you can't do native NIC teaming in the guest when the guest is 2008 R2.

    So what I've done is:

    • delete the 4 Hyper-V Virtual Switches
    • in the host OS, create a dynamic LACP NIC team called "Hyper-V" on the 4 remaining physical NICs
    • create a Hyper-V Virtual Switch called "Hyper-V Team Switch" connected to the "Hyper-V" NIC team

    Questions:

    1. Is there a better way of doing this, or am I on the right track?
    2. I noticed when creating the Hyper-V Team Switch that I could still choose to enable SR-IOV. Is there any point in doing this? I thought that SR-IOV doesn't work for a VM when you team the NICs at the host OS level.


    Friday, January 03, 2014 12:18 AM

Answers

All replies

  • Hi ,

    1. "

      • delete the 4 Hyper-V Virtual Switches
      • in the host OS, create a dynamic LACP NIC team called "Hyper-V" on the 4 remaining physical NICs
      • create a Hyper-V Virtual Switch called "Hyper-V Team Switch" connected to the "Hyper-V" NIC team"

      You are on the right track .

      2. I am afraid ,after you create a Teaming NIC , the SR-IOV can not be used

      "Incompatibilities. The NIC teaming feature is compatible with networking capabilities in Windows Server 2012 with three exceptions:

      • SR-IOV
      • Remote Direct Memory Access (RDMA)
    • TCP Chimney"

     More information please check here :

    http://technet.microsoft.com/en-us/library/hh997031.aspx

     

    Hope this helps

    Best Regards

    Elton Ji


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    • Marked as answer by 0xCBW Thursday, January 09, 2014 10:48 PM
    Monday, January 06, 2014 3:41 AM
    • 2. I am afraid ,after you create a Teaming NIC , the SR-IOV can not be used

    So the SR-IOV option that is presented to the user when adding a Hyper-V Virtual Switch to a NIC team is just a GUI bug which actually does nothing when selected?
    Wednesday, January 08, 2014 1:43 AM
    • You are on the right track .

    So performance should be okay for such a configuration even without SR-IOV?
    Wednesday, January 08, 2014 1:44 AM
  • Hi 0xCBW,

    Sorry for my clumsy word "I am afraid ,after you create a Teaming NIC , the SR-IOV can not be used ".

    Since i had seen this "This allowed me to go into the 2012 R2 guest and do the team there, taking advantage of SR-IOV " from your post , i think you want to do teaming in the VM  , am i right ?

    In the article i found the possible potential issue of what you want to do :

    "Because failover between network adapters in a virtual machine might result in traffic being sent with the MAC address of another interface, each Hyper-V switch port associated with a virtual machine that is using NIC teaming must be set to allow MAC spoofing. Because some solutions that utilize Single-Root Input/Output Virtualization (SR-IOV) do not support MAC spoofing in the hardware, NIC teaming — and particularly the failover aspects of NIC teaming — might not work when SR-IOV network adapters are present."

     Personally , the VNIC of the VM is 10GB bandwidth (teaming is not needed).

    Hope this helps

    Best Regards

    Elton Ji


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Wednesday, January 08, 2014 3:40 AM
  • Ideally I want to do teaming in the VM because that supports SR-IOV. However, I can't do this because -- as I understand it -- 2008 R2 guests don't support it.

    I believe that your warning about ensuring that MAC spoofing is enabled only applies to when NIC Teaming is done in the VM. Since I need to run a 2008 R2 guest which doesn't support this, the point is moot, isn't it...

    So, to summarise (correct me if I'm wrong):

    1. The SR-IOV option that is presented to the user when adding a Hyper-V Virtual Switch to a NIC team is just a GUI bug which actually does nothing when selected.
    2. Performance should be okay when teaming in the host OS instead of the VM, even without SR-IOV (I wonder how much different the performance is between doing teaming with SR-IOV in the VM versus teaming in the host OS without SR-IOV...)
    3. NIC teaming in the VM with SR-IOV isnt' an option because I need to run 2008 R2 guests on this hypervisor.
    Wednesday, January 08, 2014 4:58 AM
  • Hi 0xCBW,

    "The SR-IOV option that is presented to the user when adding a Hyper-V Virtual Switch to a NIC team is just a GUI bug which actually does nothing when selected."

    If you checked the SR-IOV option of the external Vswitch and enabled the "enable SR-IOV" option of hardware acceleration in vm settings , you can use powershell "get-vmnetworkadapter -vmname xxxx | fl *iov*" in HOST  to check if it is enabled .

    Best Regards

    Elton Ji


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.


    Wednesday, January 08, 2014 6:34 AM
  • It's cool, they're all zero. I think it's just a UI inconsistency. The option should be greyed-out but they leave it present for some reason.
    Thursday, January 09, 2014 10:47 PM
  • Hope you can help me here... I am doing some what of the same config... 

    I team 2 NICs with Dynamic LACP they come up active and ready to go. 

    I add the team to a virtual switch and uncheck "Allow management OS to share this network adapter" 

    I add my virtual switch to a VM and I can't connect...

    When you added your NIC team to a Virtual switch did you leave check "Allow management OS to share this network adapter"?? 

    Wednesday, September 10, 2014 7:18 PM