none
SBS 2011 Console Security Alert - "Windows Firewall is not enabled"

    Question

  • I have recently upgraded from SBS 2003 to SBS 2011 using the Swing Migration method, and all is well.  I do have one problem I have not been able to solve.  The SBS Console reports a critical security alert, indicating the Windows Firewall is not enabled, when it clearly is enabled.  Running the "Fix My Network" wizard yields not clues.  Any ideas as to how I can troubleshoot this issue?
    Thursday, April 28, 2011 9:54 AM

Answers

  • Hi,

     

    I would like to suggest you perform the following troubleshooting steps:

     

    Reset Repository

    ===========

    1. Click “Start” button, type “cmd” (without the quote) in the search box.

    2. On the program results list, right click the “cmd.exe” and choose “Run as administrator”.

    3. In the command window, type the following commands and press Enter, one by one.

     

    Net     Stop     Winmgmt

    CD     /D     %Windir%\system32\wbem

    Ren     Repository     Repository.old

    Net     Start     Winmgmt

     

    4. Restart the computer.

     

    Regards,

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, May 05, 2011 7:47 AM
    Moderator

All replies

  • Hi,

     

    Please export and backup the following registry:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MpsSvc

     

    After that, please try to download and import the new MpsSvc registry from the following link:

     

    http://cid-49401e22fd9c1bd2.office.live.com/self.aspx/.Public/MpsSvc.zip

     

    Now, please restart the SBS 2011 to check the result.

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, April 29, 2011 6:40 AM
    Moderator
  • I downloaded and applied the key as instructed, and then did a re-boot.  Unfortunately, I see no visible change.  Checking through the Control Panel/Windows Firewall, the firewall is clearly on, and yet the SBS Console gives a security alert saying that "The Windows Firewall is not enabled".  Any other suggestions?  I assume it's OK to simply leave the registry as it is now, and not bother putting the old information back.  Thanks for your help.

    Friday, April 29, 2011 7:33 PM
  • Hi,

     

    I would like to suggest you perform the following troubleshooting steps:

     

    Reset Repository

    ===========

    1. Click “Start” button, type “cmd” (without the quote) in the search box.

    2. On the program results list, right click the “cmd.exe” and choose “Run as administrator”.

    3. In the command window, type the following commands and press Enter, one by one.

     

    Net     Stop     Winmgmt

    CD     /D     %Windir%\system32\wbem

    Ren     Repository     Repository.old

    Net     Start     Winmgmt

     

    4. Restart the computer.

     

    Regards,

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, May 05, 2011 7:47 AM
    Moderator
  • Hi did you ever get this issue resolved? I am having the same message, i bought a Dell Server with SBS2011 preloaded, i keep getting the SBS 2011 Console Security Alert - "Windows Firewall is not enabled" when it clearly is, i tried the two suggestions above but neither resolved the error.
    • Edited by ChrisGr87 Friday, September 02, 2011 6:02 PM
    Friday, September 02, 2011 5:57 PM
  • Guess what? me too. The firewall is clearly running, I've even restarted it, but the console reports that it is not...

    SBS 2011, clean install (not preloaded) and migration.

    Jim

    Wednesday, March 14, 2012 7:41 AM
  • Same here !
    Thursday, March 15, 2012 9:56 AM
  • Hello,

    Please open an eleated command prompt and try the following commands:

    netsh advfirewall set AllProfiles state off
    netsh advfirewall set AllProfiles state on

    netsh firewall set opmode mode = DISABLE
    netsh firewall set opmode mode = ENABLE

    Check the state of the windows firewall in SBS console. Restart the server if required and then check again.
    We need to be sure that Base Filtering Engine service is started.


    We can also refer blog:
    http://blogs.technet.com/b/sbs/archive/2010/02/18/managing-your-firewalls-with-sbs-2008-and-windows-7.aspx
    http://technet.microsoft.com/en-us/library/cc771920(v=WS.10).aspx

    Do we get any events related to windows Firewall??

    Thanks

    Raj


    • Edited by Raj Gera Thursday, March 15, 2012 11:29 AM
    Thursday, March 15, 2012 11:20 AM
  • Thursday, March 15, 2012 2:16 PM