none
Lite Touch PE x86 loads extremely slow

    Question

  • I'm hoping to acquire some guidance regarding MDT 2010 Win PE. I have been using MDT for quite some time without problem. However, when attempting to image an x86 computer it pxe boots without trouble, the lite touch x86 wim is taking forever to load. When I state forever to load I'm talking almost a half an hour and it still wasn't completed loading.  I have imaged 64 bit machines without any problem, this only occurs with the 32 bit units. Any suggestions would be appreciated.
    Monday, April 29, 2013 2:09 PM

Answers

  • Thanks for the help. What I did was go into the registry for the WDSTFTP settings and changed the size of the block to a higher number. Restarted the server and pxe booted and connected in a snap.

    Thanks again.

    /Bob

    • Marked as answer by Burntout Tuesday, April 30, 2013 3:19 PM
    Tuesday, April 30, 2013 3:19 PM

All replies

  • How big is your LiteTouch.wim file in MB?
    Monday, April 29, 2013 2:31 PM
  • When you say "load", do you mean when it gets downloaded from the PXE server (the white bar at the bottom) before it starts up WinPE?  Have you tried imaging from the same port that you imaged an x64 machine?  Could just be a faulty cable or router unit, depending on how your imaging is setup.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Monday, April 29, 2013 2:57 PM
  • Thanks for the reply Dave.

    Yes, it's the white bar. I pxe boot, wds provides the ip and I'm prompted for x86 or x64. I select x86 and that's where it drags. I have changed ports and tried a different machine, both with the same results. I have made no changes to the share that I may attribute this to. Any suggestions are appreciated.

    /Bob

    Monday, April 29, 2013 9:25 PM
  • I'd start by taking the ISO equivalent and try booting a VM off it and see if you have the same issue.  We can see if it's PXE/WDS, networking, or the image itself and hopefully eliminate (or prove) the image.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Monday, April 29, 2013 9:29 PM
  • I'll try that when I get into work tomorrow. I'll let you know how it goes. Thanks for the help.

    /Bob

    Tuesday, April 30, 2013 12:28 AM
  • Good Morning Dave,

    What I did was burn the ISO to a dvd. Put it in the machine, not a virtual machine a Lenovo Desktop. Booted from the DVD and it loaded right up. So at least I know the boot is good. So I'm thinking it has to be something in my settings, either in WDS or MDT. Before doing this I ran a patch cord right to the switch to insure connectivity was not an issue. I'll keep digging. If you can think of anything please let me know. Thanks

    /Bob

    Tuesday, April 30, 2013 1:48 PM
  • Sounds like it might be WDS or the NIC on the WDS server.  See this thread for some possible solutions: http://social.technet.microsoft.com/Forums/en-US/mdt/thread/333d0b77-03dc-43b4-afa6-4a7c7aea521e

    Can you run network monitor on the server during a PXE boot against WDS and see if you can trace it?  Also maybe enable logging on your WDS (http://support.microsoft.com/kb/936625) to see if something is going wrong on it that you weren't aware of.  If you did a full deploy from the DVD and it worked fine, that should remove the Boot Image and the MDT Deployment Share from the scope of "what could be bad".


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, April 30, 2013 1:54 PM
  • I just checked the WDS Server and found error code 1460, TFTP. I'm trying to figure out what is causing this error. I checked the settings on the DHCP server and all appears to be ok. If you can enlighten me I would appreciate it. We're running Server 2008 R2 and all updates have been applied. I did see something about a hot fix that MS had come out with pertaining to this issue. Specifically block size. But I believe that this fix was included in the updates. 
    Tuesday, April 30, 2013 2:40 PM
  • See this thread: http://social.technet.microsoft.com/Forums/en-US/winserversetup/thread/a1246f62-6a8a-482b-9323-7e02dfeab196

    You can check to see if your packet sizes were changed to what the KB did.  But as I understand it, 1460 just means that the client stopped responding, so it may be an issue with the networking, still.  Might be time to run the network monitor and see what's going on from end to end.  Maybe your network guy can tell if you if the Server or the Client ports are having issues (like dropping a lot of packets) that may give an indication to what's wrong.


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, April 30, 2013 2:53 PM
  • Thanks for the help. What I did was go into the registry for the WDSTFTP settings and changed the size of the block to a higher number. Restarted the server and pxe booted and connected in a snap.

    Thanks again.

    /Bob

    • Marked as answer by Burntout Tuesday, April 30, 2013 3:19 PM
    Tuesday, April 30, 2013 3:19 PM