none
Desktop background using Group Policy

    Question

  • Hi Guys,

    we have set it up GP for applying desktop background as globally , we have wide laptop users .. the background wallpaper showing when user in our network. If user not in our network its showing blank. how to fix this.

    I had the setup like this.

    Path is %logonserver%/xxxxx/xxxx.jpeg

    If people not in our network the desktop backround is blank. how to get rid out .


    Thanks, Venkatesh. "Hardwork Never Fails"

    Thursday, June 27, 2013 11:52 AM

Answers

  • Try enabling this:

    Computer Configuration/Policies/Admin Templates/Network/Offline Files/<span gpmc_settingdescription="This policy setting lists network files and folders that are always available for offline use. This ensures that the specified files and folders are available offline to users of the computer.

    If you enable this policy setting, the files you enter are always available offline to users of the computer. To specify a file or folder, click Show. In the Show Contents dialog box in the Value Name column, type the fully qualified UNC path to the file or folder. Leave the Value column field blank.

    If you disable this policy setting, the list of files or folders made always available offline (including those inherited from lower precedence GPOs) is deleted and no files or folders are made available for offline use by Group Policy (though users can still specify their own files and folders for offline use).

    If you do not configure this policy setting, no files or folders are made available for offline use by Group Policy.

    Note: This setting appears in the Computer Configuration and User Configuration folders. If both policy settings are configured, the policy settings will be combined and all specified files will be available for offline use." gpmc_settingname="Specify administratively assigned Offline Files" gpmc_settingpath="Computer Configuration/Administrative Templates/Network/Offline Files" gpmc_supported="At least Windows 2000" tabindex="0">Specify
    administratively assigned Offline Files

    Add the JPG path as the offline file location.

    Alternatively, you could use Group Policy Preferences to copy the file to your clients. Then you could change the desktop wallpaper setting to the local machine.


    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 

    • Marked as answer by imvenkat Monday, July 01, 2013 6:28 AM
    Thursday, June 27, 2013 12:12 PM
  • In Group Policy Management Console, edit your background GPO. Then go to:

    Computer Configurgation/Policies/Admin Templates/Network/Offline Files. Enable: Specify administratively assigned Offline Files

    Then add a path to a jpg. EX: \\SERVER1\Share1\Images\Jpg.jpg


    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 

    • Marked as answer by imvenkat Monday, July 01, 2013 6:28 AM
    Thursday, June 27, 2013 12:49 PM

All replies

  • Try enabling this:

    Computer Configuration/Policies/Admin Templates/Network/Offline Files/<span gpmc_settingdescription="This policy setting lists network files and folders that are always available for offline use. This ensures that the specified files and folders are available offline to users of the computer.

    If you enable this policy setting, the files you enter are always available offline to users of the computer. To specify a file or folder, click Show. In the Show Contents dialog box in the Value Name column, type the fully qualified UNC path to the file or folder. Leave the Value column field blank.

    If you disable this policy setting, the list of files or folders made always available offline (including those inherited from lower precedence GPOs) is deleted and no files or folders are made available for offline use by Group Policy (though users can still specify their own files and folders for offline use).

    If you do not configure this policy setting, no files or folders are made available for offline use by Group Policy.

    Note: This setting appears in the Computer Configuration and User Configuration folders. If both policy settings are configured, the policy settings will be combined and all specified files will be available for offline use." gpmc_settingname="Specify administratively assigned Offline Files" gpmc_settingpath="Computer Configuration/Administrative Templates/Network/Offline Files" gpmc_supported="At least Windows 2000" tabindex="0">Specify
    administratively assigned Offline Files

    Add the JPG path as the offline file location.

    Alternatively, you could use Group Policy Preferences to copy the file to your clients. Then you could change the desktop wallpaper setting to the local machine.


    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 

    • Marked as answer by imvenkat Monday, July 01, 2013 6:28 AM
    Thursday, June 27, 2013 12:12 PM
  • Sorry i couldnt understand can u please gimme a clear picture on this where should i go and enablet this ??

    "Computer Configuration/Policies/Admin Templates/Network/Offline Files/<span gpmc_settingdescription="This policy setting lists network files and folders that are always available for offline use. This ensures that the specified files and folders are available offline to users of the computer"


    Thanks, Venkatesh. &quot;Hardwork Never Fails&quot;

    Thursday, June 27, 2013 12:36 PM
  • In Group Policy Management Console, edit your background GPO. Then go to:

    Computer Configurgation/Policies/Admin Templates/Network/Offline Files. Enable: Specify administratively assigned Offline Files

    Then add a path to a jpg. EX: \\SERVER1\Share1\Images\Jpg.jpg


    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 

    • Marked as answer by imvenkat Monday, July 01, 2013 6:28 AM
    Thursday, June 27, 2013 12:49 PM
  • Hi Joseph,

    Its working now. thank you so much.


    Thanks, Venkatesh. &quot;Hardwork Never Fails&quot;

    Monday, July 01, 2013 6:28 AM
  • Awesome!

    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 

    Monday, July 01, 2013 10:53 AM
  • Hey Jospeh,

    its working fine but its taking too much time while login. how to sort out this.?


    Thanks, Venkatesh. &quot;Hardwork Never Fails&quot;

    Tuesday, July 02, 2013 8:46 AM
  • Try this then:

    Use Group Policy Preferences: Files (under Computer Configuration). Create a new preference that copies the background from the share to a local folder (like C:\Users\Public\Wallpaper). Then change your background setting to point to this new local location.


    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 

    Tuesday, July 02, 2013 10:48 AM
  • I did but the same result its still slow in offline, PFA FYR..


    Thanks, Venkatesh. &quot;Hardwork Never Fails&quot;

    Wednesday, July 03, 2013 5:04 AM
  • Very odd! Can you upload a GPResult of a user getting this background setting?

    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 

    Wednesday, July 03, 2013 11:20 AM
  • Plese find the screenshot


    Thanks, Venkatesh. &quot;Hardwork Never Fails&quot;

    Thursday, July 04, 2013 7:18 AM

  • Thanks, Venkatesh. &quot;Hardwork Never Fails&quot;

    Thursday, July 04, 2013 7:19 AM
  • As a test, copy emerio.jpg to C:\Users\Public\Pictures\

    Then change the Desktop Wallpaper Name to that local path. Let me know if that makes it any faster.


    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 

    Monday, July 08, 2013 11:28 AM
  • Dear Joseph,

    I would like to tell you one thing the offline policy not working in another sites.. people complaining they could see that wall while they are in offline.. when i checked their computer i couldnt see the offline netlogon folder in Sync center in windows 7. can u suggest any idea on tis?


    Thanks, Venkatesh. &quot;Hardwork Never Fails&quot;

    Wednesday, July 10, 2013 2:12 PM
  • Did setting the picture to the local Public Folder fix the issue above?

    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 

    Wednesday, July 10, 2013 4:16 PM