none
HIDESHELL=YES Causes "Dirty Environment Found" message when Windows boots for the first time

    Question

  • I have read several posts on this topic like http://social.technet.microsoft.com/Forums/en-US/mdt/thread/36ed037b-51b1-4053-a248-46bd3ac9ecda where the Dirty Environment Found message appears, but the circumstances are a bit different in my case. 

    I have a new MDT 2012 Update 1 task sequence with a newly captured Windows 7 SP1 x86 image captured with MDT 2012 Update 1.

    If I run the task sequence with no HIDESHELL specified in CustomSettings.ini, it runs to completion with no issues.  If I set HIDESHELL=YES in CustomSettings.ini, then the StateRestore phase starts with booting to Windows 7, auto-logging in and then the task sequence continues.  At the same time, I get the Dirty Environment Found message and if I leave it alone, the task sequences completes with no errors, just with the Dirty Environment FOund message on top.

    This only happens when HIDESHELL=YES is specified in CustomSettings.ini.

    Tuesday, September 04, 2012 6:56 PM

All replies

  • A little more digging on this reveals that it is actually being caused by the Citrix On-Line Plug-In 12.1 installer.  I can change where I get the Dirty Environment prompt by moving the application install in the task sequence.   My command line is:

    CitrixOnlinePluginFull12.1.exe /noreboot /silent ENABLE_DYNAMIC_CLIENT_NAME=Yes ENABLE_SSON=Yes SERVER_LOCATION=http://citrixwebinterface.mycompany.org

    When the install begins, two command windows open and disappear very quickly and then the Durty Environment FOund prompt appears.

    There is no reboot that occurs, but omething is launching another instance of LiteTouch.wsf, which sees that LTIDirty is TRUE and prompts while the task sequence continues in the background.

    Wednesday, September 05, 2012 3:12 PM
  • Hi eschloss, Were you able to resolve it? I have exactly the same issue as yours. Need your help to make this annoying message go away.


    Anurag

    Monday, December 10, 2012 1:25 PM
  • I did not resolve the issue.  I ended up taking HIDESHELL=YES out of my Custom Settings and adding a run command line step after each reboot to run taskkill.exe /IM explorer.exe /F to kill explorer amd aachieve essentially the same goal.
    • Proposed as answer by anuragyadav Tuesday, December 11, 2012 9:57 AM
    Monday, December 10, 2012 1:34 PM
  • Thankyou! I think, i will also kill the explorer instead of using HideShell=Yes. However, I will investigate whenever i find more time and provide update.

    Anurag

    Monday, December 10, 2012 2:00 PM
  • Citrix Receiver always has issues.

    In my case, figured out that Citrix kind of likes the interactive desktop when being installed. If you hide the shell which is basically - pausing the explorer UI, it fails to proceed.

    You have couple of options:

    1. Don't use HideShell
    2. Put Citrix Receiver part of the Image (I would not really do this one)
    3. In my case, just to make sure no one from the Desktop Support or End User plays around with anything during installation - I added a wallpaper for the administrator - "DO NOT TOUCH - INSTALLATION IN PROGRESS".


    Regards, Vik Singh "If this thread answered your question, please click on "Mark as Answer"

    Tuesday, December 11, 2012 8:25 AM
  • Thanks Vikram, I tested with killing explorer with taskkill and it works great. So, for now, I am going to use HideShell=No and kill the explorer.

    Anurag

    • Proposed as answer by Ashutosh1971 Friday, March 15, 2013 12:37 PM
    Tuesday, December 11, 2012 9:58 AM