none
Exchange Transport Service Stop

    Question

  • Hi, i have exchange 2010 installed with GFI Mail essential & mail security. Recently i have uninstalled the both & install Trend Micro for testing purpose, since i have uninstalled GFI the subject service disables itself automatically. During the installation of trend micro the subject service was not starting for which i have made some changes in registry which resolves the problem. But after the trend micro the problem again begins, in event viewer i found two events:

    16023

    Microsoft Exchange couldn't start transport agents. The Microsoft Exchange Transport service will be stopped. Exception details: Failed to create type 'ContentSecurity.ExchangeAgents.GfiAvSmtpAgentFactory' from assembly 'C:\Program Files (x86)\GFI\ContentSecurity\MailSecurity\ContentSecurity.ExchangeAgents.GfiAvSmtpAgent.dll' due to error 'Invalid agent assembly path.'. : Microsoft.Exchange.Data.ExchangeConfigurationException: Failed to create type 'ContentSecurity.ExchangeAgents.GfiAvSmtpAgentFactory' from assembly 'C:\Program Files (x86)\GFI\ContentSecurity\MailSecurity\ContentSecurity.ExchangeAgents.GfiAvSmtpAgent.dll' due to error 'Invalid agent assembly path.'. ---> System.ArgumentException: Invalid agent assembly path.
       --- End of inner exception stack trace ---
       at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable.CreateAgentFactory(AgentInfo agentInfo)
       at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable..ctor(IEnumerable agents)
       at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.RuntimeSettings..ctor(MExConfiguration config, String agentGroup)
       at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.MExRuntime.Initialize(String configFile, String agentGroup, Boolean isBridgeHead, String installPath)
       at Microsoft.Exchange.Transport.Extensibility.AgentComponent.Load()

    1052


    Failed to create agent factory for the agent 'GfiAvSmtpAgent' with error 'Failed to create type 'ContentSecurity.ExchangeAgents.GfiAvSmtpAgentFactory' from assembly 'C:\Program Files (x86)\GFI\ContentSecurity\MailSecurity\ContentSecurity.ExchangeAgents.GfiAvSmtpAgent.dll' due to error 'Invalid agent assembly path.'.'. Please verify the corresponding transport agent assembly and dependencies with correct version are installed.

    There is no folder name C:\Program Files (x86)\GFI\ in the C:. i have also given the Full Control rights to the Transport Role folder, & after that now i have found this event

    1009

    The Microsoft Exchange Mail Submission service is currently unable to contact any Hub Transport servers in the local Active Directory site. The servers may be too busy to accept new connections at this time.

    The exchange transport service starts & stop,  Any idea please.

    Thanks
    Sunday, March 14, 2010 8:17 AM

All replies