none
Error al instalar SQL Server 2008 R2

    Question

  • Un saludo 

    Quisiera formular la siguiente pregunta, debido a que no conseguí información puntual respecto a la posible solución del inconveniente.

    Instalando SQL Server 2008 R2 con Servicios Avanzados para 64bits faltando un 15% para terminar la instalación aparece el siguiente mensaje: No todos los privilegios o grupos a los que se hace referencia son asignados al llamador.  y no permite llevar a feliz termino al proceso de intalación, alguna sugerencia al respecto?

     

    Muchas gracias

     

     


    Ingphillip's Prog
    Recetas ASP.NET

    Follow @Ingphillip
    Friday, December 23, 2011 3:32 AM

Answers

  • Hola.

    Revisando los logs, se observa que tienes un error al intentar invocar un componente, SQL_Engine_Core_Inst. Puedes encontrarlo al final del log que se llama "Detail.txt":

    2011-12-25 12:03:53 SQLEngine: --SqlServerServiceSCM: Waiting for nt event 'Global\sqlserverRecComplete' to be created
    2011-12-25 12:03:55 SQLEngine: --SqlServerServiceSCM: Waiting for nt event 'Global\sqlserverRecComplete' or sql process handle to be signaled
    2011-12-25 12:03:55 Slp: Configuration action failed for feature SQL_Engine_Core_Inst during timing ConfigRC and scenario ConfigRC.
    2011-12-25 12:03:55 Slp: Acceso denegado
    2011-12-25 12:03:55 Slp: The configuration failure category of current exception is ConfigurationFailure
    2011-12-25 12:03:55 Slp: Configuration action failed for feature SQL_Engine_Core_Inst during timing ConfigRC and scenario ConfigRC.
    2011-12-25 12:03:56 Slp: System.ComponentModel.Win32Exception: Acceso denegado
    2011-12-25 12:03:56 Slp:    at System.Diagnostics.ProcessManager.OpenProcess(Int32 processId, Int32 access, Boolean throwIfExited)
    2011-12-25 12:03:56 Slp:    at System.Diagnostics.Process.GetProcessHandle(Int32 access, Boolean throwIfExited)


    Esto puede ser porque los binarios que tengas estén corruptos (solución, descargarlo de nuevo) o porque estés usando una cuenta que no tiene suficientes permisos.

    Existe un KB que bien podría aplicar a tu caso, a pesar de que es para SQL Server 2008, ya que es justamente el mismo error que tu tienes. Yo lo revisaría:

    http://support.microsoft.com/kb/2000257

    Déjanos saber qué tal te fue.


    Alberto López Grande
    SQL Server MVP
    Visita mi blog en http://qwalgrande.blogspot.es/ Sígueme en twitter en http://twitter.com/qwalgrande

    Friday, December 30, 2011 10:30 AM
    Moderator

All replies

  • Hola.

    Aunque cabe pensar que no se inició la instalación con elevación de permisos o que las cuentas asignadas no posean los privilegios suficientes para ello, habría que examinar los logs de instalación para confirmarlo.

    Así, reintenta la instalación con un usuario que posea permisos de administración local y hazlo con elevación (el famoso "Run as administrator"). Si eso no lo resuelve, pásanos los logs de instalación.


    Alberto López Grande
    SQL Server MVP
    Visita mi blog en http://qwalgrande.blogspot.es/ Sígueme en twitter en http://twitter.com/qwalgrande

    Friday, December 23, 2011 8:24 AM
    Moderator
  • Hola  qwalgrande, gracias

     

    Como primera medida intenté instalarlo con derechos de administrador y continua saliendo el error.

     

    En el siguiente link te envío un comprimido con los log.

     

    Saludos.


    Ingphillip's Prog
    Recetas ASP.NET

    Follow @Ingphillip
    Sunday, December 25, 2011 5:18 PM
  • Buenas tardes y Feliz Navidad:

    Tengo el mismo problema en dos equipos diferentes (Windows 7 Home Premium + Sql Server 2008 R2) , en un tercero he probado la instalación y funciona perfectamente, incluso sin el SP1 de Windows 7.

    El primer error que nos aparecía era: “SQL server setup media does not support the language of the OS or does not have ENU localized files. Use the matching language-specific SQL Server media or change the OS locale through Control Panel.” (Hay blogs que ya hablan de este problema)

    Aunque verifique que el idioma era Español - España , tuve que cambiar el idioma a Español - Argentina y volver a dejarlo en Epañol - España para que la instalación arrancara. ¿¿???

    Al 85% de la instalación segundo error " No todos los privilegios o grupos a los que se hace referencia ........ etc etc".

    En el tercer equipo que he probado no ha hecho falta "run as Administrator" y se ha instalado correctamente.

    Saludos

     

     

    Sunday, December 25, 2011 6:48 PM
  • Trata de correr el CD de instalacion con estos parametros


    Angel R. Jimenez G.
    Software Development
    Santo Domingo
    Republica Dominicana
    My Blog
    Sunday, December 25, 2011 7:49 PM
  • Buenar tardes y gracias por vuestras sugerencias.

    Despues de intentar instalarlo con las indicaciones de Angel ha vuelto a fallar.

    Buscando, he encontrado un post donde sugeria que la instalación podia fallar sino se realizaba desde el disco C: (del Sistema Operativo), y efectivamente yo estaba intentando instalarlo desde el disco de datos G:. Achacable a tema de permisos.

    Conclusion: La instalacion de Sql Server 2008 R2 Express + Adv. Services en Windows Home Premium 7 puede fallar sino se realiza desde el disco del sistema operativo.

    Saludos y gracias de nuevo.

     

    Monday, December 26, 2011 4:44 PM
  • Hola Angel, gracias, te comento que realice el proceso tal cual lo indicas y no  hubo éxito.

     

    Sale el mismo error


    Ingphillip's Prog
    Recetas ASP.NET

    Follow @Ingphillip
    Tuesday, December 27, 2011 2:33 AM
  • Verificate este BUG
    Angel R. Jimenez G.
    Software Development
    Santo Domingo
    Republica Dominicana
    My Blog
    Tuesday, December 27, 2011 12:33 PM
  • No Angel, esto es para Server 2003 tengo Windows 7 64bits Premium, por cierto el bug que me indicas está relacionado con la hora para la cuenta Local del sistema.

     

    Gracias.


    Ingphillip's Prog
    Recetas ASP.NET

    Follow @Ingphillip
    Tuesday, December 27, 2011 4:41 PM
  • Otra idea referente a este problema amigos!?

     

    Gracias!


    Ingphillip's Prog
    Recetas ASP.NET

    Follow @Ingphillip
    Tuesday, December 27, 2011 4:42 PM
  • Hola  qwalgrande pudiste revisar los Log?

     

    Gracias de ante mano!


    Ingphillip's Prog
    Recetas ASP.NET

    Follow @Ingphillip
    Tuesday, December 27, 2011 9:20 PM
  • Hola.

    Revisando los logs, se observa que tienes un error al intentar invocar un componente, SQL_Engine_Core_Inst. Puedes encontrarlo al final del log que se llama "Detail.txt":

    2011-12-25 12:03:53 SQLEngine: --SqlServerServiceSCM: Waiting for nt event 'Global\sqlserverRecComplete' to be created
    2011-12-25 12:03:55 SQLEngine: --SqlServerServiceSCM: Waiting for nt event 'Global\sqlserverRecComplete' or sql process handle to be signaled
    2011-12-25 12:03:55 Slp: Configuration action failed for feature SQL_Engine_Core_Inst during timing ConfigRC and scenario ConfigRC.
    2011-12-25 12:03:55 Slp: Acceso denegado
    2011-12-25 12:03:55 Slp: The configuration failure category of current exception is ConfigurationFailure
    2011-12-25 12:03:55 Slp: Configuration action failed for feature SQL_Engine_Core_Inst during timing ConfigRC and scenario ConfigRC.
    2011-12-25 12:03:56 Slp: System.ComponentModel.Win32Exception: Acceso denegado
    2011-12-25 12:03:56 Slp:    at System.Diagnostics.ProcessManager.OpenProcess(Int32 processId, Int32 access, Boolean throwIfExited)
    2011-12-25 12:03:56 Slp:    at System.Diagnostics.Process.GetProcessHandle(Int32 access, Boolean throwIfExited)


    Esto puede ser porque los binarios que tengas estén corruptos (solución, descargarlo de nuevo) o porque estés usando una cuenta que no tiene suficientes permisos.

    Existe un KB que bien podría aplicar a tu caso, a pesar de que es para SQL Server 2008, ya que es justamente el mismo error que tu tienes. Yo lo revisaría:

    http://support.microsoft.com/kb/2000257

    Déjanos saber qué tal te fue.


    Alberto López Grande
    SQL Server MVP
    Visita mi blog en http://qwalgrande.blogspot.es/ Sígueme en twitter en http://twitter.com/qwalgrande

    Friday, December 30, 2011 10:30 AM
    Moderator
  • Hola muchas gracias, intente, hice de todo, pero a la final me ganó la impaciencia, conseguí un DVD con el SQL Server y aunque esto no solucionó el problema, logre la meta que era instalarlo.

     

    Tema cerrado jeje

     

    Un Saludo y Feliz año 2012


    Ingphillip's Prog
    Recetas ASP.NET

    Follow @Ingphillip
    Saturday, December 31, 2011 2:49 AM
  • Hola.

    Bueno, era una de las dos opciones que te comenté que podía estar ocurriendo, que estuvieran los binarios corruptos. Para dar el tema por cerrado, marca la entrada o entradas que te ayudaron a resolver el problema.


    Alberto López Grande
    SQL Server MVP
    Visita mi blog en http://qwalgrande.blogspot.es/ Sígueme en twitter en http://twitter.com/qwalgrande

    • Proposed as answer by hcbcel Saturday, April 27, 2013 1:35 PM
    Saturday, December 31, 2011 7:55 AM
    Moderator