none
Task Updates have been approved but not showing in schedule

    Question

  • Hi all,

    I have a team lead updating tasks (marking them 100% complete).  This is submitted to the PM for approval which is then seen in the approval centre and then approved.  This all works successfully.  However, the updated changes aren't being reflected in the schedule.  I have tried a few ways:

    - Approving as PM then opening the schedule and clicking 'Publish'

    - Setting the 'Manage Rules' to automatically publish

    Then I thought maybe the plan had to be checked back in for changes to take effect but that made no difference.  Am I just not understanding how this process works???

    Thanks,

    Ann

    Friday, July 26, 2013 4:12 PM

All replies

  • Ann,

    It might be worthwhile to check the "History" on the Approval Center and make sure the status updates are indeed published.

    If not, try checking in all projects, and select all pending updates and hit Publish.


    Prasanna Adavi,PMP,MCTS,MCITP,MCT http://thinkepm.blogspot.com

    Friday, July 26, 2013 4:27 PM
  • Hi,

    Have checked that as suggested.  The history shows the status for all is published and the info says 'complete'.  Still not showing on the published plan though - when I previewed them before approval the change showed there.

    Ann

    Friday, July 26, 2013 4:37 PM
  • Hi,

    Just to add on Prasanna's reply, please add %Complete and %Work Complete(if not added already) in your schedule in MS Project.

    Check any of the above mentioned field is marked as 100% Complete.

    It Generally happens with "Fixed Duration Task" for further details please follow this Thread.

    MS product team has confirmed this is a bug in MS Pro 2007 and 2010 fixes might be there in Office 2007 SP3 and 2010 SP2, Please check and confirm.

    Also let me know in case have doubts.


    Sachin Vashishth MCTS

    Friday, July 26, 2013 4:44 PM
  • Many thanks for the replies.  I have added %Work complete column to the schedule but unfortunately it too still shows 0% when it should say 100%.  I checked the other thread on fixed duration tasks but that seems to be a problem with differences in the two columns regarding percentages.  This suggests to me that in that case they were able to get it to update the percentages at least though not with the correct figure if you know what I mean.  In my case, I am seeing no change in the schedule although the 'preview schedule' reflects the changes.  Am I perhaps missing a step (if anyone could point me to instructions online for how this actually works that would help - finding it hard to get good instructions on the workings of project 2010 and pwa).  If I am sure that its not anything I'm doing wrong then I will investigate the fixes.

    Thanks,

    Ann

    Thursday, August 01, 2013 1:57 PM
  • Anyone able to help?
    Friday, August 02, 2013 8:47 AM
  • Ann,

    Sorry I have not had the chance to dig into details on this and help you out.

    To me, if this is the only project that you have this problem on, then there are a few possible causes:

    1. Confirm that the status manager is you (or the PM) on all the tasks. Some of the updates could be going to a different Status Manager (Project pro >> Insert column called Status Manager)

    2. Have you ever had an offline copy of this project, and then you overwrote the version on the server? If yes, this could be the reason. When you overwrite, the GUIDs of the tasks change and the whole approval process gets kind of messed up.

    3. There could be a corruption in your project plan. Before we start troubleshooting this, please let me know your responses on the the first two possibilities.


    Prasanna Adavi,PMP,MCTS,MCITP,MCT http://thinkepm.blogspot.com

    Friday, August 02, 2013 1:55 PM
  • I think that the step you are missing is that you didn't refresh PWA after task approval.

    I reproduced your issue on my side and found that when I hit F5, the tasks were displayed as 'updated' in PWA.

    Sunday, August 04, 2013 1:50 PM
  • Also check the Manage Queue to confirm the activities occurring after approval.


    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky

    Sunday, August 04, 2013 2:00 PM
  • OK - I had been working only in PWA.  I have just opened it in MS Project and there the updates are showing - all have 100% complete against them.  Yet when I check it in and open it again in pwa it is not showing any of them?  How is this possible?

    Ann

    Wednesday, August 07, 2013 10:53 AM
  • Hi,

    I have rigorously tested this problem again, just to be sure it wasn't anything I was doing wrong and it is still not working.  I found this thread which shows the same problem and it would appear that a fix is indeed required.  The thread was called 'task updates that are approved are not applying to my project' (I don't seem to be able to insert a link to it - sorry!).

    How do I go about getting the particular Hotfix that the thread references?

     

    thanks,

    Ann

    Friday, August 23, 2013 3:41 PM
  • I have encountered situations where the Approvals History page shows that updates have been processed, they are shown as being "Accepted" and "Published" but when checking the schedule in PWA the tasks are not shown as having been updated in the Published Version of the schedule, however the Draft version of the schedule shown in PWA does show the updates correctly applied. Publishing the schedule in PWA then results in the Published Schedule showing the updates.

    Is there any chance that "Published" in the Approvals "Status Update" History grid means something subtly different to "Published" as far as the schedule is concerned?

    There are occasions when different terms are used to denote the same thing in the Project Server offering "working version - read draft version" "Approval Manager - read Status Manager" "Owner - read Project Manager"

     

    Dominic Moss MAPM, MCTS, MCITP, MCT
    Wellingtone PM News
    Wellingtone EPM Site
    Wellingtone PM Recruitment

    Wednesday, October 16, 2013 8:45 PM
  • Hello,

    I have the same problem in our plataform (Project Server 2013).

    The resources lay the hours in your tasks, i approve of, i publish in the session "Status Update", but in the schedule dont display your real hours.

    Someone successfully solved this problem?

    Thursday, January 23, 2014 2:02 PM