none
Client installation on XP fails due BITS too old, but can't install BITS due newer version installed

    Question

  • On some of our Windows XP workstations, client installations fails with

    "This operating system does not contain the correct version of BITS. BITS 2.5 or later is required."

    But I can't install BITS 2.5 from KB923845 because

    "the Service Pack version of this system is newer than the update you are applying. There is no need to install this update." (translated from German)

    Part of CCMSETUP.LOG:

    <![LOG[Detected client version 4.00.6487.2000 from WMI.]LOG]!><time="10:14:57.457-120" date="09-21-2012" component="ccmsetup" context="" type="1" thread="2688" file="ccmsetup.cpp:962">
    <![LOG[Updated security on object C:\WINDOWS\ccmsetup\.]LOG]!><time="10:14:57.472-120" date="09-21-2012" component="ccmsetup" context="" type="0" thread="2688" file="ccmsetup.cpp:7971">
    <![LOG[A Fallback Status Point has not been specified.  Message with STATEID='100' will not be sent.]LOG]!><time="10:14:57.472-120" date="09-21-2012" component="ccmsetup" context="" type="1" thread="2688" file="ccmsetup.cpp:8443">
    <![LOG[Successfully started the ccmsetup service]LOG]!><time="10:14:57.472-120" date="09-21-2012" component="ccmsetup" context="" type="1" thread="3292" file="ccmsetup.cpp:2737">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\ccmsetup.exe.download]LOG]!><time="10:14:57.472-120" date="09-21-2012" component="ccmsetup" context="" type="1" thread="3292" file="ccmsetup.cpp:8174">
    <![LOG[CcmSetup is exiting with return code 0]LOG]!><time="10:14:57.472-120" date="09-21-2012" component="ccmsetup" context="" type="1" thread="3292" file="ccmsetup.cpp:9450">
    <![LOG[This operating system does not contain the correct version of BITS. BITS 2.5 or later is required.]LOG]!><time="10:14:57.816-120" date="09-21-2012" component="ccmsetup" context="" type="3" thread="1832" file="ccmsetup.cpp:1931">
    <![LOG[A Fallback Status Point has not been specified.  Message with STATEID='321' will not be sent.]LOG]!><time="10:14:57.816-120" date="09-21-2012" component="ccmsetup" context="" type="1" thread="1832" file="ccmsetup.cpp:8443">
    <![LOG[CcmSetup failed with error code 0x80004005]LOG]!><time="10:14:57.816-120" date="09-21-2012" component="ccmsetup" context="" type="1" thread="2688" file="ccmsetup.cpp:9454">
    

    BITS installation log (German):

    [bits.log]
    1.781: ================================================================================
    1.781: 2012/09/21 09:16:19.037 (local)
    1.781: e:\420df71fb133e79b88dd59\update\update.exe (version 6.2.29.0)
    1.781: Hotfix started with following command line: /passive /norestart /log:c:\bits.log 
    1.781: CheckSystem: ServicePack version Mismatch
    1.781: DoInstallation: CheckSystem Failed: 0xf06b 
    1.781: Die Service Pack-Version dieses Systems ist neuer als das Update, das Sie installieren möchten. Das Update muss nicht installiert werden.
    1.781: Update.exe extended error code = 0xf06b
    1.781: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    

    Is there anything I can do? Reinstall a later BITS package (that I was unable to find)? Somehow reset the existing BITS installation?


    Friday, September 21, 2012 8:24 AM

Answers