none
Windows 7 Autologon problems

    Question

  • Hi everyone,

    I'm deploying an UAS win7 Enterprise 64BIT image and for specific machines, we need the autologon function.

    i tried adding the regkeys mentioned on this forums:

    The user is a normal user.

    HKLM\software\Microsoft\Windows NT\CurrentVersion\Winlogon 
    AutoAdminlogon = 1
    DefaultDomainName  = .....
    DefaultPassword = password
    DefaultUserName = powerUser

    But that doesn't seem to work. I get the "other user" icon after i logged on with my Admin account.

    When I check the registry after this happend i notice that the regkeys DefaultPassword  &  DefaultUserName are renamed to the Admin account name and the Admin account password.

    When I delete the keys and repeat the procedure with NETPLWIZ (select the normal user, add the password) it works again until i log on with the admin account.

    I really need to sort this issue out because we need multiple pc's with that solution in a short period of time.

    I also tried the autologon application but that doesn't seem to work eighter.

    My question:

    How do i manage to get this working?

    Is there a known policy conflict with this ?

    Thanks in advance all,

    Kristof


    • Edited by Kristof L Thursday, August 22, 2013 7:10 AM
    Thursday, August 22, 2013 6:08 AM

All replies

  • Hi Mr.Stofke,

    You can try the following method to automatically Logon to Windows 7:

    1. Click Start, type netplwiz in then search box, and then press Enter.
    2. Uncheck the option Users must enter a user name and password to use this computer under the tab Users of User Accounts.
    3. Click Apply at the bottom.
    4. Enter the user name you wish to automatically Logon to Windows 7 when the Automatically Log On dialog box appears. And enter the current password and confirm it, and then click OK.
    5. Click OK on the User Accounts window to complete the process.

    What’s more, please refer to the Autologon tool to perform automatically Logon:

           http://technet.microsoft.com/en-us/sysinternals/bb963905.aspx

    Regards,

    Lany Zhang


    Thursday, August 22, 2013 9:34 AM
    Moderator
  • Hi Lany, Thanks for your reply!

    As stated above it works with the netplwiz tool. and i tried the autologon application as well.

    But afterwards, when i log on with my adminaccount, the autologon for the normal user account stops working.

    This is what happens:

    Admin account on the PC : Administrator, password Admin1234

    DefaultPassword = User1234                                       becomes                    Admin1234 = User1234
    DefaultUserName = User                                               becomes                   Administrator = User

    So when i don't log on with the admin account (or a runas /u:Administrator) it all works great.

    But when i logon with the admin account on any possible way: the keys change and the autologon stops working

    Br,

    Kristof

    Thursday, August 22, 2013 10:54 AM
  • Hi,

    Is it possible for me to delete the winlogon hive in my registry and import one from a pc that is working ? together with the replacement of the "Group Policy" folder from the working pc ?

    Sunday, August 25, 2013 11:06 AM
  • hi,

    Pls disable "Administrator" user account using http://www.howtogeek.com/howto/windows-vista/enable-the-hidden-administrator-account-on-windows-vista/

    and create other Admin account like "PCAdmin" and add it to Administrator Groups.

    and do the registry changes for Autologin .

    thanks

    Sunday, August 25, 2013 4:56 PM
  • Hi, 

    Thanks for your reply, i will try it tomorrow! :)

    The problem is that when i create another admin account, he doesn't have the same rights as our 'renamed' Administrator account.

    Br,

    Kristof

    Sunday, August 25, 2013 6:04 PM