none
Coress-forest mailbox migration failed

    Question

  • Hi There,

    We are trying to migrate mailboxes from Exchange 2003 to Exchange 2010 cross-forest.  We have setup two-way trusts and confirmed that the trust is working properly (have validated the trust, can ping each other by FQDN or shortname, can browse the accounts from the other forest). 

    I have migrated user account use Prepare-MoveRequest.ps1 and the account have been migrated ok.  However when I tried to migrated SID history using ADMT, it gives the error

    "Could not verify auditing and TcpipClientSupport on domains.  Will not be able to migrate Sid's.  Access is denied"

    Then if I run the following to migrate mailbox:

    New-MoveRequest -Identity "testmail" -RemoteLegacy  -TargetDatabase "database01" -RemoteGlobalCatalog 'dc1.local’ -RemoteCredential $Cred -TargetDeliveryDomain 'dchost.local'

    I Will get this error "MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80040115, ec=-2147221227)
    Diagnostic context:
        ......
        Lid: 16280   dwParam: 0x6BE      Msg: EEInfo: ComputerName: n/a
        Lid: 8600    dwParam: 0x6BE      Msg: EEInfo: ProcessID: 3820
        Lid: 12696   dwParam: 0x6BE      Msg: EEInfo: Generation Time: 2012-06-11 04:18:08:493
        Lid: 10648   dwParam: 0x6BE      Msg: EEInfo: Generating component: 18
        Lid: 14744   dwParam: 0x6BE      Msg: EEInfo: Status: 0
        Lid: 9624    dwParam: 0x6BE      Msg: EEInfo: Detection location: 290
        Lid: 13720   dwParam: 0x6BE      Msg: EEInfo: Flags: 0
        Lid: 11672   dwParam: 0x6BE      Msg: EEInfo: NumberOfParameters: 1
        Lid: 12952   dwParam: 0x6BE      Msg: EEInfo: prm[0]: Long val: 0
        Lid: 45169   StoreEc: 0x80040115
        Lid: 52465   StoreEc: 0x80040115
        Lid: 60065
        Lid: 33777   StoreEc: 0x80040115
        Lid: 59805
        Lid: 52209   StoreEc: 0x80040115
        Lid: 56583
        Lid: 52487   StoreEc: 0x80040115
        Lid: 19778
        Lid: 27970   StoreEc: 0x80040115
        Lid: 17730
        Lid: 25922   StoreEc: 0x80040115
        + CategoryInfo          : NotSpecified: (0:Int32) [New-MoveRequest], RemoteTransientException
        + FullyQualifiedErrorId : E6D36B2E,Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest

    There's no firewalls between the two forests as I have disabled all the firewalls.

    Can i please get some help on how to solve it?

    Thanks in advance

    Winnie

    Monday, June 11, 2012 8:28 PM

Answers

All replies

  • --Try to confirm the access of source Domain controller - registry, by logging into target domain controller as Admin account and try to access Source domain controller -registry using regedit.

    -- http://support.microsoft.com/kb/892192


    suresh kumaresan

    Tuesday, June 12, 2012 3:01 AM
  • Hi,

    The error indicates that the user account that is used to run ADMT does not have enough permissions to perform the migration in one or both of the domains.


    Regards from www.windowsadmin.info | www.blog.windowsadmin.info

    Tuesday, June 12, 2012 3:27 AM
  • Hi Manu,

    What permission does the account need?  The account that i was using is in the built-in administrator group in the target domain and I have added the account into the administrators group in the source domain.  What else does it need to have in terms of Exchange permissions on Exchange 2003 (source domain) and Exchange 2010 (target domain)?

    Thanks

    Winnie

    Wednesday, June 13, 2012 8:55 PM
  • Try using MigrationWiz. They specialize in Exchange migrations. Very easy to use.

    http://www.migrationwiz.com/

    • Proposed as answer by Dom-ZBanned Saturday, June 16, 2012 5:29 AM
    Thursday, June 14, 2012 12:23 AM
  • You should be a member of 'Organization management container too in target domain

    Regards from www.windowsadmin.info | www.blog.windowsadmin.info

    Thursday, June 14, 2012 3:36 AM
  • Account  should have Admin privileges in both domains (or an account with delegated MigratesIDHistory extended rights in the target domain).

    Also please refer http://support.microsoft.com/kb/322970

    Thursday, June 14, 2012 9:02 PM