none
Enabling RDP 8 from Windows 8.1 to Windows 7 Machine

    Question

  • After following the guidance in KB2592687, I am unable to make an RDP 8 connection to a Windows 7 SP1 desktop.  All of the patches and suggested group policy edits have been made.  I have tried Wireshark but I don't see any UDP activity on the wire. I tried adding a 3389/udp as well as an any-to-any firewall rule to see if that had any impact but no luck. Any other tools to troubleshoot RDP 8 connectivity?  Both machines are on the same network.

    Monday, April 07, 2014 9:23 PM

Answers

  • Looks like the policy editor wasn't writing the updates to the correct area.  When I added the following to the 64-bit registry (not Wow3264Node) it worked:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\TerminalServices]
    "fServerEnableRDP8"=dword:00000001
    "SelectTransport"=dword:00000000
    
    Monday, April 07, 2014 10:53 PM

All replies

  • Hi,

    To confirm, on the Windows 7 PC:

    1. You installed DTLS and RDP 8.0 updates and restarted

    2. You Enabled the Select RDP transport protocols policy setting and set it to Use both UDP and TCP, then restarted

    3. Using netstat -ano|findstr ":3389" verified that the process id for TermService is listening on both TCP and UDP

    4. In Windows Firewall with Advanced Security (wf.msc) both Remote Desktop - User Mode (TCP-In) and Remote Desktop - User Mode (UDP-In) are enabled

    5. The RDP-Tcp listener is set to the default Security Layer which is Negotiate.  This would only be different if you set it manually, via group policy, etc.

    -TP

    Monday, April 07, 2014 9:47 PM
    Moderator
  • I always forget about netstat. :)  Nothing listening on 3389/udp, only tcp. Not sure what 5355/udp is about though:

      TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING       1552
      TCP    [::]:3389              [::]:0                 LISTENING       1552
      TCP    [fe80::3dc7:9c5:4022:369d%17]:3389  [fe80::cdd4:3bed:61cd:3709%17]:13145  ESTABLISHED     1552
      UDP    0.0.0.0:5355           *:*                                    1552
      UDP    [::]:5355              *:*                                    1552
    The following firewall rules are enabled:
    • Remote Desktop - RemoteFX (TCP-In) - 3389/tcp
    • Remote Desktop - RemoteFX (UDP-In) - 3389/udp
    • Remote Desktop (TCP-In) - 3389/tcp

    I don't see a User Mode rule set.

    This is Windows 7 Enterprise x64 SP1 with all of the relevant KBs installed.  Policies to enable RDP 8 and set transport to "Use both UDP and TCP" set. Machine has been rebooted.

    Tried re-installing KB in order - KB2574819 then KB2592687 and that didn't make any difference.  Still nothing listening on 3389/udp.
    Monday, April 07, 2014 10:27 PM
  • Looks like the policy editor wasn't writing the updates to the correct area.  When I added the following to the 64-bit registry (not Wow3264Node) it worked:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\TerminalServices]
    "fServerEnableRDP8"=dword:00000001
    "SelectTransport"=dword:00000000
    
    Monday, April 07, 2014 10:53 PM