none
DNS in Windows 2008 R2 cannot resolve

    Question

  • Hi All,We have single Exchange 2010 on Windows 2008 R2, we got a bit trouble when resolving DNS.

    Please refer photos as below and tell me know how to fix it. (We cannot send mail out if DNS resolve is fault.)

    Thanks and looking forward to hearing from you.

    Van Cong Khanh



    Friday, December 27, 2013 3:51 AM

Answers

  • Then Try to delete the Exchange server DNS entries of IPv6 from DNS Server and create same entries with IPv4 IP address with all respective record. After creating all records in DNS server, kindly uncheck the IPv6 and try to connect your Exchange Management Console.

    After complete this activity also you’re getting same problem, then share the error msg. of management console and events

    Regards,

    Deepak Kotian

    Friday, December 27, 2013 8:12 AM

All replies

  • Hi,

    Thank you for your post here.

    Please try to disable your IPv6 in your network.

    http://support.microsoft.com/kb/929852

    Best Regards

    Quan Gu

    Friday, December 27, 2013 6:35 AM
    Moderator
  • Thanks for your reply, it's cannot use Exchange Management Console if we disable IPv6.

    I think we need to set priority of DNS server IPv4 is primary and IPv6 is Second it's will be OK, because we have no setup DNS server for IPv6 on our system, but we don't how to do.

    Best regards,

    Van Cong Khanh


    Friday, December 27, 2013 7:13 AM
  • Hi,

    Just let me know, when you trying to resolve your exchange server what IP address you're getting. IT is resolving through IPv4 or IPv6. Kindly confirm DNS is AD integrated or standalone

    Kindly share the error massages also.

    Regards,

    Deepak Kotian



    Friday, December 27, 2013 7:20 AM
  • we have a server setup windowsn 2008 R2 -> Domain Controller and Ms Exchange on it.

    IP Address is:

    Ethernet adapter Local Area Connection 2:

       Connection-specific DNS Suffix  . : mshome.net
       Description . . . . . . . . . . . : HP Network Team #1
       Physical Address. . . . . . . . . : AC-16-2D-89-94-C4
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::b0e7:de52:18e9:7c59%18(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.0.15(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.252.0
       Default Gateway . . . . . . . . . : 192.168.0.7
       DHCPv6 IAID . . . . . . . . . . . : 514594349
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-E2-82-71-AC-16-2D-89-94-C6

       DNS Servers . . . . . . . . . . . : fe80::d9d7:a893:3a83:ffd9%18
                                           192.168.0.15
       NetBIOS over Tcpip. . . . . . . . : Disabled
       Connection-specific DNS Suffix Search List :
                                           mshome.net

    ----------

    C:\>nslookup DNS request timed out. timeout was 2 seconds. Default Server: UnKnown Address: fe80::d9d7:a893:3a83:ffd9 > nslookup lgsourcing.com DNS request timed out. timeout was 2 seconds. DNS request timed out. timeout was 2 seconds. DNS request timed out. timeout was 2 seconds. DNS request timed out. timeout was 2 seconds. *** Can't find address for server lgsourcing.com: Timed out

    > nslookup mail.lgsourcing.com DNS request timed out. timeout was 2 seconds. DNS request timed out. timeout was 2 seconds. DNS request timed out. timeout was 2 seconds. DNS request timed out. timeout was 2 seconds. *** Can't find address for server mail.lgsourcing.com: Timed out >

    Thanks and Best regards,

    Van Cong Khanh


    Friday, December 27, 2013 7:29 AM
  • I think “nslookup” command you’ve faired through DNS server, then your DNS server is running through IPv6. Due to this you're facing this issue and as per given information by you, your network IP range belong to IPv4 not IPv6.

    Suppose your network belong to IPv4 then kindly disable your IPv6 from DNS server.

    before disabling IPv6, kindly provide IPv4 IP address to your respective server.

    Regards,


    Deepak Kotian

    Friday, December 27, 2013 7:41 AM
  • Kindly confirm your network is running through IPv4 or IPv6.
    Friday, December 27, 2013 7:45 AM
  • As per provide snap shot i am understanding, you're Network is mix mode network. Kindly confirm.
    Friday, December 27, 2013 7:56 AM
  • Yes, our network IP range IPv4, it got trouble that we cannot connect to Exchange Management Console (all users can check mail normally) after disabling IPv6. we really worry about MS exchange if it got somethings wrong.

    Best regards,
    Van Cong Khanh

    Friday, December 27, 2013 7:56 AM
  • Then Try to delete the Exchange server DNS entries of IPv6 from DNS Server and create same entries with IPv4 IP address with all respective record. After creating all records in DNS server, kindly uncheck the IPv6 and try to connect your Exchange Management Console.

    After complete this activity also you’re getting same problem, then share the error msg. of management console and events

    Regards,

    Deepak Kotian

    Friday, December 27, 2013 8:12 AM
  • Thank you very much.....

    Regards, Deepak Kotian

    Tuesday, December 31, 2013 9:59 AM