none
Deployment ignoring custom values in CustomSettings.ini

    Question

  • I'm trying to use the CustomSettings.ini to dictate which OU my machines add themselves to when joining the domain (laptop, desktop, server etc). However MDT seems to be ignoring everything outside of the [Default] attribute and only applying the settings defined there - so it is joining the domain, but the computer objects are landing in the default Computers OU.
    Domain joining is not specified in my Bootstrap.ini or in the unattended.xml. MDT is also not adding my prefix value for "SiteID" to the OSDComputerName.

    My CS.ini is structured as follows:

    Priority=ByLaptopType,ByDesktopType,ByVMType,ByServerType,Default
    Properties=

    SiteID,Type
          
    [Default]
    OSInstall=Y
    SkipCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerBackup=YES
    SkipApplications=NO

    OSDComputerName=%SiteID%%Type%%SERIALNUMBER%

    SKIPCOMPUTERNAME=NO
    SkipDomainMembership=YES
    DomainAdmin=mdtsauser
    DomainAdminDomain=mycompany.local
    DomainAdminPassword=somepassword1
    JoinDomain=mycompany.local

    SkipUserData=yes
    SkipComputerBackup=YES
    SkipComputerName=YES
    SkipPackageDisplay=YES
    SkipLocaleSelection=YES
    UserLocale=en-AU
    UILanguage=en-AU

    SkipBitLocker=YES
    SkipSummary=YES

    SLShare=\\mdt\mdtshare$\logs
    SLShareDynamicLogging=\\mdt\mdtshare$

    [ByLaptopType]
    Subsection=Laptop-%IsLaptop%

    [ByDesktopType]
    Subsection=Desktop-%IsDesktop%

    [ByVMType]
    Subsection=VM-%IsVM%

    [Laptop-True]
    Type=LT
    SKIPCOMPUTERNAME=NO
    SkipDomainMembership=YES
    DomainAdmin=mdtsauser
    DomainAdminDomain=mycompany.local
    DomainAdminPassword=somepassword1
    MachineObjectOU=OU=Laptops,OU=Office,OU=ManagedComputers,DC=mycompany,DC=local
    JoinDomain=mycompany.local

    [Desktop-True]
    Type=OF
    SKIPCOMPUTERNAME=NO
    SkipDomainMembership=YES
    DomainAdmin=mdtsauser
    DomainAdminDomain=mycompany.local
    DomainAdminPassword=somepassword1
    MachineObjectOU=OU=Desktops,OU=office,OU=ManagedComputers,DC=mycompany,DC=local
    JoinDomain=mycompany.local


    [VM-True]
    Type=VM
    SKIPCOMPUTERNAME=NO
    SkipDomainMembership=YES
    DomainAdmin=mdtsauser
    DomainAdminDomain=mycompany.local
    DomainAdminPassword=somepassword1
    MachineObjectOU=OU=VM,OU=VDI,OU=ManagedComputers,DC=mycompany,DC=local
    JoinDomain=mycompany.local

    [LON]
    SiteID=LON

    Any ideas why these settings are not being applied? Thanks 

    Thursday, September 19, 2013 11:33 PM

All replies


  • Properties=

    SiteID,Type
          

    I'm pretty sure this should be one line.

    /Andrew


    Blog: http://scriptimus.wordpress.com

    Thursday, September 19, 2013 11:43 PM
  • Yeah sorry, it is on one line, it just pasted over a bit weird and I must have knocked Enter by accident when I was sorting out the formatting
    Friday, September 20, 2013 12:52 AM
  • Just realised that this is actually working perfectly for my laptops, but not the desktops...very strange. 
    Friday, September 20, 2013 2:53 AM
  • I don't see how your [lon] section is supposed to be parsed. Can you explain?

    Keith Garner - keithga.wordpress.com

    Tuesday, September 24, 2013 12:24 AM
    Moderator
  • You can move these lines under [default] as they're all the same common values.

    SKIPCOMPUTERNAME=NO
     SkipDomainMembership=YES
     DomainAdmin=mdtsauser 
     DomainAdminDomain=mycompany.local
     DomainAdminPassword=somepassword1
     MachineObjectOU=OU=VM,OU=VDI,OU=ManagedComputers,DC=mycompany,DC=local
     JoinDomain=mycompany.local
     

    /Andrew


    Blog: http://scriptimus.wordpress.com

    Wednesday, September 25, 2013 12:59 PM