none
Exchange 2010: Out of Office not working for one user. ExternalAudience None wont change to All

    Question

    • Out of office external not working for one user:

      Get-MailboxAutoReplyConfiguration 

      Shows ExternalAudience as None, but when you change it via Set-MailboxAutoReplyConfiguration -ExternalAudience All. The command runs without any errors, also in the event shows as successful, but after running Get-MailboxAutoReplyConfiguration still shows -ExternalAudience as None 

      Have tried the set command with a test user, can change to none and back to all successfully 

    Wednesday, July 31, 2013 2:54 PM

Answers

  • Hi,

    Based on my experience, per-user external OOF option may be set to InternalOnly by administrators, which may cause that OOF external not working for one user.

    So before try Rich Matheisen’s suggestion, we can allow external OOF firstly by running:

    Set-Mailbox -id <mailbox identity> -ExternalOOFOptions   External

    For more information: http://blogs.technet.com/b/exchange/archive/2006/10/06/3395024.aspx

    Hope it can help you.

    Thanks

    • Marked as answer by JezzaB Thursday, August 01, 2013 10:46 AM
    Thursday, August 01, 2013 10:11 AM

All replies

  • Try using MFCMAPI to clean up the OOF data. Also check the rules quota on the mailbox and make sure there just isn't enough room for the OOF rules! I've seen mailboxes that have many duplicate OOF rules (usually caused by running different versions of Outlook and ActiveSync clients) that just didn't work together.

    http://www.slipstick.com/general/clean-out-of-office-rules-using-mfcmapi/


    --- Rich Matheisen MCSE&I, Exchange MVP

    Thursday, August 01, 2013 2:38 AM
  • Thanks Rich, 

    Unfortunately didn't work. 

    Most of  them deleted ok, but the ones with matched the  properties came up with errors when trying to delete

    Error: 
    Code: MAPI_E_VERSION == 0x80040110
    Function lpMAPIProp->SaveChanges(KEEP_OPEN_READWRITE)
    File MAPIFunctions.cpp
    Line 961

    and 

    Error: 
    Code: MAPI_E_VERSION == 0x80040110
    Function DeleteProperty(m_lpMAPIProp,ulPropTag)
    File SingleMAPIPropListCtrl.cpp
    Line 1185


    Thursday, August 01, 2013 9:00 AM
  • Hi,

    Based on my experience, per-user external OOF option may be set to InternalOnly by administrators, which may cause that OOF external not working for one user.

    So before try Rich Matheisen’s suggestion, we can allow external OOF firstly by running:

    Set-Mailbox -id <mailbox identity> -ExternalOOFOptions   External

    For more information: http://blogs.technet.com/b/exchange/archive/2006/10/06/3395024.aspx

    Hope it can help you.

    Thanks

    • Marked as answer by JezzaB Thursday, August 01, 2013 10:46 AM
    Thursday, August 01, 2013 10:11 AM
  • Hi,

    Based on my experience, per-user external OOF option may be set to InternalOnly by administrators, which may cause that OOF external not working for one user.

    So before try Rich Matheisen’s suggestion, we can allow external OOF firstly by running:

    Set-Mailbox -id <mailbox identity> -ExternalOOFOptions   External

    For more information: 

    Hope it can help you.

    Thanks

    Hi thanks, 

    I tried this the other day and came back with an error. I though it was because it was only an Exchange 2007 Powershell command. Have rerun it just now and seems to have worked, not sure if its a combination of Rich's solution and this one. 

    :)

    Thursday, August 01, 2013 10:46 AM
  • you have tried to reestart the Mailbox Assistants Service ?
    Thursday, August 08, 2013 9:46 PM