none
SharePoint 2013 x86 on a 64-bit server?

    Question

  • I have an existing SharePoint installation which is 64-bit installation. I would like to install SharePoint 32-bit instead because Visual Studio is 32-bit. Is it possible to do that on a 64-bit Windows Server 2012?
    • Edited by diffident Wednesday, August 28, 2013 5:19 PM
    Wednesday, August 28, 2013 4:54 PM

Answers

  • SharePoint 2010 and 2013 only come in 64-bit flavors.  While Visual Studio only comes in 32-bit flavors, it can develop, debug, and deploy 64-bit applications, including SharePoint solutions.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 28, 2013 5:33 PM
    Moderator

All replies

  • Can we install x86 SharePoint 2013 on Windows Server 2012? Will there be any limitations to that approach?

    Wednesday, August 28, 2013 5:18 PM
  • SharePoint 2010 and 2013 only come in 64-bit flavors.  While Visual Studio only comes in 32-bit flavors, it can develop, debug, and deploy 64-bit applications, including SharePoint solutions.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 28, 2013 5:33 PM
    Moderator
  • but why does I get this error when debugging a web application from windows server 2012 with visual studio 2013 and sharepoint 2013 installed?

    Microsoft SharePoint is not supported in 32-bit process. Please verify that you are running in a 64-bit executable.

    Wednesday, August 28, 2013 6:33 PM
  • This is when debugging a SharePoint solution?

    Have you set the Platform Target to "AnyCPU"?  It might be set to 32bit.


    Trevor Seward, MCC

      

    Follow or contact me at...


    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.


    Wednesday, August 28, 2013 6:35 PM
    Moderator
  • No. This happens when debugging an ASP.NET Web Application that has a reference to Microsoft.SharePoint.dll

    Initially, it was set to Any CPU and then I changed it to x64 but both of them throw the same error.

    Wednesday, August 28, 2013 6:48 PM
  • Wednesday, August 28, 2013 6:51 PM
  • Is the Application Pool in IIS set to enable 32bit applications (it should be set to false), or are you using IIS Express for debugging?

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 28, 2013 6:53 PM
    Moderator
  • Was about to say the same thing, seems like it's running 32bit mode. Surprised it would even run in that.
    Wednesday, August 28, 2013 7:07 PM
  • I have visual studio installed on the server and that is where I am doing my development. I hit F5 and that is when visual studio's internal IIS server takes over (i guess?). I am not launching this application from the browser per se. Do you mean what I am saying and hence there is no application pool involved.
    Wednesday, August 28, 2013 7:29 PM
  • It's been a long time since I've done any SharePoint development but it used to just tie into the SharePoint w3p process that is running on the server to debug the project on the site. I doubt it's changed. You need to make sure the app pool running the SharePoint site you are debugging doesn't have that 32bit option on.

    Also make sure your project or debug options are set to 64bit in visual studio as well when you kick that off. If I had it installed I'd go find the option but it's got to be that or the application pool setting previously discussed.

    Wednesday, August 28, 2013 7:42 PM
  • Thanks Turismon. I will try these and let you know.

    Wednesday, August 28, 2013 7:43 PM
  • Turismon - When I set project options to 64bit, I do not get compile time error but runtime error that reads as:

    Could not load file or assembly 'ExtractorV1' or one of its dependencies. An attempt was made to load a program with an incorrect format.             

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.            

    Exception Details: System.BadImageFormatException: Could not load file or assembly 'ExtractorV1' or one of its dependencies. An attempt was made to load a program with an incorrect format.

    Wednesday, August 28, 2013 7:47 PM
  • That likely means that ExtractorV1 is a 32bit assembly, and will need to be recompiled into a 64bit assembly.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 28, 2013 8:42 PM
    Moderator
  • How can I recompile it into a 64bit assembly? I have x64 set for project build option and recompiled it but still the same result. :(
    Wednesday, August 28, 2013 9:02 PM
  • Do you have the source code to ExtractorV1 and do you have the source or 64bit assemblies for any assemblies ExtractorV1 requires?

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 28, 2013 9:03 PM
    Moderator
  • Now I am confused. I do have source code to ExtractorV1 but the assemblies that i have added are x86 version. Please see below:

    System, Microsoft.CSharp, System.Configuration, System.Core

    The reason why I think above assemblies are x86 is because they are in Program Files (x86)

    Is my reasonsing correct?

    Wednesday, August 28, 2013 9:18 PM
  • Yep, your reasoning would be correct.  You'll want 64bit assemblies instead, which you should be able to find in the GAC.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 28, 2013 9:22 PM
    Moderator
  • Sorry but i am unable to locate 64bit assemblies in GAC. Tried all these subfolders:

    GAC, GAC_64, GAC_MSIL, NativeImages_v4.0.30319_64

    I couldn't find "system.dll" which is 64bit.

    Any pointers on where I can find them?

    Wednesday, August 28, 2013 9:38 PM
  • Sorry, I shouldn't have said that reasoning would be correct, it might be, it might not be.  But it sounds like you have at least one assembly loaded by the ExtractorV1 source that is 32bit.  You can use https://assemblyinformation.codeplex.com/ to identify the Target Processor.  AnyCPU and 64bit should be OK.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 28, 2013 10:14 PM
    Moderator
  • Hi Trevor: When I create a blank ASP.NET web application, set its project build option to x64, I get the same error. Looks like when I create an empty web application it is adding x86 assemblies as references. Now how can I create an x64 web application from visual studio 2013?

    Thursday, August 29, 2013 3:37 PM
  • Trevor -- Help with this one?
    Thursday, August 29, 2013 7:51 PM
  • On the Project Properties -> Build, what is the target?  It should be AnyCPU.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, August 29, 2013 8:00 PM
    Moderator
  • If I set it to AnyCPU, I get the same error which I posted as an image earlier in this thread: PlatformNotSupportedException
    Thursday, August 29, 2013 8:18 PM
  • What version of .NET is the project set to?

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, August 29, 2013 8:23 PM
    Moderator
  • It is set to 4.5
    Thursday, August 29, 2013 8:27 PM
  • Go to Project Properties -> Web, uncheck use IIS Express.


    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, August 29, 2013 8:53 PM
    Moderator
  • Thanks Trevor, that worked!

    So, what can I conclude from this problem? I cannot use IIS Express? What is the difference between a local IIS web server and using IIS express or both?

    Thursday, August 29, 2013 9:56 PM
  • Looks like the one built-in to VS 2012 is 32bit (I really don't use IIS Express).  There is a 64bit build of IIS 8.0 Express - http://www.microsoft.com/en-us/download/details.aspx?id=34679

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, August 29, 2013 10:57 PM
    Moderator
  • Again Trveor Saved my day!!! :-D i was trying to call SP dll in my asp.net appln, its throwing the above error

    i checked the use iis express field---> its already CHECKED.

    so i unchecked and it worked!! but  i am getting an erro the site is unavailable!

    i have found out the one more thing:

    in the project properties--> BUILD MENU -->  UNCHECK THE PREFER 32 BIT  check box.

    after that my solution started working and reading  my splist from my console appln.!!!


    • Edited by SaMolPP Thursday, November 21, 2013 6:58 AM added 1 more solution.
    Tuesday, November 19, 2013 2:29 PM