none
Hyper -V Platform not installing from a Windows 8 Pro upgrade

    Question

  • Hi, I recently purchased Lenovo IdeaPad Yoga 13 which came with Windows 8.  I upgraded to Windows 8 Pro and it's now activated.

    I tried installing Hyper -V Platform because I'm working on a Windows Phone 8 app and currently don't have a WP8 phone.  When I try to debug the app I get Hyper -V isn't installed.

    So, I went through the BIOS to first enable virtualization hardware acceleration and then I went into Windows Programs Add new features and components and checked the box for Hyper -V

    However I get the following error

    "Windows couldn't complete the requested changes.

    The component store has been corrupted

    Error Code: 0x80073712"

    I'm not sure where to go from here.  I try it again I get the same error.  I can't find an external URL to download and install and I have double check my activation of windows since I had updated it that day and everything seems to be in check, just no luck with this install.

    thanks,

    • Moved by BrianEhMVP Tuesday, December 11, 2012 3:55 PM (From:Hyper-V)
    Tuesday, December 11, 2012 2:21 AM

Answers

  • Hi, try to perform those step for "System Update Readiness Tool fixes Windows Update errors in Windows 8".(from http://support.microsoft.com/kb/947821)

    • Swipe in from the right edge of the screen, and then tap Search. (If you're using a mouse, point to the upper-right corner of the screen, move the mouse pointer down, and then click Search.)
    • Type command prompt in the search box.
    • In the list of results, swipe down on or right-click Command Prompt, and then tap or click Run as administrator.
    • In the Administrator: Command Prompt window, type the following commands exactly as they appear. Press the Enter key after each command:
      • "DISM.exe /Online /Cleanup-image /Scanhealth"
      • "DISM.exe /Online /Cleanup-image /Restorehealth"
    • To close the Administrator: Command prompt window, type Exit, and then press Enter.
    • Run Windows Update again.
    • It will detect KB2764462 patches.
    • Install the patches and restart laptop.

    It should be allow us to add in Hyper-V features as per normal. It's works for my Yoga 13 Win8 Pro.

    Wednesday, December 19, 2012 3:44 PM
  • Hi,


    Try to use PowerShell to install Hyper-v:

    On the Windows PowerShell command line, type the following:

    Enable-WindowsOptionalFeature –FeatureName Microsoft-Hyper-V -All

    If the issue persists, try to perform a system refresh:

    Click Control Panel
    Click General on the left column
    Under the Refresh your PC without affecting your files, click Get started


    Leo Huang
    TechNet Community Support

    Thursday, December 13, 2012 7:28 AM
    Moderator

All replies

  • My first suggestion would be to do a clean install of Win8 Pro and avoid the upgrade process. Should be pretty quick.
    Tuesday, December 11, 2012 7:14 AM
  • Hi,


    Try to use PowerShell to install Hyper-v:

    On the Windows PowerShell command line, type the following:

    Enable-WindowsOptionalFeature –FeatureName Microsoft-Hyper-V -All

    If the issue persists, try to perform a system refresh:

    Click Control Panel
    Click General on the left column
    Under the Refresh your PC without affecting your files, click Get started


    Leo Huang
    TechNet Community Support

    Thursday, December 13, 2012 7:28 AM
    Moderator
  • I ran into this exact same issue too, and for exactly the same reasons. I have an IdeaPad Yoga 13 and upgraded to Windows 8 Pro (activated). I tried the PowerShell option, and just got an error back about 'ambiguous parameter set'.

    I don't really want to perform a Refresh since it will just take me back to before I upgraded to Windows 8 Pro, which isn't helpful since I can't activate Hyper-V then. Any other options?

    Wednesday, December 19, 2012 6:35 AM
  • I having exactly same situation as you.

    -After upgrade Yoga to w8 pro, getting same error when enable hyper0-v

    getting error message if enable hyper-v features with power shells:

    Enable-WindowsOptionalFeature : Parameter set cannot be resolved using the specified named parameters.
    At line:1 char:1
    + Enable-WindowsOptionalFeature –FeatureName Microsoft-Hyper-V -All
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [Enable-WindowsOptionalFeature], ParameterBindingException
        + FullyQualifiedErrorId : AmbiguousParameterSet,Microsoft.Dism.Commands.EnableWindowsOptionalFeatureCommand

    Wednesday, December 19, 2012 2:37 PM
  • Hi, try to perform those step for "System Update Readiness Tool fixes Windows Update errors in Windows 8".(from http://support.microsoft.com/kb/947821)

    • Swipe in from the right edge of the screen, and then tap Search. (If you're using a mouse, point to the upper-right corner of the screen, move the mouse pointer down, and then click Search.)
    • Type command prompt in the search box.
    • In the list of results, swipe down on or right-click Command Prompt, and then tap or click Run as administrator.
    • In the Administrator: Command Prompt window, type the following commands exactly as they appear. Press the Enter key after each command:
      • "DISM.exe /Online /Cleanup-image /Scanhealth"
      • "DISM.exe /Online /Cleanup-image /Restorehealth"
    • To close the Administrator: Command prompt window, type Exit, and then press Enter.
    • Run Windows Update again.
    • It will detect KB2764462 patches.
    • Install the patches and restart laptop.

    It should be allow us to add in Hyper-V features as per normal. It's works for my Yoga 13 Win8 Pro.

    Wednesday, December 19, 2012 3:44 PM
  • That's amazing. Thanks so much for these instructions. This should be straight forward stuff. Exactly the same issue with a Yoga upgrade - process is still broken in 07/2013.

    Now we're clicking...

    Tuesday, July 09, 2013 3:39 PM
  • Xiao,

    You are my Hero, works fine for me !

    Paul

    Wednesday, September 25, 2013 9:41 AM