none
Can't find ~$ files

    Question

  • Hi All

    Discovered something disturbing today. I tried to delete temp files before moving folders and searched for ~$*.*

    Using Explorer nothing showed up. How can I tell Explorer to search for these hidden files?

    I have ticked all the boxes in "Folder and search options" I use to display these files, but search still does not bring them up.

    Cheers

    Thomas

     

    Sunday, November 03, 2013 11:53 PM

Answers

  • Under registry , the applications reference HKCR for all the possible file extensions.

    For explorer it would be HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

    Explorer would reference below key

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

    If you want to set / modify the hide file extensions for all users at the machine level, then the registry is

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden

    and

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\HideFileExt

    ======================

    You can also use Indexing option to add the file extension to search for the specific type.

    control panel --> indexing option ->> advance --> file ext

    Monday, November 04, 2013 11:48 PM
  • Hello Thomas,
    did you also try to search for "~$*.*" with quotes ?

    Look at this serverfault article too How do I search for files with tilde in the name in Windows Server 2008 R2?.

    Bye,
    Luca


    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights. | Whenever you see a helpful reply, click on Vote As Help and click on Mark As Answer if a post answers your question.

    Tuesday, November 05, 2013 8:32 AM

All replies

  • Hello Thomas,
    if you ticked all boxes this mean you ticked "Hide protected operating system files (Recommended)" option too that shoudn't. And also make sure "Show hidden files, folders, and drivers" option button is selected too.
    Then, are you sure there should be ~$*.* files inside the folder where you are searching ?

    Bye,
    Luca


    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights. | Whenever you see a helpful reply, click on Vote As Help and click on Mark As Answer if a post answers your question.

    Monday, November 04, 2013 8:29 AM
  • Hi Luca

    Thanks for trying to help. Ticked all the boxes is a metaphor for ticking and un-ticking all the boxes needed "to display these files"

    Check for yourself, these files are ~$*.doc files with a hidden attribute, (you most likely find one on any 2008R2 terminal server with Office users)

    I can see them in Explorer, but I can't search for them.

    I guess there must be a registry key to fix that.

    I can find them though using command prompt with the  DIR /AH option.

    Cheers

    Monday, November 04, 2013 11:09 PM
  • Under registry , the applications reference HKCR for all the possible file extensions.

    For explorer it would be HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

    Explorer would reference below key

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

    If you want to set / modify the hide file extensions for all users at the machine level, then the registry is

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden

    and

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\HideFileExt

    ======================

    You can also use Indexing option to add the file extension to search for the specific type.

    control panel --> indexing option ->> advance --> file ext

    Monday, November 04, 2013 11:48 PM
  • Hello Thomas,
    did you also try to search for "~$*.*" with quotes ?

    Look at this serverfault article too How do I search for files with tilde in the name in Windows Server 2008 R2?.

    Bye,
    Luca


    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights. | Whenever you see a helpful reply, click on Vote As Help and click on Mark As Answer if a post answers your question.

    Tuesday, November 05, 2013 8:32 AM
  • Thursday, November 14, 2013 1:18 AM