none
Outbound email not working after migration from SBS 2003 to SBS 2011

    Question

  • Hello good people of the forum - I am hoping there is someone out there that can assist with this.

    Environment:

    Dynamic IP (Rogers), POP email accounts through GoDaddy, DYNDNS connector running on server

    Situation: Migration from SBS 2003 to 2011.  Email flowed in both directions without issue while SBS 2003 server (only) was deployed.  After migration (both servers still live, all Exchange services on 2003 disabled), configured POP3 connectors successfully for retreiving email from GoDaddy.  Receiving email is not an issue.

    Using smtpout.secureserver.net on port 3535 but Exchange fails to send email - queue continually shows "retry".

    Power Shell output:

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    [PS] C:\Users\bradmin\Desktop>Get-SendConnector

    Identity                                AddressSpaces                           Enabled
    --------                                -------------                           -------
    Windows SBS Internet Send SBS2011       {smtp:*;1}                              True


    [PS] C:\Users\bradmin\Desktop>Get-SendConnector | List Name, Port

    Name : Windows SBS Internet Send SBS2011
    Port : 3535

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    I can telnet from server to smtpout.secureserver.net on port 3535 and get the following results:

    220 m1plsmtpa01-05.prod.mesa1.secureserver.net  ESMTP

    Help!?

    Friday, July 13, 2012 5:15 AM

Answers

  • Hello all,

    I appreciate the feedback.

    Martina - I did have authentication enable and configured on the GoDaddy smart host.  As per GoDaddy tech support I used one of my email accounts - using the email address and password to authenticate.  I have also tried with and without Basic Authentication over TLS.

    Here is how I fixed this issue:

    1) Created a new email account with Rogers

    2) Configured smarthost smtp.broadband.rogers.com - using the email address and password from above

    3) Log into Rogers' site for the management of emails etc and create a "send only" alias for each email account in the network.  It will ask for a name for the alias as well as the email address from which Rogers will expect outbound email from.  This will kick a verification email from Rogers to said account. 

    Upon choosing to verify the account, those accounts are now able to send email through Exchange, through the smart host via Rogers.  This does not affect inbound email.

    Curiously however, since these changes, my cousin in Germany  gets a bounce back message when attempting to send email to me - message indicates relay is not permitted.  Yet all my testing from my hotmail and work accounts go through without issue.

    • Marked as answer by Michael Tapp Thursday, July 19, 2012 3:27 AM
    Thursday, July 19, 2012 3:27 AM

All replies

  • Hi,

    Can you also send an e-mail using telnet to the secureserver.net service?

    Leif

    Friday, July 13, 2012 11:27 AM
  • See below

    C:\Windows\system32>telnet smtpout.secureserver.net 25
    Connecting To smtpout.secureserver.net...Could not open connection to the host,
    on port 25: Connect failed

    When attempting to telnet on the same smart host but on port 3535:

    220 p3plsmtpa01-02.prod.phx3.secureserver.net ESMTP
    HELO domain.com
    250 p3plsmtpa01-02.prod.phx3.secureserver.net
    MAIL FROM: michael@domain.com
    250 Sender accepted.
    RCPT TO: myemailaddress@hotmail.com
    553 Sorry, that domain isn't in my list of allowed rcpthosts.
    RCPT TO: michael@domain.com
    500 Not implemented.
    SUBJECT: test
    500 Not implemented.

    telnet to same on port 465 opens a connection but no prompts for commands

    Saturday, July 14, 2012 4:14 AM
  • Hi,
    I could be wrong here, but don't GoDaddy requires authentication?
    ..and if so, do you have it configured on your SendConnector?


    Martina Miskovic

    Saturday, July 14, 2012 6:33 AM
  • Using smtpout.secureserver.net on port 3535 but Exchange fails to send email - queue continually shows "retry".

    What is the last error you get in the queue viewer?

    Please run this command and post the result in your next post:

    Get-Sendconnector -identity "Windows SBS Internet Send SBS2011" |fl

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Monday, July 16, 2012 5:17 AM
  • Hello all,

    I appreciate the feedback.

    Martina - I did have authentication enable and configured on the GoDaddy smart host.  As per GoDaddy tech support I used one of my email accounts - using the email address and password to authenticate.  I have also tried with and without Basic Authentication over TLS.

    Here is how I fixed this issue:

    1) Created a new email account with Rogers

    2) Configured smarthost smtp.broadband.rogers.com - using the email address and password from above

    3) Log into Rogers' site for the management of emails etc and create a "send only" alias for each email account in the network.  It will ask for a name for the alias as well as the email address from which Rogers will expect outbound email from.  This will kick a verification email from Rogers to said account. 

    Upon choosing to verify the account, those accounts are now able to send email through Exchange, through the smart host via Rogers.  This does not affect inbound email.

    Curiously however, since these changes, my cousin in Germany  gets a bounce back message when attempting to send email to me - message indicates relay is not permitted.  Yet all my testing from my hotmail and work accounts go through without issue.

    • Marked as answer by Michael Tapp Thursday, July 19, 2012 3:27 AM
    Thursday, July 19, 2012 3:27 AM