none
unable to add usb drives for backups server 2012

    Question

  • I have been trying to add an additional external usb drive to an existing backup schedule and am unable to. The other drive that is currently in the backup is not plugged in is also usb... and the gui is failing with the error "the system cannot find the path specified".

    this was an issue back in 2k8r2 where if this happened you had to add it from command line however this dose not work as well.

    PS C:\Windows\system32> WBADMIN GET DISKS
    wbadmin 1.0 - Backup command-line tool
    (C) Copyright 2012 Microsoft Corporation. All rights reserved.

    Disk name: Virtual HD ATA Device
    Disk number: 0
    Disk identifier: {ac5fe721-0000-0000-0000-000000000000}
    Total space: 500.00 GB
    Used space : 111.65 GB
    Volumes: <not mounted>[System Reserved],C:[]

    Disk name: Virtual HD ATA Device
    Disk number: 1
    Disk identifier: {4f8e6912-8928-43c5-b763-3e96c4a3d485}
    Total space: 500.00 GB
    Used space : 495.06 GB
    Volumes: E:[Backup 2012_12_21 11:30 DISK_01]

    Disk name: WD My Book 1140 USB Device
    Disk number: 2
    Disk identifier: {0c3fbe2c-1e36-49e2-92ee-bf2127477d9c}
    Total space: 3725.99 GB
    Used space : 128.01 MB
    Volumes: <not mounted>[(no volume label)]

    PS C:\Windows\system32> .\wbadmin.exe enable backup -addtarget:{0c3fbe2c-1e36-49e2-92ee-bf2127477d9c}
    wbadmin 1.0 - Backup command-line tool
    (C) Copyright 2012 Microsoft Corporation. All rights reserved.

    Storage locations for scheduled backups can be disks, volumes, or remote
    shared folders. Multiple storage locations can be configured for scheduled
    backups, but they must be of the same type. The current schedule uses disk
    for backup storage. Adding a new storage type will remove the disk
    storage locations.
    Do you want to continue?
    [Y] Yes [N] No Y

    ERROR - The specified backup location could not be found or is not a
    supported backup storage location.

    please advice.

    Tuesday, February 26, 2013 3:55 PM

Answers

  • Answering my own post--I just went through a paid incident on this issue (presumably now won't require payment by the client).  It is confirmed as a bug, and there will be a Microsoft Update issued on this.  In the meantime, there's a hotfix they provided--"Windows8-RT-KB426957-x64-InstallForTestingPurposesOnly.exe".

    No, they don't know when they'll release the real fix.  Yes, the hotfix will  have to be uninstalled when the real update comes out.

    Yes, the hotfix brands your screen as "Windows Server 2012 Standard/For testing purposes only. Build 9200".  I figure that's a Good Thing(Tm), since it'll remind me to look for the update.

    And it works, at least for adding disks.  The Microsoft Backup GUI works cleanly; the "wbadmin" CLI setup leaves a "funny" string on the disk identifier, but I have no indication that it won't work.  Of course, I now have to go through a full backup cycle.

    • Marked as answer by dw5304 Thursday, April 11, 2013 8:36 PM
    Wednesday, April 10, 2013 9:37 PM
  • according to Microsoft its a bug and the solution is to recreate the schedule or attach all existing backups to the machine to add another drive.

    "And for your question about this behave, after confirming with our Senior Engineer, it’s a bug in Windows Server 2012 based on reviewing source code.  In Windows Server 2008 R2 it used to work from command line."

    • Edited by Daniel Walters1 Monday, March 25, 2013 4:40 AM answer from microsoft
    • Proposed as answer by Daniel Walters1 Monday, March 25, 2013 4:40 AM
    • Marked as answer by dw5304 Thursday, April 11, 2013 8:36 PM
    Monday, March 18, 2013 11:42 AM

All replies

  • Hi,

    Could you find more information about this issue in backup log? Meanwhile here are 3 threads which related to the same error message, please see if there is any one helpful:

    http://social.technet.microsoft.com/Forums/en/windowsbackup/thread/09462f71-30b0-4095-aab9-b44e83cf6b0c

    http://social.technet.microsoft.com/Forums/en-NZ/windowsbackup/thread/6811a779-e820-4079-9589-fc40db033c91

    http://social.technet.microsoft.com/Forums/en/windowsbackup/thread/ef3fd1c6-4baa-4240-a65f-e474cbf96c61


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Tuesday, March 05, 2013 7:03 AM
  • their is no errors that are readable there is one *.etl file

    I have looked over the other threads listed prior to posting this one the only one that seemed like it would be right is http://social.technet.microsoft.com/Forums/en/windowsbackup/thread/09462f71-30b0-4095-aab9-b44e83cf6b0c however the kb says that i can add it via command line via --addtrarget  this is also failing and the reason i created this thread. I do not have any extra usb ports i can do add to this server so i can not "attach" the other drive.

    Tuesday, March 05, 2013 7:46 AM
  • there was no additional information in the etl file. :(. any other ideas?
    • Edited by dw5304 Tuesday, March 12, 2013 1:17 PM
    Friday, March 08, 2013 8:15 PM
  • according to Microsoft its a bug and the solution is to recreate the schedule or attach all existing backups to the machine to add another drive.

    "And for your question about this behave, after confirming with our Senior Engineer, it’s a bug in Windows Server 2012 based on reviewing source code.  In Windows Server 2008 R2 it used to work from command line."

    • Edited by Daniel Walters1 Monday, March 25, 2013 4:40 AM answer from microsoft
    • Proposed as answer by Daniel Walters1 Monday, March 25, 2013 4:40 AM
    • Marked as answer by dw5304 Thursday, April 11, 2013 8:36 PM
    Monday, March 18, 2013 11:42 AM
  • Has there been any movement on this problem?  I just ran into it myself on a new Server 2012 Standard installation, and haven't found any solutions on either Microsoft's site or the 'Net.
    Thursday, April 04, 2013 3:19 PM
  • Answering my own post--I just went through a paid incident on this issue (presumably now won't require payment by the client).  It is confirmed as a bug, and there will be a Microsoft Update issued on this.  In the meantime, there's a hotfix they provided--"Windows8-RT-KB426957-x64-InstallForTestingPurposesOnly.exe".

    No, they don't know when they'll release the real fix.  Yes, the hotfix will  have to be uninstalled when the real update comes out.

    Yes, the hotfix brands your screen as "Windows Server 2012 Standard/For testing purposes only. Build 9200".  I figure that's a Good Thing(Tm), since it'll remind me to look for the update.

    And it works, at least for adding disks.  The Microsoft Backup GUI works cleanly; the "wbadmin" CLI setup leaves a "funny" string on the disk identifier, but I have no indication that it won't work.  Of course, I now have to go through a full backup cycle.

    • Marked as answer by dw5304 Thursday, April 11, 2013 8:36 PM
    Wednesday, April 10, 2013 9:37 PM
  • one thing i should note dave is the fact old backups will not restore from my testing. I have already sent feedback to them on this.
    Tuesday, April 16, 2013 7:30 PM
  • Hi Dave, I have a lot of customers that never had any problems with 2008R2 Windows backup. But now with 2012 they are having a lot of problems. Suddenly the backup can’t find any disks, we recreate the whole job with all USB disk’s connected and it work again a couple of weeks "if they are lucky" then the problems come back. I have tried every solution I could find but couldn’t solve the problem. This behaviour is with several customers.

    When I phone Microsoft for partners they don’t find this hotfix you mention and they will off course put up a paid incident.

    Is it possible for you to in some how share this hotfix to us/me? Or can you tell me where I can download this fix without paying Microsoft for there’s disaster to backup bug!

    Where can I download "Windows8-RT-KB426957-x64-InstallForTestingPurposesOnly.exe"?

    Anyone?

    Wednesday, June 19, 2013 10:39 AM
  • I would send you a copy of the hotfix i had... however its "expired". I would recomend calling pro support pay the incident then ask for a refund seeing it is a bug... if enough people do this they will need to release it sooner than latter.
    Wednesday, June 19, 2013 1:09 PM
  • Sorry for the long delay in replying to this.  I didn't have any old backups, I haven't seen this.  I did test recovery from backups created after the hotfix was applied, and they do work.

    Also, it's now over three months later, and they've not released the fix for the general public.  What the heck is going on?

    Saturday, June 22, 2013 12:42 PM
  • Unfortunately, I don't know the legal status of redistribution of a HotFix.  I'm absolutely gobsmacked that they've not released it by now as a regular update.

    I can report they did reverse charges on the client's credit card, so as long as you have a CC you can temporarily charge, you should be able to open an incident and get the fix for free.

    Saturday, June 22, 2013 12:44 PM
  • Im going to call them and see when they are planning to release this update... i already have a case. I have tested recovery from a box w/o hotfix installed it does work with out issues. however if you try to recover an older backup on a server that has this hotfix install it will not see it.


    edit:

    oas case notes... Unable to add additional backup drive to server backup

    06/14/2013 19:47 From:Microsoft Support Subject:

    Closing the case Closing the case as asked by (xxxx).

    Unable to add additional backup drive to server backup

    06/13/2013 12:18 From:Microsoft Support Subject:under discussion.

    Unable to add additional backup drive to server backup

    06/09/2013 21:14 From:Microsoft Support Subject:Under discussion

     Unable to add additional backup drive to server backup 06/05/2013 21:33

    From:Microsoft Support Subject:Case under discussion

     Unable to add additional backup drive to server backup

    06/04/2013 18:51 From:Microsoft Support Subject:Case under discussion

     Unable to add additional backup drive to server backup

    05/31/2013 19:45 From:Microsoft Support Subject:Case under discussion

    • Edited by Daniel Walters1 Saturday, June 22, 2013 12:54 PM update case notes
    Saturday, June 22, 2013 12:45 PM
  • Has there been any movement on this? I am dealing with this now as well, and I have applied every update available as of 8/13/13. I try not be a Microsoft "basher", but this really is unacceptable, and truly a new low for even them. Are they just going to ignore this problem, or can we expect a resolution in the near future?

    Mike Mendes

    Tuesday, August 13, 2013 5:56 PM
  •  
    Hi Daniel,
    
    Thank you for using Microsoft Support and Microsoft Products.
    
    One of my Support Professional, xxxxxx contacted you.
    
    As per the last update you had query regarding availability of Hotfix. As update earlier, we will email you the details as soon as the Hotfix is available.  I have sent the query to concerned team and it will take few days to get an update  .
    
    Also I wanted to understand that Is there anything that the engineer could have done better .
    
    We will be closing this case as of now. You have mine and technical lead contact details.
    
    Please contact me at your convenience by phone or e-mail.
    
    Thank you for choosing Microsoft.
    
    Have a great day ahead!!
    

    • Edited by dw5304 Tuesday, August 13, 2013 6:05 PM
    Tuesday, August 13, 2013 6:05 PM
  • just received a call back from microsoft this hot fix has been publicly relased please see

    http://support.microsoft.com/kb/2833738

    Wednesday, August 14, 2013 8:58 PM
  • If you just want to back up your data, you can try free backup software. With the help of the free software, you can get your data backup easily. 

    http://www.backup-utility.com/free-backup-software.html
    Monday, August 19, 2013 2:43 AM
  • I ran this hotfix and, unfortunately, it didn't fix the problem with Server 2012.  The server still doesn't list a USB drive as a backup destination.  We use the Imation RDX cartridges for backups and it's aggravating that we can't get the Windows Server Backup to see the drive!!!!!!!!!
    Monday, August 26, 2013 7:05 PM
  • The access to the USB drive is restricted.  We want to use the Imation RDX backup cartridges so that the backups can be rotated into our vault.
    Monday, August 26, 2013 7:32 PM