none
FIM 2010 R2 RC upgrade error

    Question

  • I currently have FIM 2010 version 4.0.3531.2 installed with Sync and Portal. I figured I would do an in place upgrade to R2.

    I downloaded the latest R2 RC bits, when I run the FIM sync service setup.exe (or the *.msi) I immediately get the below error.

     -- Error 25201.Forefront Identity Manager Synchronization Service is installed on this computer. Remove it before installing Forefront Identity Manager Synchronization Service Evaluation.

    I've got the log file in case you're interested.  any ideas?

    Thanks,

    Peter

    Thursday, February 16, 2012 10:22 PM

Answers

  • Peter,
    Are you by any chance trying to upgrade FIM RTM EVAL sku to FIM R2 RC VL sku?
    When you change between SKUs (for example, EVAL to VL), a major upgrade is not supported. Therefore, if that is the case, you must uninstall RTM and install R2 RC.

    --Samer

    • Marked as answer by Peter Jalaff Monday, February 20, 2012 10:11 PM
    Friday, February 17, 2012 8:20 PM

All replies

  • I'm pretty sure the RC doco says upgrade not supported... The RTM release will support upgrade, but for now we're still in beta.

    http://www.wapshere.com/missmiis

    Friday, February 17, 2012 2:18 AM
  • Hi Carol,

    I've seen several places that mention that upgrades are OK.  http://technet.microsoft.com/en-us/library/hh322919(v=ws.10).aspx

    "Upgrade to FIM 2010 R2 RC is supported from all builds prior to, and including, build 4.0.3579.2."

    -Peter

    btw - big fan of yours, love your web site - it's one of the first places I go when I have questions.

    Friday, February 17, 2012 2:31 PM
  • Peter,
    Are you by any chance trying to upgrade FIM RTM EVAL sku to FIM R2 RC VL sku?
    When you change between SKUs (for example, EVAL to VL), a major upgrade is not supported. Therefore, if that is the case, you must uninstall RTM and install R2 RC.

    --Samer

    • Marked as answer by Peter Jalaff Monday, February 20, 2012 10:11 PM
    Friday, February 17, 2012 8:20 PM
  • Hi Samer,

    I believe you are correct the version I had was Eval, since this was on a demo. 

    I ended up uninstalling the current version and reinstalled with the latest RC version.  The good thing was that during install I pointed to the older databases and they were upgraded.  So all the configurations kept fine.

    Thanks for everyone's responses.

    -Peter

    Monday, February 20, 2012 10:11 PM