none
Problème pour la connectivité entre iPhone et Exchange Server 2003

    Question

  • Bonjour,
    Tout d'abord, veuillez m'escuser si je ne poste pas au bon endroit

    Configuration

    SBS 2003
    Exchange SP2
    Service Certiticate Server activé

    iPhone 3G (dernier firmware)

    Problèmatique
    A la demande de mes responsables, je dois permettre l'accès distant via iPhone à notre messagerie interne.
    J'ai suivi à peu prés tout ce que j'ai pu trouver comme ressources sur Internet à ce sujet mais je ne trouve pas la solution.

    En l'état :
    - J'accède bien à la messagerie de l'extérieur avec l'interface Web Outlook
    - IMAP4 fonctionne bien en interne ce qui semble prouver que je n'ai pas de problème de certificat (en interne du moins)
    - J'ai déjà suivi la note http://support.microsoft.com/default.aspx/kb/817379
    - J'ai utilisé l'utilitaire de configuration iPhone fourni par Apple.
    - J'ai suivi les différentes informations concernant le SSL, les certificats et l'authentification par formulaire

    Malgré tout cela il m'est toujours impossible d'accéder à ma messagerie Exchange avec mon iPhone.

    La seule chose qui pourrait jouer (mais j'ai testé sans succés), est que mon Site web principal est sur le port 8080.

    Quelqu'un pourrait-il m'aider ?

    Cordialement,
     
    Wednesday, September 30, 2009 2:32 PM

Answers

  • Problème résolu !

    Je vous fait un retour pour ceux qui rencontrerais, comme moi, le souci décrit dans ce post :

    En fait, il n'y a rien à toucher dans IIS ou autres sur un serveur SBS ! J'ai regarder de plus près, et en fait, j'était en SP1 pour exchange et non en SP2... j'ai donc procéder à la mise à jour, étant donné toutes mes manipulations se soldaient par un échec. Le fait d'avoir mis à jour Exchange en SP2 à résolu automatiquement le problème ! L'iphone à automatiquement synchronisé la boite mail, sans rien toucher. Donc vérifiez votre version :-)

    Bonne journée !
    Stef.
    Tuesday, January 26, 2010 3:47 PM

All replies

  • Il faut utiliser le client Active Sync fourni dans Iphone :
    Réglages
    Mail
    Compte / Exchange ActiveSync
    Données du compte
    Serveur : essayer de mettre tonserveur.tondomaine:8080 car par défaut il se connectera sur le port 443 en SSL et 80 sans SSL

    cdlt

    Ludovik DOPIERALA
    http://www.le-pi.com
    Thursday, October 01, 2009 9:22 AM
  • Bonjour Ludovik,

    Donc en l'occurence, c'est après ne pas être parvenu à faire la configuration dont vous parlez que j'ai fait quelques recherches et suis tombé sur les informations parlant des histoires de certificat et d'utilitaire de configuration de l'iPhone.

    L'utilitaire permettant uniquement d'importer un certificat en plus des autres paramètres de configuration.

    En gros, ma configuration est la suivante :

    Adresse : EMAIL REMOVED
    Serveur : http://mondomaine.dyndns.org:8080 (essayé également avec /exchnage, /oma, /owa et /exchnage-oma)
    domaine : mondomaine (local)
    Utilisateur : toto
    mot de passe : password


    Avec ou sans SSL

    Une autre idée ? ^^
    Tuesday, October 06, 2009 8:20 AM
  • J'en ai configuré par mal des Iphone et des Exchange Active Sync.... Mais qu'en 80 ou 443 pour le SSL je n'ai jamais essayé sur un autre port et je n'ai rien sous la main pour essayer...
    Une chose est certaine dans la conf classique 80 ou 443 ça fonctionne nickel...

    Revient sur une conf "standard" pour qu'on le fasse fonctionner puis on pourra regarde à modifier petit à petit

    cdlt

    Ludo

    Tuesday, October 06, 2009 9:02 AM
  • Je vais essayer mais ce n'est pas gagner d'avance car l'architecture intranet / Extranet est un peu "bordélique".

    A l'origine je n'avais fait qu'une configuration basique des serveurs en freelance mais un développeur a été utilisé pour dèvelopper les intranet et a fait une configuration qui est un peu compliquée.

    En l'état je n'ai pas le temps matériel pour remettre tout à plat avec mes autres fonctions maintenant que j'ai intégré la société.

    J'essaye de voir ce qui est faisable le plus rapidement possible.

    Tuesday, October 06, 2009 10:55 AM
  • Bon petite progression

    J'ai pu changer les ports http de manière à être sur 80 et 443

    Avec mon navigateur, je suis à présent capable de me connecter sur ma messagerie avec https://mondomain.dndns.org/exchange-oma qui est le répertoire sécurisé résultant d'une note de la kb pour SBS.

    Par contre toujours pas de connexion iPhone si je passe par la configuration standard.

    Pas mon câble avec moi donc je ferai le test avec l'utilitaire Apple demain pour pouvoir charger mon certificat client.
    Tuesday, October 06, 2009 1:51 PM
  • J'ai pu tester avec les certificats masi cela ne fonctionne pas.

    Je pense que mon problème vient de la gestion des certifficat.

    Lorsque j'active l'acceptation des certificas client dans IIS sur /Exchange-oma, j'obtiens un message sur navigateur me disant que le certificat n'a pas pu être vérifié.

    Peut-être un problème d'authorité de certification ?...

    PS : Après un nouveau test de création du compte manuellement sur mon iPhone, j'ai eu un message sur celui-ci me parlant également d'un problème de certificat.

    Le message exact sous IE7 est :

    Le certificat de sécurité présenté par ce site Web n’a pas été émis par une autorité de certification approuvée.
    Wednesday, October 07, 2009 11:47 AM
  • Ce message a lieu lorsque le certificat de l'autorité qui a créé ton certificat n'est pas présent sur le périphérique. Tu as certainement créé un certificat avec ton Windows mais pas acheté un certificat "public"

    Tu peux néamoins essayer de connecter sans SSL (tu décoches SSL dans Iphone)

    cdlt


    Ludo
    Wednesday, October 07, 2009 1:25 PM
  • Je viens de le faire :

    - Désactivation de SSL et Ignorer les certificats sur le dossier /exchange-oma
    - Désactivation de SSL sur le iPhone

    En résultat, connexion directe par navigateur Web et toujours impossible de se connecter avec le iPhone.
    Wednesday, October 07, 2009 1:41 PM
  • La conf Iphone :
    Réglages / Mail Contact Cal / Ajouter un compte / Microsoft Exchange
    Adresse ton email
    Serveur : le nom de serveur fqdn genre mail.serveur.com
    Domaine : Nom de domaine NetBIOS genre MONDOMAINE
    Nom utilisateur : ton login
    Mot de Passe : ....

    Utiliser SSL : 0

    ensuite tu lance la synchro...

    As tu quelques chose dans les log de ton serveur Exchange (Authentification refusé etc)

    cdlt,

    Ludovik DOPIERALA
    http://www.le-pi.com
    Thursday, October 08, 2009 9:29 AM
  • J'avais désactive les log dessus.
    Peux-tu m'indiquer lesquels sont à activer ?
    J'en ai activé certains mais aucun retour concernant des connexions distances
    Merci
    Thursday, October 08, 2009 12:58 PM
  • Les journaux web IIS liéés au site Exchange /
    L'obersaveteur d'événement de ton serveur Exchange sur lequel l'Iphone se connecte en Active sync Exchange

    Est-ce que ActiveSync fonctionne avec un smartphone ?

    cdlt

    Ludo
    Thursday, October 08, 2009 2:35 PM
  • Je n'ai pas de smartphone à disposition et ne peux donc tester cette solution.
    Monday, October 12, 2009 9:04 AM
  • ok et concernant les log Exchange ça donne quoi ?

    cdlt

    Ludo
    Monday, October 12, 2009 11:57 AM
  • Re,

    J'ai fait un test supplémentaire avec IMAP4 (qui fonctionne très bien en réseau local)

    J'ai donc sur mon iphone 1 compte Exchange et un compte IMAP4

    Lorsque je tente une connexion :

    - Erreur de connexion IMAP4 ID 1004 dans l'Event Log
    - Rien d'autre comme erreur de connexion.



    Monday, October 12, 2009 2:27 PM
  • Le détail de l'événement ?

    Avec Outlook Express ça fonctionne en IMAP de l'externe ?

    cdlt

    Ludo
    Tuesday, October 13, 2009 1:17 PM
  • Type de message d'info depuis que j'ai activé les rapport : ID 1030 référencé dans la KB comme à ignorer et lié a l'activation de certains logs.
    EMAIL REMOVED n'a pas réussi une opération sur le dossier /O=xxxxxx/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=OAB VERSION 471C9E9714AE74CFFD7F3F58AFD43AA8700002E dans la base de données "Premier groupe de stockage\Banque de dossiers publics (xxxxx)" car l'utilisateur n'avait pas les droits d'accès suivants :

    'Delete' 'Read Property' 'Write Property' 'Create Message' 'View Item' 'Create Subfolder' 'Write Security Descriptor' 'Write Owner' 'Read Security Descriptor' 'Contact'

    Pour IMAP de l'extérieur :

    En indiquant comme serveur SMTP et IMAP mon IP fixe externe, j'obtiens un message parlant d'un certificat invalide dont le CN ne correspond pas.

    Ceci ne m'empêche cependant pas de me connecter.
    Wednesday, October 14, 2009 9:38 AM
  • Et depuis l'extérieur quel est l'erreur avec Active Synch Exchange de l'Iphone ?

    cdlt

    Ludo

    Monday, October 19, 2009 9:29 AM
  • "Impossible de relever le courrier : La connexion au serveur à échoué."

    Avec Imap4 (sur iphone) ca me dis que mes identifiants sont incorrects. Bizarre vu qu'avec O.E ça fonctionne.

    Quid de cette histoire de certificat ?


    Monday, October 19, 2009 10:08 AM
  • normalement tu ne dois pas configurer un compte IMAP4 pour l'Iphone mais un compte Active Sync Exchange pour relevé tes emails comme je te l'ai indiqué dans un précédent post

    cdlt

    Ludo
    Monday, October 19, 2009 12:21 PM
  • J'ai juste testé les deux pour voir si justement le problème était purement Active Synch ou plus général.

    Thursday, October 22, 2009 10:13 AM
  • Nouveauté justement concernant le compte IMAP4.

    Lorsque je tente la connexion avec je vois bien immédiatement dans l'eventlog du serveur la tentative de connexion; Et d'ailleurs, ceci fonctionne à présent.

    Par contre toujours rien avec Active Sync Ecchange

    Thursday, October 22, 2009 10:30 AM
  • Que ce passe t-il avec Active Sync Exchange ? As tu résussit à le configurer sur l'Iphone.

    cdlt

    Ludo
    Thursday, October 22, 2009 12:26 PM
  • Oui c'est configuré; J'ai même testé différents chemins d'accés au dossiers exchange et différentes manières de saisir les identifiants.
    Thursday, October 22, 2009 1:25 PM
  • Thursday, October 22, 2009 1:36 PM
  • • Vérifiez qu’un certificat de serveur est installé sur le serveur Exchange frontal et activez le protocole SSL pour le répertoire virtuel Exchange ActiveSync (nécessite une authentification SSL de base).

    Cette partie est-elle obligatoire ? Si oui, peux-tu m'expliquer car j'ai un peu de mal avec les histoires de certificats.

    Pour le reste tout est déjà fait et je n'ai ISA.

     

     

    Thursday, October 22, 2009 2:11 PM
  • Non ce n'est pas obligatoire mais il ne faut que SSL soit à I dans la conf Active Sync Exchange de ton Iphone...

    cdlt

    Ludo
    Thursday, October 22, 2009 2:18 PM
  • J'ai bien fait cela.

    Par contre, je fini également par me poser des questions concernant le chemin que je dois indiquer comme serveur en liaison avec ce qui est appelé répertoire virtuel Exchange ActiveSync
    Thursday, October 22, 2009 2:43 PM
  • Bonjour à tous,

    Je rencontre trait pour trait le même problème chez un client à moi, et ce, avec la même config... :

    - Serveur en Windows SBS 2003
    - Exchange SP2

    - iPhone 3Gs

    j'ai également suivit le tuto suivant : http://support.microsoft.com/default.aspx/kb/817379

    Sur l'iPhone, la vérification du compte Exchange se déroule bien, par contre impossible synchroniser les messages, peu importe les modifications que j'effectue pour essayer de résoudre le pb (SSL ou pas...), j'obtient toujours la même erreur : "Impossible de relever le courier, La connexion au serveur à échoué."

    Tu à du nouveau sur ce problème Boris ?

    Merci à vous.
    Stef.
    Tuesday, January 26, 2010 1:46 PM
  • Problème résolu !

    Je vous fait un retour pour ceux qui rencontrerais, comme moi, le souci décrit dans ce post :

    En fait, il n'y a rien à toucher dans IIS ou autres sur un serveur SBS ! J'ai regarder de plus près, et en fait, j'était en SP1 pour exchange et non en SP2... j'ai donc procéder à la mise à jour, étant donné toutes mes manipulations se soldaient par un échec. Le fait d'avoir mis à jour Exchange en SP2 à résolu automatiquement le problème ! L'iphone à automatiquement synchronisé la boite mail, sans rien toucher. Donc vérifiez votre version :-)

    Bonne journée !
    Stef.
    Tuesday, January 26, 2010 3:47 PM
  • Bonsoir à tous. J' ai un problème a peu près similaire. Je m' occupe de l' informatique dans une petite mairie ou nous avons un sbs 2003 r2.

    Nous recevons les mx de notre fai directement dans l' exchange, tout fonctionne bien depuis plusieurs années.

    Le maire m' a demandé de connecté son iphone4 s sur l' exchange pour pouvoir synchroniser son calendrier (uniquement) quand il est a l' extérieur.

    J' ai donc relancé l' assistant de connexiont internet et messagerie et j' ai rajouté outlook mobile acces et outlook web accès dans les différentes options de connexion. j' ai ensuite générer un certificat ssl a partir de l' assistant sbs.

    Quand je configure exchange dans l' iphone je n' ai pas de message d' erreurs par contre je n' ai pas de synchronisation. En outlook web acces ça fonctionne, bien que j' ai un avertissement sur le certificat.

    est ce qu' il peut y avoir un rapport avec le sp2 d' exchange ou alors avec mon certificat.

    Lorsque je le test sur digicert j' ai un rapport ok pour dns, ok pour niveau de sécurité, ok pour date d' expiration par contre j' ai un message

     

    "Certificate does not match name mail.mondomaine.fr"

    est ce qu' il faut le régénérer

    Monday, November 28, 2011 5:36 PM