none
Surface Pro 2 + Surface Ethernet Adapter + Super slow PXE

    Question

  • Hi all

    Does anybody have any experience PXE booting the new Microsoft Surface Pro 2 with the Surface Ethernet Adapter?

    The download of the boot image takes like 5-10 minutes or more. I'm using SCCM 2012 SP1 CU3 and Server 2008 R2.

    All the other machines are PXE booting at normal speeds.

    I can get it working with USB boot media + Surface Ethernet Adapter and the speeds are not that slow then.



    Monday, November 25, 2013 5:54 PM

All replies

  • The main problem is the specs of the "USB Ethernet Adapter". That is IF what you are using and not the docking station. I too was also VERY disappointed to find it's only using USB 2.0 and the Ethernet is not even Gigabit!

    This link should give you some insight:
    http://www.speaktothegeek.co.uk/oliblog/2013/06/22/microsoft-surface-pro-usb-ethernet-adapter/

    This becomes more complicated when you have a large company using hundreds of Surface Pro and Surface Pro 2 and you need to image them (I'm assuming you need to do this also). This isn't even taking into account if you need to use the same adapter to image multiple devices and it has the MAC address hardcoded into it. I would have hoped it was more enterprise and used some sort of pass through from a chip possibly (Marvell, Intel?)

    -Ken
    (using SCCM 2007 & migrating to SCCM 2012)

    Monday, November 25, 2013 8:57 PM
  • Hi Ken

    Thanks for replying, I knew that the Surface Ethernet Adapter was only 100mbit and that is uses usb 2.0.
    But it shouldn't take that long to download the boot image. The download of the image when WinPE has loaded does not take that long.

    Have you tried PXE booting with it? How long does the download of the boot image take?

    Anyone else tried PXE booting with the Surface Ethernet adapter  and can say if what I'm experience is normal?

    Monday, November 25, 2013 9:11 PM
  • Your welcome.

    You may be having this problem as we had:
    http://www.david-obrien.net/2013/11/11/hotfix-available-configuration-manager-2012-r2/
    (with the original article from Johan Arwidmark who is amazing at OSD/MDT)

    Hotfix:
    http://support.microsoft.com/kb/2905002

    -Ken

    Monday, November 25, 2013 10:14 PM
  • Not applicable to me, I'm not using R2.
    Monday, November 25, 2013 10:16 PM
  • I've been running imaging tests as well, and this Ethernet Adapter is definitely not up to snuff. It takes HOURS to deploy from SCCM (with the R2 hotfix, as above.) 

    I haven't been able to get a good PXE boot (another story entirely) but using a USB boot image and a USB 2.0 hub to connect to SCCM, the performance is agonizingly slow.

    -P

    Tuesday, November 26, 2013 6:06 PM
  • We have the same issue!!!

    We are running System Center 2012 R2

    Friday, November 29, 2013 12:03 PM
  • We are also having the same issue and it seems related to the surface pro + ethernet adapter.  We are also on SCCM 2012 R2 + OSD (KB2905002) Hotfix and this specific issue only happens to our surface devices, not other workstations we are currently building. 

    Anyone gain any traction on this?

    Wednesday, December 11, 2013 7:34 PM
  • Well it seems that after we "hopefully" resolve the PXE boot issue and deal with the slow transfer (don't use the Microsoft USB 10/100 Ethernet), we have something else to possibly look forward to. UEFI seems to be another issue (at least on Surface Pro 2 within the task sequence and possibly the original models).

    http://www.deploymentresearch.com/Research/tabid/62/EntryId/130/Deploying-Surface-2-Pro-with-ConfigMgr-2012-SP1-CU3.aspx

    What is very interesting is the article mentioned if using SCCM 2012 SP1 CU1 on manually creating WinPE 5.0 by Niall Brady here: http://www.niallbrady.com/2013/10/09/how-can-i-manually-add-winpe-5-boot-images-to-system-center-2012-configuration-manager-sp1-cu3/

    This might be helpful to diagnose/resolve the PXE problems if the logs match.

    -Ken

    Thursday, December 12, 2013 3:13 PM
  • Did anyone ever get anywhere with this.  I've used the Surface dock, the Surface USB NIC, and a Lenovo USB 3.0 dock.  They all lead to 3+ hour-long deployments.  My other systems knock the task sequence out in 30 minutes or less. 

    Best, Jacob I'm a PC.

    Thursday, January 16, 2014 6:46 PM
  • I'm running WDS on Server 2012 and use the Surface Pro Ethernet adapter to PXE boot. It does take about 5 minutes to load the boot image, but after that I am looking at about a 15-20 minute deployment. Multicast seems to be working as well. This is imaging the Surface Pro 2 with a capture image I created.

    Thursday, January 23, 2014 5:45 PM
  • I too have this issue. I have noticed it on our Surface Pro Devices and Surface pro 2 devices. I am running all of the latest patches for SCCM 2012 R2 and am still having issues. I am attempting to PXE boot a Surface Pro 3 and am finding it taking 2+ hours to load the PE environment, however after the PE environment loads it is quick to finish the Task Sequence. Any more insight into this?
    Tuesday, July 01, 2014 11:02 PM
  • Is the behavior same for PCs in the same network segment as Surface devices?
    Wednesday, July 02, 2014 9:41 AM
  • My Surface Pro 2s still take around 2 hours to image.  We've started imaging Surface Pro 3s and they take no time at all.  I do not PXE boot those, we use a WinPE boot disk.  The entire build takes less than 20 minutes, now.  You may give it a try to see if it helps at all.

    Best, Jacob I'm a PC.

    Wednesday, July 02, 2014 8:28 PM
  • Repeating my question, is this behavior same for PCs in the same network segment as the Surface devices?

    Monday, July 07, 2014 12:32 PM
  • The Surface Pro and Surface Pro 2 show this behavior.  I have nothing else that take that long to image.  The odd thing is that the Surface Pro 3 is substantially faster.  Not much of a worry, but was kind of a nuisance. 

    Best, Jacob I'm a PC.

    Tuesday, July 08, 2014 12:58 AM
  • We have SCCM 2012 R2 and Surface Pro 2s - same issue takes about 10-15 minutes for the initial winpe boot over PXE.  Any other machine takes 2 minutes tops.  Even worse I just tried the Surface Pro 3 with the 100Mb Microsoft adaptor and it takes over an hour!!  Maybe it is an issue with certain switches... seems like it's negotiating 10Mb half duplex or something.  Our switches are Cisco though you'd expect they would have tested these scenarios.  Going to try one of the new Surface Ethernet Gigabit adaptors and see if any improvement.

    Frustrating!

    Tuesday, July 29, 2014 3:05 AM
  • I was having this same problem on new Surface Pro 3s, and I decided to try and install available firmware updates. I logged into the stock Windows environment, ran Windows Update once to install KB2969817, rebooted, and ran again to install firmware updates. After the installation was complete, I tried the PXE boot again, and it went MUCH faster. (From 1 hour+ before to the normal minute or two.) Hope this helps others having the same issue.
    Friday, August 08, 2014 3:49 PM