none
Slow Preformance & RsReportServer.Config

    Question

  • I have c# appliction with rdlc flle reports  > not using reportserver !

    the end user have only ReportViewer.exe install and  framework 4

    i have slow preformance on first time runing the report

    it's recomend to difine RecycleTime in RsConfig file

    the client computre don't have rsConfig file ( we using on sever the basic sql server express )

    do rdlc reports  using rsConfig ? 

    what the best way to solve slow preformance on first time only    in this case  (rdlc reports) ?


    ben frenkel

    Sunday, September 22, 2013 6:51 PM

All replies

  • I assume, you have a Dataset in your C# code that feeds RDLC file. Question is where is it talking time? Is it during Dataset population or is it during Report rendering. You can put a timer in your code and verify this.

    Depending on the findings, you can improve the report performance.

    Monday, September 23, 2013 5:35 AM
  • tank's for your repliy

    it's happen just on the first time  >  if i runing the report again it's work normal !

    on rdl reports it's happrning as well > recommended to define the recycletime ( rsConfig )

    on the back ground the reprot server agent is restarting !!!

    the agent is not runing on rdlc file > so the question is why it's happening  in rdlc reports ?

    ben


    ben frenkel


    • Edited by benf99 Monday, September 23, 2013 7:32 AM
    Monday, September 23, 2013 7:31 AM
  • Hi Ben,

    When we use a local processing mode ReportViewer control to display a client report definition (RDLC) file, all report processing is performed on the computer that hosts the application. All data used by the report must be provided by the host application. Since the RDLC reports are independent of a report server, they have nothing to do with the rsreportserver.config which stores settings that are used by Report Manager, the Report Server Web service, and background processing.

    Based on your scenario, the issue may be related to the custom application side. Besides, I suggest that you update the ReportViewer to the latest version and check the issue again. You can download the latest version of Report Viewer from Microsoft Download Center.

    Regards,


    Mike Yin
    TechNet Community Support

    Tuesday, September 24, 2013 2:25 PM
    Moderator