none
DHCP e segmentos de rede

    Question

  • Technet Masters,

     

    Eu estou passando por um problema que não passava antes com Windows 2000 Server e estou passando com o Windows Server 2003.

     

    Eu tenho uma rede com quase 300 computadores. Meu escopo está configurado de 172.16.0.x para 172.16.1.x com máscara classe B, 255.255.0.0.

     

    Os computadores do segmento 172.16.0.x enxergam todos os computadores na rede, acessa e tudo mais, mas o contrário não acontece corretamente.

     

    O que pode ser isto??? Pelo que vejo tem algo a ver com roteamento. Como devo proceder?

    Monday, April 16, 2007 2:28 PM

Answers

  • Acredito que vc tenha configurado alguma coisa errada, ainda mais levando em conta que aparentemente vc estava usando a classe B atendendo apenas 254 máquinas, como se fosse uma classe C. Então é melhor vc criar um novo escopo conforme mencionei no post anterior. Qualquer coisa crie um backup do seu DHCP antes, clicando com o botão direito no nome do sevridor e escolhendo Backup;

     

    Classifique,

    Paulo Dutra

    Monday, April 16, 2007 9:47 PM

All replies

  • Amigo,

    Vc possui dois segmentos de redes é isso? No DHCP vc está configurando o endreeço de roteador para cada segmento de acordo com o segmento? o que vc informou acima é uma unica rede, 172.16, pois a mascar está com 16 bits. Caso queira ter duas subredes vc deverá ter uma rede 172.16.x.x e outra 172.17.x.x

    Detalhe melhor sua infra para pdermos ajudá-lo.

     

    Classifique,

    Paulo Dutra

    Monday, April 16, 2007 5:27 PM
  • Não! É uma única rede.

     

    O meu range de IP inicial ia de 172.16.0.1 - 172.16.0.254/255.255.0.0, mas como aumentaram o nº de computadores, tivemos que aumentar o escopo para a rede 172.16.1.1 - 172.16.1.254/255.255.0.0.

     

    O problema é que estamos notando que os computadores do segmento 172.16.1.x não conseguem enxergar todos os PCs do segmento 172.16.0.x. Já verifiquei se poderia ser o Firewall, mas este recurso do XP fica desabilitado.

     

    Grato,

     

    Artur Aragão

    Monday, April 16, 2007 7:16 PM
  • Amigo,

    O problema está com a mascara de rede. Quantas máquinas vc precisa colocar no escopo?

    Crie um novo escopo com a faixa de ips de 172.16.0.1 até 172.16.1.254. por exemplo, com a mascara 255.255.0.0, configure os ips dos servidores DNS e roteador. Remova os outros escopos.

     

    Classifique,

    Paulo Dutra

    Monday, April 16, 2007 7:44 PM
  • Como????

     

    A máscara é esta mesma e o escopo também. Quer dizer que refazendo o mesmo escopo resolverei o problema?

    Monday, April 16, 2007 8:39 PM
  • Acredito que vc tenha configurado alguma coisa errada, ainda mais levando em conta que aparentemente vc estava usando a classe B atendendo apenas 254 máquinas, como se fosse uma classe C. Então é melhor vc criar um novo escopo conforme mencionei no post anterior. Qualquer coisa crie um backup do seu DHCP antes, clicando com o botão direito no nome do sevridor e escolhendo Backup;

     

    Classifique,

    Paulo Dutra

    Monday, April 16, 2007 9:47 PM
  • Paulo,

     

    Antes de realizar este procedimento, vou tentar ainda mais algumas coisas, pois os problemas que ocorrem não são em todos os PCs do seguimento 172.16.1.x.

     

    De qualquer forma, muito obrigado por todos os feed backs que me deu. Muito obrigado mesmo!

     

    Abraços!!!

    Tuesday, April 17, 2007 7:31 PM
  • Boa tarde Artur!

     

    Na sua 1ª rede você tem um servidor DHCP que atende os micros existentes nela. E a 2ª rede, onde os micros buscam os IP's? A comunicação entre as redes é feita por roteador?

    Se na rede 172.16.1.x, os micros estiverem tentando obter os IP's do servidor que está na outra rede, eles não vão conseguir. Isso porque os clientes DHCP utilizam broadcast para buscar concessões no servidor DHCP. E roteadores não encaminham broadcast, ao menos que tenham sido configurados.

    Se esse for o caso, você deve instalar na rede 172.16.1.x, um agente de retransmissão DHCP( Relay Agent ). O Relay Agent será o responsável em fazer as solicitações de concessão de IP's com o servidor DHCP da outra rede.

     

    Espero ter ajudado.

     

     

     

     

     

    Tuesday, April 17, 2007 7:34 PM
  • Artur,

    Estamos aqui para ajudar.

    Detalhe melhor o que está acontecendo para podemros ajudá-lo, que problema, quando ocorre, já verificou o logo de eventos?

    Post aqui as informações.

     

    Um abraço,

     

    Paulo Dutra

    Wednesday, April 18, 2007 12:53 AM
  • Paulo,

     

    Obrigado!

     

    Não sei se estou me expressando mal. Eu estou acompanhando esta situação remotamente, mas estou agendando para verificar o problema localmente.

     

    Eu deixei por conta de um outro funcionário o levantamento no log de eventos das estações de ambos os ranges de IP. Infelizmente só terei estas informações amanhã. A rede é única e como o nº de estações ultrapassa a reserva entre 172.16.0.1\16 ~ 172.16.0.254\16, tivemos que refazer o escopo com o range 172.16.0.1\16 ~ 172.16.1.254\16. Já utilizávamos assim com o domínio no Windows 2000 e funcionava muito bem. Realizamos migração do ambiente totalmete do zero e colocamos esta configuração como mencionado. Depois que algumas estações começarama pegar ips do range 172.16.1.x é que o problema ocorreu, mas em poucas estações. Foi instalado do zero uma esração para testes e o memo problema ocorreu.

     

    Grato,

     

    Artur Aragão

     

     

    Wednesday, April 18, 2007 3:25 AM