none
MDT 2012 : Unable to mount the WIM, so the update process cannot continue (RpcCommAddImage:(425) Received an unrecognized message id: 0xd0000022)

    Question

  • Hello

    I'm trying to "Update Deployment Share" in Deployment Workbench (2012).

    It fails with "Unable to mount the WIM, so the update process cannot continue"

    I have checked the following:
    - the file (winpe.wim) exists
    - the file is not read only
    - I am running as an administrator and have full rights (UAC is disabled)

    If I run ImageX /mount with reference to this file it gets to 100% and also fails
    The error it shows is :

    "Error mounting image."
    "Access is denied"

    I have full rights to the source and destination locations (so it can't be file permissions)

    If I specify the /logfile option with imagex I get : 

    [3532] [INFO] Mounting new image.wim <and then the source and destination locations>
    [3532] [INFO] WimServ process started for guid:<guid>. Id: 3968
    [3532] RpcCommAddImage:(425) Received an unrecognized message id: 0xd0000022
    [3532] WIMMountImageHandle:(956): Received an unregognized message id: 0xd0000022

    - I've  done a "repair" on the AIK etc.

    I also check user rights for "Manage Auditing and Security log" (which I'd seen in another post as possibly relevant) and confirmed my account has those rights.

    I've run process monitor but it doesn't show  any sign of "Access Denied" and I can't see any obvious cause for failure.

    Have used dir /r to check for alternative data streams in the file - none exist.

    I'm struggling to know what else to try to fix this - any suggestions ?!

    Imagex.exe and the associated wimgapi.dll that came with the AIK show as  Version: 6.1.7600.16385

    Thanks

    =AL

    • Edited by Alistg Wednesday, October 03, 2012 9:39 PM
    Wednesday, October 03, 2012 8:41 PM

Answers

  • Hi all,

    had exactly the same problem after a lockdown script (in lieu of GPO) was applied to an MDT server.  After much searching through the script i found thsi command:

    ntrights.exe -u "Administrators" -r SeChangeNotifyPrivilege

    applied "ntrights.exe -u "Administrators" +r SeChangeNotifyPrivilege" and all worked again

    Chris

    • Marked as answer by Alistg Thursday, January 10, 2013 9:24 AM
    Thursday, January 10, 2013 7:49 AM

All replies

  • Hi .. for me, both files have the same version number but still they are different. Try to replace the file in "Windows Imaging" with the one from System32.
    Monday, October 29, 2012 6:11 AM
  • Hi all,

    had exactly the same problem after a lockdown script (in lieu of GPO) was applied to an MDT server.  After much searching through the script i found thsi command:

    ntrights.exe -u "Administrators" -r SeChangeNotifyPrivilege

    applied "ntrights.exe -u "Administrators" +r SeChangeNotifyPrivilege" and all worked again

    Chris

    • Marked as answer by Alistg Thursday, January 10, 2013 9:24 AM
    Thursday, January 10, 2013 7:49 AM
  • Great work Chris !

    Thanks for the reply.

    best regards

    -AL

    Thursday, January 10, 2013 9:25 AM