none
2008 Print Server not showing

    General discussion

  • I just installed a new 64 bit 2008 R2 server.  I installed all the printers but can't see them unless I go directly to the share.  Example if I go to add printer, add a network printer it only shows the old print server and it's printers.  Which by the way is still installed until I can move everyone over.  Any reason why?

     

    Thanks!

    Thursday, March 03, 2011 8:45 PM

All replies

  • You would need to publish the printers to the AD in order for Add Printer to list them.  Add printer does not look at the print server until you give it the server name on 3rd page.
    Alan Morris Windows Printing Team
    Thursday, March 03, 2011 10:13 PM
  • Hi,

    Please feel free to let us know if there is any update on this issue.

    Thanks,

    Miles


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, March 07, 2011 1:56 AM
  • Not sure what your saying about 3rd page?  More help?

     

    Thanks

     

    Darrell

    Tuesday, March 08, 2011 4:22 PM
  • Sorry 2nd page of Add Printer.  You will not see the shared printers until you enter the server name there.
    Alan Morris Windows Printing Team
    Tuesday, March 08, 2011 4:48 PM
  • Windows 7 machine example add printer, add network printer a list of all of our old printers on the old printserver show up.  How do I get the new printserver to show up?

     

    Thanks again!

     

    Darrell

    Tuesday, March 08, 2011 5:37 PM
  • You set List in the directory in printer sharing.  Make sure you have the proper location field set or you will need to refine the search to look for a blank location. here's a pointer to the Windows 2000 knowledge base article on this

    http://support.microsoft.com/kb/234619


    Alan Morris Windows Printing Team
    Tuesday, March 08, 2011 7:04 PM
  • I am having the exact issue as described here - I have an old 2003 print server and a new 2008 R2 print server - all printers on both servers are shared out and are set to "list in the directory" (I checked the printer event log on the 2008 box and the event 332 is listed when I check the "list" box)

    When I go to an XP box and add a network printer, all printers from both servers are listed - when I go to a Win7 box, only the printers from the old server are listed and I have to use the "select a shared printer by name" box and enter the 2008 server name before its printers are available to add.

    Any suggestions on why this is happening would be apprecaited.

    Is there an issue with having the 2 servers on the same network?

    Thanks... Tim

    Thursday, March 17, 2011 5:16 PM
  • I have the same problem as TJMM. What gives?
    Monday, May 02, 2011 1:24 PM
  • How do you have the location field configured on the Windows 7 machine?  Are you pulling this information from AD or do you have this preconfigured through group policy?

    The default configuration is to pull the location from the Site data assigned to the subnet and match this with the location string configured on the shared printer.


    Alan Morris Windows Printing Team
    Monday, May 02, 2011 4:03 PM
  • hi, ich have the same problem. any news?
    Monday, May 23, 2011 2:04 PM
  • Hi,

    I have the same problem as well. Does anyone have a solution yet?

    Tuesday, September 13, 2011 1:33 PM
  • If you have more that 20 printers in the directory, you will need to make a policy setting to show all the printers.
    Alan Morris Windows Printing Team
    Tuesday, September 13, 2011 11:23 PM
  • Hi Alen,

    which policy do you mean?

    Wednesday, September 14, 2011 6:08 AM
  • This worked for me.  I had 'List in the directory' checked on the 'Sharing' tab. Also, when if I right click on a printer from the Printers list in Print Management it has the option to 'Remove from Directory', which tell me it is already added.  However, when I select all printers (CTRL A) and right click I can choose 'List in Directory'.  By doing that, they now show up when browsing to add a printer from a client workstation.

    To recap, select all printers (CTRL A) and right click I can choose 'List in Directory'.

    Wednesday, December 07, 2011 8:05 PM
  • This worked for me.  I had 'List in the directory' checked on the 'Sharing' tab. Also, when if I right click on a printer from the Printers list in Print Management it has the option to 'Remove from Directory', which tell me it is already added.  However, when I select all printers (CTRL A) and right click I can choose 'List in Directory'.  By doing that, they now show up when browsing to add a printer from a client workstation.

    To recap, select all printers (CTRL A) and right click I can choose 'List in Directory'.


    Mlbasso; this worked perfectly for me!  Now just waiting for replication to take place.
    Monday, December 19, 2011 9:53 PM
  • mlbasso, your instructions worked for me as well.  This happened to us after adding a new domain controller at a remote location.  We had some sync issues, and I think somewhere during the process the printers were all removed from the directory by the new DC.

    Doing this re-added them all without issue. Thanks!

    Tuesday, June 25, 2013 1:56 PM