none
Windows Server 2012 - Error 0x80070079: The semaphore timeout period has expired

    Question

  • I am trying to copy files between Windows Server 2012 servers and get the infamous: Error 0x80070079: The semaphore timeout period has expired

    So far after reviewing about 20 previous postings regarding this error, I have not found any real answers.  The problem probably has a simple solution in my case - simply increase the Timeout Period length to accommodate larger files (e.g. > 200GB VHDX and VHD files). 

    How do I Increase the Timeout Period to allow more time for transferring larger files? 

    This error doesn't appear to be permanent as usually clicking the "retry" button appears to work.  However, when the error happens, I question the integrity of the file copy completed after I retry.

    I really think that, by now, file copy between servers should be a mature and solid feature of the Windows operating system.

    Config:  Windows 2012 to Windows 2012 Standard Edition, all current Windows updates, hard wired, static IPv4 addresses.

    One suspect is that a Windows Storage Manager Volume with "Thin" provision is receiving the files being copied.  I suspect the timeout occurs when the receiving server needs to increase the storage size.  This is why I think simply increasing the timeout value will prevent the timeout error condition.

    Sunday, July 28, 2013 8:22 PM

All replies

  • Hi,


    It could be caused by bad clusters on the disks. Run CHKDSK with elevated privilege first. Also try run the vendor’s diagnosis tool to scan the disk.


    TechNet Subscriber Support |If you have any feedback on Technet forum, please contact tnmff@microsoft.com.

    Monday, July 29, 2013 7:19 AM
    Moderator
  • Did you ever try this in Windows Server 2012? 

    1) In the Windows File Explorer, select the hard drive, Right click, select Properties, then select the Tools tab and click the Check button in the Error Checking section.  The result is a friendly dialog:

    However, I still ran CHKDSK manually with the following clean results:

    C:\Users\Administrator>chkdsk d:
    The type of the file system is NTFS.
    Volume label is HVOL.

    WARNING!  F parameter not specified.
    Running CHKDSK in read-only mode.

    CHKDSK is verifying files (stage 1 of 3)...
      1400832 file records processed.
    File verification completed.
      18 large file records processed.
      0 bad file records processed.

    CHKDSK is verifying indexes (stage 2 of 3)...
      1928132 index entries processed.
    Index verification completed.
      0 unindexed files scanned.
      0 unindexed files recovered.

    CHKDSK is verifying security descriptors (stage 3 of 3)...
    Security descriptor verification completed.
      263650 data files processed.

    Windows has scanned the file system and found no problems.
    No further action is required.

       7340413 MB total disk space.
       2522794 MB in 1135049 files.
        281076 KB in 263652 indexes.
             0 KB in bad sectors.
       1696355 KB in use by the system.
         65536 KB occupied by the log file.
       4815688 MB available on disk.

          4096 bytes in each allocation unit.
    1879145983 total allocation units on disk.
    1232816175 allocation units available on disk.

    -----------

    I would really like to try increasing the Semaphore Timeout period to prevent the Windows File Explorer failures copying large files.  How do I increase the Semaphore Timeout period?

    Monday, July 29, 2013 1:29 PM