none
"Pipe Endpoint Error" - Never Saw This Error Before

    Question

  • Hello -

    I'm getting a strange error from within Data Tools whenever I try to test my SSRS report which i'm developing, i've never seen this before -

    "The pipe endpoint 'net.pipe://localhost/PreviewProcessingService6268/ReportProcessing' could not be found on your local machine"

    Can someone tell me what this means and how to fix it?  I'm not finding much about it online. 

    Thanks

    Tuesday, August 05, 2014 6:37 AM

Answers

  • Hi AvenueStuart,

    According to the error message, the issue can be caused by Net.Pipe Listener Adapter Windows service is not started or the SPN for the report server is not registered when Kerberos authentication is enabled. So, to fix this issue, please refer to the following tips:

    • Start the Net.Pipe Listener Adapter services.
      1. Press WinKey+R , input “services.msc” in the Run box, and press enter.
      2. In the local services list, find the “Net.Pipe Listener Adapter”. If it is stopped, start it. If it is started, restart it.
    • Please run the following command to register a Service Principal Name (SPN) for a Report Server:
      Setspn -s http/<computername>.<domainname>:<port> <domain-user-account>


    References:
    Similar issue
    Register a Service Principal Name (SPN) for a Report Server

    Hope this helps.

    Thanks,
    Katherine Xiong


    Katherine Xiong
    TechNet Community Support

    Wednesday, August 06, 2014 6:36 AM
    Moderator