none
Virtual App Extensions to set Default mail client

    Question

  • I sequenced Office 2010 with Appv 5.0, its working fine. i want to set the virtual outlook as default mail client. i edit the configuration xml file and add the below  content inside the subsystem tags.

    <SoftwareClients Enabled="TRUE">  
           <ClientConfiguration EmailEnabled="true" />
            <Extensions>
             <Extension Category="App-V.SoftwareClient">
              <SoftwareClients>
       <EMail MakeDefault="true">
                 <Name>Outlook Email</Name>
                 <Description>An Email Client</Description>
                 <DefaultIcon>[{AppVPackageRoot}]\Office14\OUTLOOK.EXE,0</DefaultIcon>         
                 <ShellCommands>
                  <ApplicationId>[{AppVPackageRoot}]\Office14\OUTLOOK.EXE</ApplicationId>
                  <Open>"[{AppVPackageRoot}]\Office14\OUTLOOK.EXE" -mail</Open>
                 </ShellCommands>
                 <MAPILibrary>[{AppVPackageRoot}]\Office14\OUTLOOK.EXE\mapi.dll</MAPILibrary>  
                 <MailToProtocol> 
                  <Description>Email URL</Description> 
                  <EditFlags>2</EditFlags>                 

    <DefaultIcon>[{AppVPackageRoot}]\Office14\OUTLOOK.EXE,0</DefaultIcon>
                  <ShellCommands>
                    <ApplicationId>[{AppVPackageRoot}]\Office14\OUTLOOK.EXE</ApplicationId>
                    <Open>"[{AppVPackageRoot}]\Office14\OUTLOOK.EXE" /email "%1"</Open>
                  </ShellCommands>
                </MailToProtocol>
              </EMail>
              </SoftwareClients>
         </Extension>
        </Extensions>
       </SoftwareClients>

    when i tried to import this xml file, getting "The configuration did not contain well formed Appv configuration XML. please check the Management server event log" and there is no useful info in the mgmt server event log. please help me to fix this.

    Friday, September 27, 2013 9:32 PM

All replies