none
USDB.dbo.tbSchemaVersion

    Question

  • 2013-07-02 13:22:40  Postinstall started
    2013-07-02 13:22:40  Detected role services: Api, UI, WidDatabase, Services
    2013-07-02 13:22:40  Start: LoadSettingsFromParameters
    2013-07-02 13:22:40  Content local is: True
    2013-07-02 13:22:40  Content directory is: C:\WSUS
    2013-07-02 13:22:40  SQL instname is:
    2013-07-02 13:22:40  End: LoadSettingsFromParameters
    2013-07-02 13:22:40  Start: Run
    2013-07-02 13:22:40  Configuring content directory...
    2013-07-02 13:22:40  Configuring groups...
    2013-07-02 13:22:40  Starting group configuration for WSUS Administrators...
    2013-07-02 13:22:40  Found group in regsitry, attempting to use it...
    2013-07-02 13:22:43  Writing group to registry...
    2013-07-02 13:22:43  Finished group creation
    2013-07-02 13:22:43  Starting group configuration for WSUS Reporters...
    2013-07-02 13:22:43  Found group in regsitry, attempting to use it...
    2013-07-02 13:22:43  Writing group to registry...
    2013-07-02 13:22:43  Finished group creation
    2013-07-02 13:22:43  Configuring permissions...
    2013-07-02 13:22:43  Fetching content directory...
    2013-07-02 13:22:43  Fetching ContentDir from registry store
    2013-07-02 13:22:43  Value is C:\WSUS
    2013-07-02 13:22:43  Fetching group SIDs...
    2013-07-02 13:22:43  Fetching WsusAdministratorsSid from registry store
    2013-07-02 13:22:43  Value is S-1-5-21-3128221918-321857698-959514307-1001
    2013-07-02 13:22:43  Fetching WsusReportersSid from registry store
    2013-07-02 13:22:43  Value is S-1-5-21-3128221918-321857698-959514307-1002
    2013-07-02 13:22:43  Creating group principals...
    2013-07-02 13:22:43  Granting directory permissions...
    2013-07-02 13:22:43  Granting permissions on content directory...
    2013-07-02 13:22:43  Granting registry permissions...
    2013-07-02 13:22:43  Granting registry permissions...
    2013-07-02 13:22:43  Granting registry permissions...
    2013-07-02 13:22:43  Configuring shares...
    2013-07-02 13:22:43  Configuring network shares...
    2013-07-02 13:22:43  Fetching content directory...
    2013-07-02 13:22:43  Fetching ContentDir from registry store
    2013-07-02 13:22:43  Value is C:\WSUS
    2013-07-02 13:22:43  Fetching WSUS admin SID...
    2013-07-02 13:22:43  Fetching WsusAdministratorsSid from registry store
    2013-07-02 13:22:43  Value is S-1-5-21-3128221918-321857698-959514307-1001
    2013-07-02 13:22:43  Content directory is local, creating content shares...
    2013-07-02 13:22:43  Creating share "UpdateServicesPackages" with path "C:\WSUS\UpdateServicesPackages" and description "A network share to be used by client systems for collecting all software packages (usually applications) published on this WSUS system."
    2013-07-02 13:22:43  Deleting existing share...
    2013-07-02 13:22:43  Creating share...
    2013-07-02 13:22:43  Share successfully created
    2013-07-02 13:22:43  Creating share "WsusContent" with path "C:\WSUS\WsusContent" and description "A network share to be used by Local Publishing to place published content on this WSUS system."
    2013-07-02 13:22:43  Deleting existing share...
    2013-07-02 13:22:43  Creating share...
    2013-07-02 13:22:43  Share successfully created
    2013-07-02 13:22:43  Creating share "WSUSTemp" with path "C:\Program Files\Update Services\LogFiles\WSUSTemp" and description "A network share used by Local Publishing from a Remote WSUS Console Instance."
    2013-07-02 13:22:43  Deleting existing share...
    2013-07-02 13:22:43  Creating share...
    2013-07-02 13:22:43  Share successfully created
    2013-07-02 13:22:43  Finished creating content shares
    2013-07-02 13:22:43  Configuring WID database...
    2013-07-02 13:22:43  Configuring the database...
    2013-07-02 13:22:43  Establishing DB connection...
    2013-07-02 13:22:43  Checking to see if database exists...
    2013-07-02 13:22:43  Database exists
    2013-07-02 13:22:43  Switching database to single user mode...
    2013-07-02 13:22:43  Loading install type query...
    2013-07-02 13:22:43  DECLARE @currentScriptVersion   int
    DECLARE @currentDBVersion       int
    IF NOT EXISTS(SELECT * FROM sys.databases WHERE name='SUSDB')
    BEGIN
        SELECT 1
    END
    ELSE
    BEGIN
        SET @currentScriptVersion = (9200 + 16384)
        SET @currentDBVersion = (SELECT SchemaVersion FROM SUSDB.dbo.tbSchemaVersion WHERE ComponentName = 'CoreDB')
        IF @currentDBVersion < 926
        BEGIN
            SELECT 3
        END
        ELSE IF @currentDBVersion < @currentScriptVersion
        BEGIN
            SELECT 2
        END
        ELSE IF @currentDBVersion = @currentScriptVersion
        BEGIN
            SELECT 0
        END
        ELSE
        BEGIN
            SELECT 4
        END
    END

    2013-07-02 13:22:43  System.Data.SqlClient.SqlException (0x80131904): Invalid object name 'SUSDB.dbo.tbSchemaVersion'.
       at Microsoft.UpdateServices.DatabaseAccess.DBConnection.DrainObsoleteConnections(SqlException e)
       at Microsoft.UpdateServices.DatabaseAccess.DBConnection.ExecuteGetSingleResult()
       at Microsoft.UpdateServices.Administration.ConfigureDB.GetInstallType()
       at Microsoft.UpdateServices.Administration.ConfigureDB.ConnectToDB()
       at Microsoft.UpdateServices.Administration.ConfigureDB.Configure()
       at Microsoft.UpdateServices.Administration.PostInstall.Run()
       at Microsoft.UpdateServices.Administration.PostInstall.Execute(String[] arguments)
    ClientConnectionId:d72e1c6d-e3b5-43fd-b783-4f6082c0957d
    Tuesday, July 02, 2013 5:55 AM

Answers

  • 2013-07-02 13:22:43  System.Data.SqlClient.SqlException (0x80131904): Invalid object name 'SUSDB.dbo.tbSchemaVersion'.

    Looks like the database that is present is not the one that's expected.

    The logfile shows us that a version of WSUS previously existed on this machine prior to running the installation, so maybe it would be good for you to give us the background of how you got here?


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Monday, July 08, 2013 1:06 AM

All replies

  • 2013-07-02 13:22:43  System.Data.SqlClient.SqlException (0x80131904): Invalid object name 'SUSDB.dbo.tbSchemaVersion'.

    Looks like the database that is present is not the one that's expected.

    The logfile shows us that a version of WSUS previously existed on this machine prior to running the installation, so maybe it would be good for you to give us the background of how you got here?


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Monday, July 08, 2013 1:06 AM
  • 2013-07-02 13:22:43  System.Data.SqlClient.SqlException (0x80131904): Invalid object name 'SUSDB.dbo.tbSchemaVersion'.

    Looks like the database that is present is not the one that's expected.

    The logfile shows us that a version of WSUS previously existed on this machine prior to running the installation, so maybe it would be good for you to give us the background of how you got here?


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Wow Lawrence, the way you connected those dots inspired me to go back and pay attention to my own log file.  I was able to work through the relatively simple issue and my WSUS is now up and running.

    Thanks!

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/e1003863-e331-46da-8803-e8625bb6324b/server-2012-wsus-postdeployment-configuration-fails-comprehending-the-log-file


    Tuesday, July 23, 2013 9:15 PM