none
unattend unsecurejoin=true not going to proper OU

    Question

  • with my unattend file my machines are joining the domain but they are not going to the proper OU.  Is this because I have unsecurejoin set to true?  If not...any idea what Im missing?  Thanks!

    settings pass="specialize">
            <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Identification>
                    <JoinDomain>domain.local</JoinDomain>
                    <MachineObjectOU>OU=AdminWorkstations,OU=Workstations,DC=domain,DC=local</MachineObjectOU>
                    <UnsecureJoin>true</UnsecureJoin>
                    <Credentials>
                        <Domain>domain.local</Domain>
                        <Password>XXXXXXX</Password>
                        <Username>install</Username>
                    </Credentials>
                </Identification>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>*</ComputerName>
                <TimeZone>Eastern Standard Time</TimeZone>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="catalog:c:/documents and settings/administrator.mapcom/desktop/win7wim64/install_windows 7 professional.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    I know for the unsecure join that I dont need the credential section in there.  I just tried that out to see if it would use those credentials to put the computer in the correct domain...

    Tuesday, December 31, 2013 4:06 PM

All replies

  • Hi,

    Based on my knowledge, unsecurity join is not related to your issue.

    We can check  the netsetup.log in C:\Windows\debug to see what happened during the domain join process.

    Please upload this log with SkyDrive.

    http://windows.microsoft.com/en-us/skydrive/add-photos-files-faq

    Thanks!


    Andy Altmann
    TechNet Community Support

    Wednesday, January 01, 2014 9:37 AM
    Moderator
  • In the debug folder it looks like it is going to the right OU but then on the setupact log file in Panther you can see it going to Computers. This is where I am getting confused. What is the difference in these log files?

    https://skydrive.live.com/redir?resid=591061860C0B118!133&authkey=!AGKRdckbmqQMR-Y&ithint=folder%2c.LOG

    Thursday, January 02, 2014 2:14 PM
  • I tried this as well...

    To grant these permissions

    1. In Active Directory, open Users and Computers.
    2. Right-click the OU where you are creating the prestaged computer accounts, and select Delegate Control.
    3. On the first screen of the wizard, click Next.
    4. Change the Object Type to include Computers.
    5. Add the computer object of the Windows Deployment Services server, and then click Next.
    6. Select Create a Custom task to delegate.
    7. Select Only the following objects in the folder.
      1. Select the Computer Objects check box.
      2. Select Create selected objects in this folder.
      3. Click Next.
    8. In the Permissions box, select the Write all Properties check box.
    9. Click Finish.

    This did not fix the OU issues.

    Thursday, January 02, 2014 2:20 PM