none
IE8 - Disable "Manage Add-On" pop-up at first launch for new users

    Question

  • Hello Technet!


    I'm here because of a anoying problem with IE8 Manage Add-On pop-up at first login of new users.
    Here is what I want to disable :

    I've already tried to create a GPO, with the following settings :

    Method #1: Using Group Policy Editor

    Using Group Policy Editor is probably the best method, because it can be used either locally, on one computer, or in an Active Directory environment by utilizing the GPO power.

    1. Press Start button + R (the Run command), type gpedit.msc and press Enter to launch the Group Policy Editor.

    Note: In an Active Directory environment, open gpmc.msc and either edit an existing GPO, or create a new one and link it to the domain level, or to an OU of your choice.

    2. In the left pane, expand User Configuration > Administrative Templates > Windows Components > Internet Explorer.

    3. On the right pane, double-click on “Prevent performance of First Run Customize settings". A new settings window will open up.

    4. Set the value to “Enabled”.

    5. In the options section you must choose one of the two options from the dropdown menu:

    • Go directly to “Welcome To IE” page
    • Go directly to home page

    You need to choose one of the two, otherwise the configuration will not work.

    The first option configures IE to skip the Welcome screen and go directly to your home page, whatever it is.

    The second option configures IE to skip the Welcome screen and and go to the “Welcome to Internet Explorer” page directly.

    Disable Welcome Screen in IE8 & IE9 via Group Policy Editor

    6. Click Apply to save the settings then click OK and close the Group Policy Editor window.

    7. Press Start button + R (the Run command) and type gpupdate /force and press Enter to refresh the Group Policy on the computer.

    (I also applied it to the Computer's settings in case, but with same result)

    I've also tryed the .reg file :

    Method #2: Using Registry Editor

    You can use this method to either manually configure one computer, or generate a .REG file to import it on other machines.

    Warning:

    This document contains instructions for editing the registry. If you make any error while editing the registry, you can potentially cause Windows to fail or be unable to boot, requiring you to reinstall Windows. Edit the registry at your own risk. Always back up the registry before making any changes. If you do not feel comfortable editing the registry, do not attempt these instructions. Instead, seek the help of a trained computer specialist.

    1. Press Start button + R to open run command dialog box. Type regedit and press Enter to open the Registry Editor. You may be prompted with a UAC prompt, click "Yes".

    2. Navigate to the following path:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\Main

    Note: The above branch does not exist by default, and has to be created manually, or by running the .REG file available at the end of this article.

    3. Right click on the right pane and select New > DWORD (32-bit) Value.

    4. Enter DisableFirstRunCustomize.

    5. Right-click on the new entry it and choose “Modify”.

    6. Modify its DWORD (32-bit) Value to “1” (without the quotes) and click OK.

    Disable Welcome Screen in IE8 & IE9 via Registry Editor

    7. Exit the Registry Editor.

    Note: You can use this .REG file to import the same setting to your computer:

    Windows Registry Editor Version 5.00

    ;Disable IE9 Welcome Screen

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\Main]
    "DisableFirstRunCustomize"=dword:00000001

    Copy the above text into a new text file, and save it as "DisableIEWelcome.reg".


    But everytime I'm first connecting to the test computer with my user, I have taht f****ng pop that shows up.
    Is there any chance someone could help me with this ?

    Thanks.

    TiGrOu.

    Thursday, September 12, 2013 2:06 PM

All replies

  • Hi TiGrOu,

    Base on my understanding, the window of "Manage Add-On" pop up when new users log in the first time. Right?

    Please try the following method to solve this issue:

    1. Click Start, and type regedit in the search box, and then press Enter to launch Register Editor.
    2. Expand to HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders.
    3. Modify the value data of value App data to %USERPROFILE%\Application Data.
    4. Click Start, and type gpedit.msc in the search box, and then press Enter to launch Group Policy Editor. Note: In an Active Directory environment, open gpmc.msc and either edit an existing GPO, or create a new one and link it to the domain level, or to an OU of your choice.
    5. In the left pane, expand User Configuration > Preferences > Windows Settings > Register.
    6. Right-click Register, and click New >Registry Item.
    7. In the General tab, Action is Update, and Hive is HKEY_USERS, and Key Path is HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders, and then click Select.
    8. In the Common tab, check Apply once and do not reapply, and then click Apply and OK.
    9. Click Start, and type cmd in the search box, and then press Enter, type gpupdate /force and press Enter to refresh the Group Policy.

    NoteIncorrectly editing the registry may severely damage your system. Before making changes to the registry, you should back up any valued data.

    For your information, please refer to the following links to get more help:

    http://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/search-provider-and-manage-add-ons-pop-up-issue/a57d045b-e770-44a0-a7af-77d69f321b16

    http://support.microsoft.com/kb/256986  

    http://technet.microsoft.com/en-us/library/cc962614.aspx

    http://technet.microsoft.com/en-us/library/cc772371.aspx

    Regards,

    Lany Zhang

    Monday, September 16, 2013 6:14 AM
  • Hi Lany Zhang,

    Many thanks for your reply.

    I've tried it on one of our domain computer to see if the registry changes could affect the Manage Add-On pop up showing up at first login (you were understanding right)

    The only thing it made on the selected computer is creating temporary profiles now everytime I'm connecting with a user that is not the Computer Administrator's.

    Any idea ?

    TiGrOu.

    Monday, September 16, 2013 8:23 AM
  • Hi TiGrOu,

    “HKEY_USERS\.DEFAULT” is the template for any new user profile. It is stored in c:\users\default and the file is ntuser.dat.  Therefore, applying on this hive will make the change to all newly logged on user profiles. It does not affect the current user however.

    Regards,

    Lany Zhang

    Tuesday, September 17, 2013 4:11 PM
  • “HKEY_USERS\.DEFAULT” is the template for any new user profile. It is stored in c:\users\default and the file is ntuser.dat.

    OMG... epic failure...

    No, it is NOT a template for new profiles, it is a registry symlink to HKU\S-1-5-18 and that's the hive that represents HKCU for local system. It is stored in %windir%\system32\config\systemprofile\ntuser.dat

    If you want to modify the default user profile registry, you have to load %systemdrive%\users\default\ntuser.dat, make your modifications and unload the structure again.


    Martin

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))

    Restore the forum design - my user defined Cascading Style Sheet!

    Tuesday, September 17, 2013 8:07 PM
  • Hi Technet,

    Still no idea for this ?

    Many thanks.

    TiGrOu.

    Monday, October 14, 2013 7:30 AM