none
SSRS and WSS 3.0 64 Bit Sp2

    Question

  • Hello all.

     

    We are trying to integrate SSRS report viewing into our current wss 3.0 topology.

     

    I keep getting 401 errors when I try to define the reports service url in central admin with windows authentication.

     

    Our Reporting Server is SQl 2008 R2. I have went through many, many articles and walk throughs already. I think i am fundamentally missing something and I think it has to do with configuring the SPN's.

    So, I am hoping someone who knows a little more about the guts of this can help.

     

     

    Thanks in advance!

    • Moved by Mike Walsh FIN Thursday, January 19, 2012 6:07 PM SSRS = BI (From:SharePoint - Setup, Upgrade, Administration and Operation (pre-SharePoint 2010))
    Thursday, January 19, 2012 5:54 PM

All replies

  • Ok, I can get the intergration section in WSS 3.0 to take my report server URL with out the 401 error. Now, when I try to browse reports, I get the 401 error.

     

    I checked the security log on the SSRS box and I find this;

     

    An account was logged off.

    Subject:
        Security ID:        ANONYMOUS LOGON
        Account Name:        ANONYMOUS LOGON
        Account Domain:        NT AUTHORITY
        Logon ID:        0xbf20896

    Logon Type:            3

    This event is generated when a logon session is destroyed. It may be positively correlated with a logon event using the Logon ID value. Logon IDs are only unique between reboots on the same computer.

     

     

    Now, I am sure this is me trying to browse the directory, but it is trying to hit it with anonymous auth versus kerberos.

     

    Please advise.

    Friday, January 20, 2012 7:59 PM
  • Hi James,

    Did you disable loopback check (http://blogs.technet.com/b/sharepoint_foxhole/archive/2010/06/21/disableloopbackcheck-lets-do-it-the-right-way.aspx)

    Could you review your SSRS installation with this link (http://technet.microsoft.com/en-us/library/cc263449(office.12).aspx)

    HTH

    Thanks,
    Skancharla

    Monday, January 30, 2012 7:57 PM