none
DPM 2010 swprv hangs stopping All RP's fail

    Question

  • I have been battling a single 2003 server getting any type of backup consistency... I have read all the posts about re-registering .dll's etc... I have removed the agent re-installed the agent.. check registry keys etc.. etc.. the agent is on the lastest version and DPM is also fully patched (plus a couple unpublished hotfixes from MS with regard to MMC console crashes). The file system backups fail after a day or so (work once maybe twice) with the swprv (Microsoft Software Shadow Copy Provider) being hung in a "Stopping" state. The only fix is to use process explorer to kill the svchost.exe -swprv process or restart the server. In addtion I cannot get any systemstate backup at all on this box.. though I can manually run dpmsystemstatebackup.cmd (path) and it runs just fine.. I have looked at the logs and they are cryptic at best the actual error is something like this : 30072 Any ideas ?
    Steve Lithgow
    Tuesday, January 03, 2012 3:58 PM

All replies

  • Hi Steve,

    Do you have one or two issues?

    I see that SWPRV hangs and the workaround is to kill it via Process Explorer to get things going again.

    Once you do that does System State works until that hang occurs again?


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    Tuesday, January 03, 2012 8:31 PM
  • I just assumed they are related.... so really two problems.. Right now I have the first issue swprv hanging in a "Stoppping" state... As I stated if I kill the process the next backup will work. For now I have removed systemstate protection since it will not work.. at all.. regardless of the state of swprv. Hope that clarifies a bit...
    Steve Lithgow
    Wednesday, January 04, 2012 3:56 PM
  • Hi Steve,

    Create a post here http://social.technet.microsoft.com/Forums/en-US/winservergen/threads

    And see if you can get help with SWPRV component.

    Can you post the whole error message (from Monitoring/Jobs)  that you get when trying to run System State backup?


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    Wednesday, January 04, 2012 6:32 PM