none
Blank page when a tablix is hidden conditionally in Report Services 2008 R2

    Question

  • I have a report that contains an additional tablix at the end. This tablix has a condition that keeps it hidden unless there is actually data to show. the problem is that when the report is run and the tablix is hidden there is a blank page at the end of the report. In addition to this when rendered into Excel (required) there is a blank worksheet at the end of it. However, if there is data for the tablix all works just fine including Excel. Any help with this would be greatly appreciated.


    I have tried to hide the rows themselves using the same conditions, however, I end up with the same results.
    Thursday, March 24, 2011 3:03 PM

Answers

  • Hi mcornejo_1,

    Apart from what Tony has suggested, See if this helps..

    The last balnk page really apperas based on the Page Break setting of First Tablix and Group.

    1) If your first tablix(or the tablix above can be hidden tablix) do not have groups, un-check  the "Add a page break after" from first tablix properties and to check "Add a page break before" for can be hidden tablix.

    2) If your first tablix(or the tablix above can be hidden tablix) have groups groups, un-check  the "Add a page break after" from first tablix properties and also uncheck "Also at end of group" in Page break tab of outermost group properties. Check "Add a page break before" for can be hidden tablix to get a page break.


    - Chintak (My Blog)

    • Marked as answer by mcornejo_1 Thursday, March 31, 2011 2:57 PM
    Thursday, March 31, 2011 6:44 AM

All replies

  • Hi mcornejo_1,

    Try setting ConsumeContainerWhiteSpace property to true in report property

    Thanks

    Kumar


    KG, MCTS
    Thursday, March 24, 2011 3:23 PM
  • Thank you but that did not work.
    Thursday, March 24, 2011 3:48 PM
  • Hi mcornejo_1,

    I can reproduce the scenario that when the Tablix is hidden it still leaves blank space in the report. In order to prevent the blank space, one possible is to nest the Tablix in another Tablix row. Please refer to the steps below:

    1.    Add a List control to the report.

    2.    Select the List, in the grouping pane, right click the (Details) item and select Delete Group. Click OK in the Delete Group dialog.

    3.    Right click the cell in the list, and select Delete to delete the nested rectangle.

    4.    Drag and drop the Tablix into the cell of the List.

    5.    Select the List, in the grouping pane, click the small triangle at the top-right corner and select Advance Mode.

    6.    Select the (Static) item in the Row Groups list, and then we can specify the Hidden property to an expression to control the visibility of the Tablix.

    Thanks,
    Tony Chain


    Tony Chain [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Thursday, March 31, 2011 6:19 AM
  • Hi mcornejo_1,

    Apart from what Tony has suggested, See if this helps..

    The last balnk page really apperas based on the Page Break setting of First Tablix and Group.

    1) If your first tablix(or the tablix above can be hidden tablix) do not have groups, un-check  the "Add a page break after" from first tablix properties and to check "Add a page break before" for can be hidden tablix.

    2) If your first tablix(or the tablix above can be hidden tablix) have groups groups, un-check  the "Add a page break after" from first tablix properties and also uncheck "Also at end of group" in Page break tab of outermost group properties. Check "Add a page break before" for can be hidden tablix to get a page break.


    - Chintak (My Blog)

    • Marked as answer by mcornejo_1 Thursday, March 31, 2011 2:57 PM
    Thursday, March 31, 2011 6:44 AM
  • I attempted both suggestions but was unable to get Tony's to work. However, Chintak's was easiest, fastest and worked like a charm. Thank you all for your help.
    Thursday, March 31, 2011 2:59 PM
  • Thank you so much! Finally someone who knows what they're talking about! I have been looking for this answer for 2 days now and if one more person told me to check my margins I was going to hunt them down! This worked perfectly, I can't believe with all the things I tried I didn't manage to find this, but sometimes you need somebody to bonk you on the nose with it. Thank you a thousand times! :)
    Wednesday, July 24, 2013 6:06 PM