none
Deployed Lightswitch web app errors

    Question

  • I am a relative newbie at this. I had a few programming classes in school but that was many years ago. I own a company and decided to use lightswitch to build a web app for inventory and job tracking in the field. The development went smooth enough. I decided to try out Azure for my deployment needs. Signed up for trial, created website, created database and published. Visual studios said publish was successful and opened azure in my browser. Tried to navigate to the website and it said "you do not have permission to view this directory.". Logged into ftp for error files error code 403.1. Not sure where to go from here
    Friday, July 26, 2013 5:04 PM

Answers

  • it seems like you are trying to do a directory listing (or atleast what seems to be happening)

    check if you have the default page set for your website (in your solution and on azure website in your dashboard, set the page correctly) and give it a try


    Please mark as answered if it helped Vishal Narayan Saxena http://twitter.com/vishalishere http://www.ogleogle.com/vishal/

    Friday, July 26, 2013 6:48 PM
  • this was also answered in an old forum post, and I was not wrong, putting the default page / document in your website settings should fix it


    Please mark as answered if it helped Vishal Narayan Saxena http://twitter.com/vishalishere http://www.ogleogle.com/vishal/

    Friday, July 26, 2013 6:51 PM

All replies

  • it seems like you are trying to do a directory listing (or atleast what seems to be happening)

    check if you have the default page set for your website (in your solution and on azure website in your dashboard, set the page correctly) and give it a try


    Please mark as answered if it helped Vishal Narayan Saxena http://twitter.com/vishalishere http://www.ogleogle.com/vishal/

    Friday, July 26, 2013 6:48 PM
  • this was also answered in an old forum post, and I was not wrong, putting the default page / document in your website settings should fix it


    Please mark as answered if it helped Vishal Narayan Saxena http://twitter.com/vishalishere http://www.ogleogle.com/vishal/

    Friday, July 26, 2013 6:51 PM
  • Ok I will try that out when I get home. Thank you for the responses. I apologize I think I glanced over that post but was to frustrated at the time to glean the information from it.
    Friday, July 26, 2013 7:02 PM
  • no worries, we all been there

    Please mark as answered if it helped Vishal Narayan Saxena http://twitter.com/vishalishere http://www.ogleogle.com/vishal/

    Friday, July 26, 2013 8:54 PM
  • if it worked for you, please mark my post as answered.

    -------------------------------


    Please mark as answered if it helped Vishal Narayan Saxena http://twitter.com/vishalishere http://www.ogleogle.com/vishal/

    Friday, August 02, 2013 10:53 PM