none
Credential Manager doesn't save credentials between sessions when on domain.

    Question

  • When connected to the 2003/2008 domain, Credentials manager on a Win7 Pro PC will not save passwords after logging off or restarting. Persistence is always set to Session. When off the domain, persistence is set to enterprise and credentials save properly. I have put my PC and my user in a Test OU that blocks inheritance and has an empty GPO enforced. GPRESULT shows no policies are applied - all domain policies are denied due to Blocked SOM. I did this thinking that by isolating my account/pc from the domain I could track down a GPO that was prevent Enterprise persistence. Why else would joining the domain cause Credential Manager not to save properly? Is there a workaround?
    Friday, September 06, 2013 11:41 PM

Answers

  • Ok well thanks for your help, but both of those settings were fine. I called Intermedia, the host of our Exchange Server, and they provided a SaveCredentials.exe that saves the Outlook passwords properly.
    • Marked as answer by Czczcz7 Wednesday, September 11, 2013 7:01 PM
    Wednesday, September 11, 2013 7:01 PM

All replies

  • Check these two links it has lot more useful infor regarding your issue.. 

    http://social.technet.microsoft.com/Forums/windows/en-US/4ea08328-01bd-4d22-8b89-ae0d9984baa4/credential-manager-error-in-windows-7

    http://www.gadgetgrill.com.au/2009/11/19/windows-7-fixing-the-mapped-drive-credentials-problem/

    -----------------------------------------------------------------------------------------------

    Hetti Arachchige V Aravinda | Microsoft Community Support | Windows Tech Information

    (B.Sc, Microsoft Small Business Specialist, Dip. in Network Administration, MCP, MCTS,

    MCSA, MCSE, MCITP, CCNA, MBCS)

    -----------------------------------------------------------------------------------------------

    Don't forget to mark this as  the answer if it helps to solve your problem and if it is helpful mark as helpful. 

    -----------------------------------------------------------------------------------------------


    Saturday, September 07, 2013 1:31 AM
  • Thank you but neither one of those links is helpful in this case. I don't receive any errors - credential manager just doesn't save credentials as persistent (for Outlook). When I am off the domain, then it does. Regardless, EFS is already off and  I deleted everything in C:\Documents and Settings\Your_User\AppData\Roaming\Microsoft\Protect\. Also, the second one is not a solution as going to each computer and manually adding email credentials is not a viable option.
    Monday, September 09, 2013 8:50 PM
  • Hi,

    There is an option preventing windows 7 clients from using Credentials Manager. So please check the option “Network access: Do not allow storage of passwords and credentials for network authentication” in GP editor.

    Also, please check if the following registry entry is set to 1.

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa

    Value Name: DisableDomainCreds

    Value Type: REG_DWORD

    Value: 1

    If it was, please delete the value.

    Wednesday, September 11, 2013 12:53 AM
  • Ok well thanks for your help, but both of those settings were fine. I called Intermedia, the host of our Exchange Server, and they provided a SaveCredentials.exe that saves the Outlook passwords properly.
    • Marked as answer by Czczcz7 Wednesday, September 11, 2013 7:01 PM
    Wednesday, September 11, 2013 7:01 PM