none
Temp Profile Problem. Windows 7, Domain

    Question

  • I have about 50 machines on domain with Windows 7 32bit OS.  We are having a problem with windows not grabbing our default profile for three of our users and instead giving them a Temp Profile every time they log into the domain.  One is a normal user account and two are admin.  All other users can log onto any computer at anytime and they do not get the temp profile.  The three accounts get the temp profile no matter which computer on the domain they choose to log in to.  Any ideas?
    Tuesday, January 07, 2014 2:11 PM

Answers

  • Yes - check for the registry key as you will need to remove it if one remains for this user;

    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    Find the one related to the account in question and remove it - try logging in again.

    Have you tested with another user on the same PC, who resides in the same OU within AD?

    Kind regards
    Barry


    • Marked as answer by Matt Sears Tuesday, January 07, 2014 8:09 PM
    Tuesday, January 07, 2014 4:40 PM
  • Have you delete the registry entries for the temp/normal profiles?

    Please do so and try again.

    • Marked as answer by Matt Sears Tuesday, January 07, 2014 8:09 PM
    Tuesday, January 07, 2014 4:29 PM
  • \SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList  I deleted the bad users and logged back in with them and now everything works.  Problem solved.  Thanks for the help.
    • Marked as answer by Matt Sears Wednesday, January 08, 2014 8:27 PM
    Tuesday, January 07, 2014 8:10 PM

All replies

  • This sounds like they have a corrupt roaming profile.
    Can you confirm whether they have roaming profiles within AD? This is on the 'Profile' tab of their account.

    If so, remove the profile path from their AD account, allow some time for replication then get them to log into a PC they have never logged into, or one you have removed their local profile.

    If this logs them in fine and creates a local profile instead of a TEMP profile, then this is the case.

    Rename/delete the folder of the roaming profile on the server and re-add the path into the AD account.

    Again - allow for replication and have the user log off (which will save changes up to the server).
    It may be worth having them log back in and out again to make sure the TEMP profile doesn't reoccur.

    It may also be worth clearing the local profiles from machines that they have logged into previously, to avoid the corruption copying back into their roaming profile.

    Remember when deleting local profiles on Win7 that you need to remove the appropriate reg entries if removing/renaming the folder manually - or use the built in function in 'Advanced system Settings' > 'User Profiles' in control panel.

    Kind Regards
    Barry

    Tuesday, January 07, 2014 3:52 PM
  • We do not have roaming profiles.  I have cleared them off of any machine they have logged in to.  These are brand new machines and the problem started from day 1.
    Tuesday, January 07, 2014 4:21 PM
  • Have you delete the registry entries for the temp/normal profiles?

    Please do so and try again.

    • Marked as answer by Matt Sears Tuesday, January 07, 2014 8:09 PM
    Tuesday, January 07, 2014 4:29 PM
  • Yes - check for the registry key as you will need to remove it if one remains for this user;

    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    Find the one related to the account in question and remove it - try logging in again.

    Have you tested with another user on the same PC, who resides in the same OU within AD?

    Kind regards
    Barry


    • Marked as answer by Matt Sears Tuesday, January 07, 2014 8:09 PM
    Tuesday, January 07, 2014 4:40 PM
  • I have tried many users on many machines, and it is only these three on any machine that doesn't work.  im looking into the registry now...
    Tuesday, January 07, 2014 6:06 PM
  • \SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList  I deleted the bad users and logged back in with them and now everything works.  Problem solved.  Thanks for the help.
    • Marked as answer by Matt Sears Wednesday, January 08, 2014 8:27 PM
    Tuesday, January 07, 2014 8:10 PM
  • Creating a default local profile for Windows 7

    1. Create a new standard local user account (named STDPROFILE), add this account to the local Administrators group on the PC.
    2. Reboot, then log onto the PC using the local user account from previous Step.
    3. Set up profile settings as desired; desktop icons, mapped printers, FRVIS physical/logical, IE home page, etc..
    4. Reboot when finished, log back onto PC with the local “Administrator” account.
    5. Double-click “Computer”, then click organize, folder and search options. On the view tab, make sure “show hidden files, folders and drives” is selected; also uncheck “Hide protected Operating System Files”. Click OK
    6. Under C:/Users, rename the hidden “Default” user folder (NOT “Default User”)
      1. Make copy of the profile (STDPROFILE) customized in Step 2, rename the folder “Default”.
      2. Right click the folder—under properties, then security tab—add “Everyone” permissions with Full Control (include all folders and subfolders).
    7. Run regedit.exe
    8. Click on HKEY-LOCAL-MACHINE. Under File, select “Load Hive”
    9. Browse to the “C:/Users/Default” folder, click on ntuser.dat (make sure hidden and system files are displayed). Name the key TEMPLATE_ACCOUNT.
      1. Right click on the TEMPLATE_ACCOUNT key, select Export, save the .reg file to the desktop.
        Open the .reg file with Notepad, and under “Edit—replace..” put the user name STDPROFILE in the “Find what” field, to be replace with the string %USERNAME% -- choose “Replace All” then save the .reg file. Double click it to re import the changes.
    10. Re-open regedit.exe
    11. Under TEMPLATE_ACCOUNT – Control Panel – desktop, change “Wallpaper” path to the wallpaper of your choice (a local OR network path will work here). Check other settings and modify any other keys.
    12. If RealPlayer is installed to the image—click on TEMPLATE_ACCOUNT—SOFTWARE—Realnetworks. Delete the entire RealNetworks Key. This key will recreate.
    13. When done, click on TEMPLATE_ACCOUNT. Then click File, select “unload hive”. This will save the changes you made.
    Wednesday, April 23, 2014 8:24 PM