none
SBS 2011 Standard - Exchange ActiveSync - Setup

    Question

  • Hi,

    Can anyone advise on the correct setup of Exchange ActiveSync in SBS 2011.

    I have Exchange setup so that I can access it from Outlook both on the internal network and via the remote.<domain>.  I can also access OWA without issue (again on the internal network and externally).

    The only thing that I don't have working is Exchange ActiveSync, which I want to use to connect mobile clients (Windows Phone 7, Apple iOS devices and Android devices).  The accounts that I want to connect mobile devices for are enabled for ActiveSync in the Exchange management console.  I'm not sure what additional configuration I need to do to get the mobile devices toconnect successfully.

    What I've tried so far:

    I've only tried configuring Windows Phone 7 clients so far.

    1. First of all I just entered the e-mail address/password for the account and had WP7 try to find the account details (which failed).
    2. I then had the opportunity to specify the (Windows) domain, which I entered, but again this failed.
    3. Finally I tried entering the fqdn (remote.<domainname>) which I use for SBS web access from the internet, but this also failed. 

    In each case I tried using the following username/password combinations:

    • Full e-mail address and password (firstname.lastname@domainname.com)
    • e-mail address without domain (firstname.lastname) and password
    • Windows username and password (I tried this both qualified by the domain name and 'plain')

    Since none of the above worked I assume I'm missing something (and given that I couldn't find any questions/answers about this by searching, I assume I'm missing the obvious).  I'd guess that I either need to enable something via the exchange management console, perhaps open additional firewall ports or configure another DNS record and setup a certificate (m.<domainname>?), but I'm really not sure.

    If anyone can advise on this, I'd be most greatful as mobile e-mail access is pretty vital.

    Thanks

    Monday, October 03, 2011 8:51 AM

Answers

  • It "just works" in SBS2011, with nothign to set up. You do need to use DOMAIN\Username for the login.

    Please try this website, which may help to diagnose your issue: https://www.testexchangeconnectivity.com/

     

    Jim

    • Marked as answer by Taligort Monday, October 03, 2011 9:37 AM
    Monday, October 03, 2011 8:59 AM
  • Hi,

    Like Jim said, ActiveSync will work out of the box when you installed your SBS server with the wizards.

    But if a mobile device will sync with the server depends on how the device works with certificates and if you use a third party trusted certificate (with this there will be no problem) or use the self-signed default certificate, some devices will work fine or you need to install the certificate on the phone and some will give you trouble with working with the self-signed certificate.

    Best practice would be to buy a public trusted certificate (for SBS this maybe a single domain certificate).

    Otherwise here is an article about WP7 with a self signed certificate: http://pocketnow.com/windows-phone/how-to-install-custom-ssl-certificates-on-wp7


    Regards Ronny
    -------------
    Visit my Blog or follow me on Twitter
    • Marked as answer by Taligort Monday, October 03, 2011 9:37 AM
    Monday, October 03, 2011 9:24 AM

All replies

  • It "just works" in SBS2011, with nothign to set up. You do need to use DOMAIN\Username for the login.

    Please try this website, which may help to diagnose your issue: https://www.testexchangeconnectivity.com/

     

    Jim

    • Marked as answer by Taligort Monday, October 03, 2011 9:37 AM
    Monday, October 03, 2011 8:59 AM
  • Hi,

    Like Jim said, ActiveSync will work out of the box when you installed your SBS server with the wizards.

    But if a mobile device will sync with the server depends on how the device works with certificates and if you use a third party trusted certificate (with this there will be no problem) or use the self-signed default certificate, some devices will work fine or you need to install the certificate on the phone and some will give you trouble with working with the self-signed certificate.

    Best practice would be to buy a public trusted certificate (for SBS this maybe a single domain certificate).

    Otherwise here is an article about WP7 with a self signed certificate: http://pocketnow.com/windows-phone/how-to-install-custom-ssl-certificates-on-wp7


    Regards Ronny
    -------------
    Visit my Blog or follow me on Twitter
    • Marked as answer by Taligort Monday, October 03, 2011 9:37 AM
    Monday, October 03, 2011 9:24 AM
  • Thanks for the quick responses.  It was me being a fool that was the cause of the problem :)

    Basically, the mobile data provider took a lot longer to recognise the DNS changes that I had made in moving our e-mail to an exchange server hosted on our own network, so the login simply wasn't getting through.

    I did get a third-party trusted certificate for this, so that didn't present problems (I just changed the DNS server settings to the public google ones for now and sync went through straight away then).

    Thanks again.

    Monday, October 03, 2011 9:40 AM