none
Connect Oracle DB with Excel 2013 64 bit - PowerPivot

    Question

  • Hi,

    I am using windows 8.1 pro version with excel 2013 64 bit. Trying to update data of a power pivot workbook I get a connection error to an Oracle data base: "OraOLEDB provider is not registered on the local machine".

    Under windows 8.1 pro with excel 2013 32 bit connection to the Oracle data base was running.

    Any suggestions to solve the excel 2013 64 bit connection problem? 

    Thanx in advance

    Chiemo

    Friday, June 06, 2014 3:22 PM

Answers

  • Hello Chiemo,

    if it works with Excel 32 bit, but not with Excel 64 bit, then because only the 32 bit Oracle data  provider is installed on your machine and the 64 bit provider is not installed; you always need a provider with matches the 32/64 bit architecture of the application which wants to use the provider. Install tze 64 bit provider, check the connections settings in PowerPivot, then it should work.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Friday, June 06, 2014 4:04 PM
    Answerer

All replies

  • Hello Chiemo,

    if it works with Excel 32 bit, but not with Excel 64 bit, then because only the 32 bit Oracle data  provider is installed on your machine and the 64 bit provider is not installed; you always need a provider with matches the 32/64 bit architecture of the application which wants to use the provider. Install tze 64 bit provider, check the connections settings in PowerPivot, then it should work.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Friday, June 06, 2014 4:04 PM
    Answerer
  • Hi Olaf,

    thank you for your prompt and correct answer and sorry that I come back to you only now.

    You are right. Basically, only the 64 bit provider had to be installed (Oracle Client 11 x64). Nevertheless, I had a hard time to make the oracle data base connection work for me. After installing the x64 client our network administrator had to change some settings due to an error message "listener did not get SERVICE_NAME in CONNECT_DATA". Unfortunately, I can not tell what settings were made by the admin.

    Thank you again for your help.

    Chiemo

    Thursday, July 03, 2014 4:20 PM