locked
SBS 2008 POP3 csatlakozó

    Question

  • Hello! 

    Az SBS konzolon be szerettem volna állítani, hogy az exchange töltse le magának a leveleket, külső pop3 fiókokból is, de valamiért nem működik neki. Erre azért lesz majd szükségünk, hogy miután átállunk a levelezéssel a saját szerverünkre, akkor is meglegyenek majd azok a levelek amiket a partnereink még véletlen a mostani, külsős szolgáltatónál lévő mailboxainkba küldenek. 
    Néztem a logokat, amiben látszik hogy a külsős szolgáltatóval felépül a kapcsolat, meg le is jönnek a levelek, csak épp a connector nem tudja belerakni a konzolon meghatározott belső mailboxba. Azt gondoltam elég lesz beállítani a konzolon a konnektort, de úgy tűnik, hogy az echange-en is kell bütykölni valamit, hogy hozzá tudjon férni a pop3 connector, csakhogy nemtudom mit kell ott beállítani. Ebben kérem a segítségeteket! 

    Az ide tartozó log: 

    [t 0] 03/12/10, 08:25:27: Beginning "Retrieve Now"... 
    [t 0] 03/12/10, 08:25:27: (AsyncConn[ pop3.stcable.net:110 ]) Connecting to 'pop3.stcable.net' on port 110. 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] +OK STcable mail ready. 
    [t 0] 03/12/10, 08:25:27: (POP3) [TX] USER sila.sind 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] +OK 
    [t 0] 03/12/10, 08:25:27: (POP3) [TX] PASS ************************ 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] +OK Logged in. 
    [t 0] 03/12/10, 08:25:27: (POP3) [TX] STAT 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] +OK 4 306996 
    [t 0] 03/12/10, 08:25:27: Check for new messages: 4 (299 KB) total. 
    [t 0] 03/12/10, 08:25:27: (AsyncConn[ localhost:25 ]) Connecting to 'localhost' on port 25. 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 220 SERVER.sila.local Microsoft ESMTP MAIL Service ready at Fri, 12 Mar 2010 08:25:26 +0100 
    [t 0] 03/12/10, 08:25:27: (SMTP) [TX] EHLO SERVER 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250-SERVER.sila.local Hello [127.0.0.1] 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250-SIZE 10485760 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250-PIPELINING 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250-DSN 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250-ENHANCEDSTATUSCODES 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250-AUTH 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250-8BITMIME 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250-BINARYMIME 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250 CHUNKING 
    [t 0] 03/12/10, 08:25:27: (POP3) [TX] LIST 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] +OK 4 messages: 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] 1 99290 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] 2 72153 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] 3 65594 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] 4 69959 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] . 
    [t 0] 03/12/10, 08:25:27: Downloading message 1 of 4. 
    [t 0] 03/12/10, 08:25:27: (POP3) [TX] RETR 1 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] +OK 99290 octets 
    [t 0] 03/12/10, 08:25:27: Sending message 1 to the SMTP recipient sila.sind@ad.sila.rs... 
    [t 0] 03/12/10, 08:25:27: (SMTP) [TX] MAIL FROM: <milan.strbac@voban.groupnbg.com> RET=FULL 
    [t 0] 03/12/10, 08:25:27: Downloading message 2 of 4. 
    [t 0] 03/12/10, 08:25:27: (POP3) [TX] RETR 2 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250 2.1.0 Sender OK 
    [t 0] 03/12/10, 08:25:27: (SMTP) [TX] RCPT TO: <sila.sind@ad.sila.rs> NOTIFY=FAILURE 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 250 2.1.5 Recipient OK 
    [t 0] 03/12/10, 08:25:27: (SMTP) [TX] DATA 
    [t 0] 03/12/10, 08:25:27: (SMTP) [RX] 354 Start mail input; end with <CRLF>.<CRLF> 
    [t 0] 03/12/10, 08:25:27: (POP3) [RX] +OK 72153 octets 
    [t 0] 03/12/10, 08:26:12: Timeout 'localhost' !!!! 
    [t 0] 03/12/10, 08:26:12: Failure hrResult (0x800ccc19) trying to deliver message id 1: 
    [t 0] 03/12/10, 08:26:12: (no server response) 
    [t 0] 03/12/10, 08:26:12: EVENT: The TCP/IP connection with the 'localhost' server was terminated while trying to access the '' mailbox. The cause may be server problems, network problems, a long period of inactivity, a connection time limit, or incorrect connection settings. 
    [t 0] 03/12/10, 08:26:12: (AsyncConn[ localhost:25 ]) Connection to 'localhost' closed. 
    [t 0] 03/12/10, 08:26:12: (POP3) [TX] QUIT 
    [t 0] 03/12/10, 08:26:12: (POP3) [RX] +OK Logging out. 
    [t 0] 03/12/10, 08:26:12: (AsyncConn[ pop3.stcable.net:110 ]) Connection to 'pop3.stcable.net' closed. 
    [t 0] 03/12/10, 08:26:12: "Retrieve Now" finished. 
    Friday, March 12, 2010 12:12 PM

All replies

  • Csak tipp: az a fiók, akinek akarod adni a letöltött leveleket, "normál" módon megkapja? Már van a postafiókjában levél?

    A.
    Friday, March 12, 2010 12:33 PM
  • Igen. A cimzett egy csoport, de szetdobta most minden csoporttagnak a levelet amit kuldtem a gmailrol. Tehat ez mukodik. Valamiert a hitelesitesen akadhat fent, de nem ertem hogy mit kellene valtoztatnom hogy mukodjon rendesen.

    Egyebkent ha ez megoldodik, mar most megvan a kovetkezo amivel szivni fogok... :D Merthogy a kliens geprol az outlook sem hajlando csatlakozni a szerverre. Akkor sem ha exchange szervert akarok beallitani, es akkor sem ha pop3 parametereket adok meg. A tesztelesnel a bejovo levelek kiszolgalojara nem tud csatlakozni, a levelkuldes viszont megy szepen.

    A levelkuldes smarthost-tal van megoldva az exchangen. Ami még talán probléma forrás lehet, hogy a hálózat nem domain rendszerben fut, hanem munkacsoport alapú, viszont a kliens gépre telepitve van szerver certificate. Ez abbol is latszik, hogy az internet explorer nem kiabal, ha megnyitom a bongeszoben a remote workplace oldalt: remote.sila.rs
    Ott egyebkent a webes feluleten megtudom nyitni a postafiokomat is es benne van minden level, meg a kuldes is mukodik. Nem is gondoltam, hogy a levelezo programra meg majd cirkuszolni fog.
    Friday, March 12, 2010 1:05 PM
  • Hello!

    Na a kliens geprol valo csatlakozas pop3-mal az megoldodott, viszont az meg mindig nem mukodik, hogy a console-ban beallitott kulsos pop3 fikokbol letoltse maganak az exchange a leveleket.

    Az elso reszre a megoldast a kovetkezo, interneten talalt bejegyzes nyujtotta:

    Exchange 2007: POP3 ERR Command is not valid in this state
    Summary: POP applications report ERR "Command is not valid in this state" after supplying credentials. To verify you try telnetting to POP port 110 of your CAS server:

    Telnet CASServer 110
    User Myaccount
    Pass Mypass
    ERR Command is not valid in this state


    Resolution: Open your Exchange Shell and enter:

    Set-PopSettings -LoginType PlainTextLogin

    Restart your POP3 service



    Forum bejegyzesek:

    7 COMMENTS:

      Anonymous said...
    I got this problem when I installed the RollUp 4 update.
    I tried changing login settings to plain text in the management console at first, however that didn't help.
    Following your instructions solved the problem. Thanks!

    3:29 AM
      nodlogin said...
    Worked like a charm. Thanks!!

    12:03 AM
      Basky said...
    But it will no more be a secured login..

    2:18 PM
      TravellerDan said...
    spot on

    2:07 AM
      Pragnesh said...
    You are star, worked.

    11:12 AM
      Anonymous said...
    Thanks for this info, I couldn't understand why this third party app would login to smtp fine but not pop3, your info sorted it.

    4:29 AM
      fiso said...
    thanks a mllion worked
    Monday, March 15, 2010 8:06 AM
  • Találtam a neten egy írást, képekkel ahol ugyanez volt a pop3 connectorral a probléma mint nálam is. Ott a megoldás az volt hogy elírták a külső pop3 fiók jelszavát, ami nálam kizárt, hisz a fenti log szövegéből is látszik, hogy a külső pop3-mal rendben van a csatlakozás. Szóval nekem ez a cikk sem tudott segíteni, de a képek miatt bemásolom ide a linket:


    Monday, March 15, 2010 10:37 AM
  • Nálad nincs semmi az eseménynaplóban?

    Kipróbálnám azt is, hogy nem egy csoportot, hanem adott felhasználót vennék fel, s annak a fiókját próbálnám letölteni pop3 segítségével.

    A.
    Tuesday, March 16, 2010 7:03 AM
  • De van nálam is bejegyzés az eseménynaplóban, de nekem nem túl beszédes:
    "A(z) 'localhost' kiszolgálóval fennálló TCP/IP-kapcsolat megszakadt, miközben a rendszer megpróbált hozzáférni a(z) 'alex@ad.sila.rs' postaládához. Ennek oka lehet a kiszolgáló vagy a hálózat problémája, hosszú idejű tétlenség, kapcsolódási időtúllépés vagy a kapcsolat hibás beállításai."

    Elég meredek nekem, hogy hálózati probléma miatt megszakadt a kapcsolat a localhosttal.... :D
    Egyszerűen a pop3 csatlakozó valamiért nem tud belépni a helyi pop3 fiókokba, ezt kellene valahol megengedni neki, de hogy hol az nekem még rejtély...

    Nem tudom mit kell a fiókon vagy akármin állítanom, hogy az sbs pop3 csatlakozó hozzá tudjon férni a fiókhoz. A csatlakozónál csak ki tudom választani a fiókot hogy hova menjenek a levelek és annyi. Semmi egyéb beállítás nincs ott, a külső pop3 fiók paraméterein kívül, de oda meg egyébként is sikeresen tud csatlakozni.

    Póbáltam már adott felhasználót is, próbáltam több különböző külső pop3 szolgáltatót, néztem a bejövő levelek méretét is, az sem nagy méretű.
    Tuesday, March 16, 2010 8:17 AM
  • "helyi pop3 fiókok"? Nem értem. Helyben sima fiókok vannak, az, hogy milyen módon érik el, bejövő levél szempontjából mindegy.

    Tehát ha közvetlenül küldesz pl. Alex-nek levelet, akkor megérkezik, csak a pop3 csatlakozóval letöltendők nem érkeznek meg? Próbáltad alex nevű külső pop3 fiókkal is?

    Ezt gondolom már nézted: http://www.netometer.com/video/tutorials/sbs-2008-pop-3-connector/

    A.
    Tuesday, March 16, 2010 8:25 AM
  • Rosszul írtam...helyik fiókról van szó természetesen. A pop3 csatlakozót ugyanazon a szerveren akarom megcsinálni amelyiken a fiókok is vannak (másképp ki sem birnám választani hogy melyik fiókba dobja a pop3 connector a levelet).

    Gmail -> alex@ad.sila.rs OK
    alex@ad.sila.rs -> Gmail OK
    alex@ad.sila.rs POP3 eléréssel OK

    tehát ezek mind mennek. A levél küldés is, a fogadás is, levelező programból, böngészőn keresztül is, minden dolgozik, egyedül a POP3 connectorral leszedett levelek nem kerülnek bele a postafiokokba. Minden más működik!

    A videót megtaláltam már én is, de nem birom megnézni mert nem vagyok regisztrálva, a tagságért meg fizetni kell, akkor meg gondoltam keresek máshol megoldást.
    Tuesday, March 16, 2010 10:23 AM
  • Amikor kézzel futtatam eddig az sbs konzolban lévő pop3 connectort, eddig minden alkalommal hibát jelzett ki, viszont ahogy nézem, néha 1-1 levél átcsusszant. Igaz, a rengeteg próbálkozáshoz képest nagyon kevés mail, úgyhogy megpróbálom ezt a connection time limitet feljebb rakni, hátha az segít.

    Egyébként az exchange konzolban: server config->hub transport->receive connectors opciónál is be kellene ezt valahogy állítani, hogy a szerver fogadjon levelet "saját magától" is. Ott is próbáltam a hitelesítésekkel játszadozni, de ha valaki tudna erről képet vagy leírást adni, hogy annak hogy is kell kinézni, akkor legalább ezt mint hibafforást ki tudnám zárni.

    Alapból volt egy connector itt a faxoknak, ami szintén localhostra volt állítva, azt módosítottam, de alapbeállítással sem ment, különben nem is módosítottam volna.

    Esetleg ha ezt a videot valaki fel tudja mashova tolteni azt megkoszonnem: http://www.netometer.com/video/tutorials/sbs-2008-pop-3-connector/
    Hátha tartalmaz olyasmit amit én nem csináltam meg és kellett volna.
    Tuesday, March 16, 2010 12:11 PM